aboutsummaryrefslogtreecommitdiffstats
path: root/www/middleman/Makefile
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2003-05-17 02:08:40 +0800
committerijliao <ijliao@FreeBSD.org>2003-05-17 02:08:40 +0800
commit57304643d3137a0cee7088ebd9ad1d5e306e6a22 (patch)
treee4353debc7bda63ca87afe23fa80af21de17defc /www/middleman/Makefile
parent5939aa7542b41b070b6747fb6921d477e2ddbb22 (diff)
downloadfreebsd-ports-gnome-57304643d3137a0cee7088ebd9ad1d5e306e6a22.tar.gz
freebsd-ports-gnome-57304643d3137a0cee7088ebd9ad1d5e306e6a22.tar.zst
freebsd-ports-gnome-57304643d3137a0cee7088ebd9ad1d5e306e6a22.zip
fix core dump
Reportted by: James Satterfield <james@uberduper.com> Submitted by: maintainer (with little modification)
Diffstat (limited to 'www/middleman/Makefile')
-rw-r--r--www/middleman/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/www/middleman/Makefile b/www/middleman/Makefile
index 0f2f40c48fab..212ca735b082 100644
--- a/www/middleman/Makefile
+++ b/www/middleman/Makefile
@@ -30,6 +30,9 @@ CONFIGURE_ARGS+= --enable-syslog
CONFIGURE_ARGS+= --enable-debug
.endif
+MMAN_CACHE= /var/cache/mman
+PLIST_SUB+= MMAN_CACHE=${MMAN_CACHE}
+
post-patch:
@${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g' ${WRKSRC}/configure
@${REINPLACE_CMD} -e 's|/usr/bin/mman|${PREFIX}/bin/mman|g' \
@@ -37,6 +40,7 @@ post-patch:
${WRKSRC}/scripts/mman.init
do-install:
+ @${MKDIR} ${MMAN_CACHE}
${INSTALL_PROGRAM} ${WRKSRC}/mman ${PREFIX}/bin
${INSTALL_DATA} ${WRKSRC}/config.xml ${PREFIX}/etc/mman.xml
${INSTALL_DATA} ${WRKSRC}/scripts/mman.init ${PREFIX}/etc/rc.d/mman.sh.sample