aboutsummaryrefslogtreecommitdiffstats
path: root/www/mimetex
diff options
context:
space:
mode:
authortota <tota@FreeBSD.org>2011-02-22 22:33:47 +0800
committertota <tota@FreeBSD.org>2011-02-22 22:33:47 +0800
commit3c1e7bae7f3bdb5b01665fadea3031a470033e9c (patch)
tree0dc153ccc61d4e5c584590d376984b9f556dc826 /www/mimetex
parent2f193d0c1ed51aa7c4d7ee6d5d97b3a59c84edb6 (diff)
downloadfreebsd-ports-gnome-3c1e7bae7f3bdb5b01665fadea3031a470033e9c.tar.gz
freebsd-ports-gnome-3c1e7bae7f3bdb5b01665fadea3031a470033e9c.tar.zst
freebsd-ports-gnome-3c1e7bae7f3bdb5b01665fadea3031a470033e9c.zip
- Use WWWDIR
- Use FETCH_ARGS instead of FETCH_CMD - Move pkg-message to files/pkg-message.in - Fix pkg-plist - Bump PORTREVISION RP: ports/153598 Submitted by: tota (myself) Approved by: maintainer timeout (> 7 weeks)
Diffstat (limited to 'www/mimetex')
-rw-r--r--www/mimetex/Makefile20
-rw-r--r--www/mimetex/files/pkg-message.in (renamed from www/mimetex/pkg-message)5
-rw-r--r--www/mimetex/pkg-plist10
3 files changed, 23 insertions, 12 deletions
diff --git a/www/mimetex/Makefile b/www/mimetex/Makefile
index 2bf5b8c265c5..dda7b2f3709f 100644
--- a/www/mimetex/Makefile
+++ b/www/mimetex/Makefile
@@ -7,7 +7,7 @@
PORTNAME= mimetex
PORTVERSION= 20080906.1.70
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= www math
MASTER_SITES= http://nivi.interfree.it/distfiles/${DIST_SUBDIR}/ \
http://www.forkosh.com/
@@ -23,17 +23,25 @@ USE_ZIP= yes
.include <bsd.port.pre.mk>
-FETCH_CMD= /usr/bin/fetch -rR # see PR bin/76134
+FETCH_ARGS= -rR # see PR bin/76134
LN_OPTS= -sf
-CGI_BIN= ${PREFIX}/www/cgi-bin/
+CGI_BIN= ${WWWDIR}/cgi-bin
CGI_PRG= ${PORTNAME}.cgi
-WWW_DIR= ${PREFIX}/www/data/mimetex/
+WWW_DIR= ${WWWDIR}/data
.if ${APACHE_VERSION} > 13
PLIST_DIRSTRY+= www/cgi-bin www/data
.endif
+PLIST_SUB= CGI_BIN="${CGI_BIN:S,^${PREFIX}/,,}" \
+ WWW_DIR="${WWW_DIR:S,^${PREFIX}/,,}"
+
+PORTDOCS= ${PORTNAME}.html
+
+SUB_FILES= pkg-message
+SUB_LIST= PORTDOCS=${PORTDOCS} WWW_DIR=${WWW_DIR}
+
# usefull if you run mimetex on another machine
.if defined(WITH_STATIC)
STATIC_MIMETEX= -static
@@ -57,9 +65,9 @@ do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${CGI_PRG} ${CGI_BIN}/${CGI_PRG}
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/${PORTNAME}.html ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${PORTDOCS} ${DOCSDIR}
${MKDIR} ${WWW_DIR}
- ${LN} ${LN_OPTS} ${DOCSDIR}/${PORTNAME}.html ${WWW_DIR}/index.html
+ ${LN} ${LN_OPTS} ${DOCSDIR}/${PORTDOCS} ${WWW_DIR}/index.html
post-install:
${CAT} ${PKGMESSAGE}
diff --git a/www/mimetex/pkg-message b/www/mimetex/files/pkg-message.in
index 98ccdbf1b073..ad7fc2c5d671 100644
--- a/www/mimetex/pkg-message
+++ b/www/mimetex/files/pkg-message.in
@@ -1,6 +1,9 @@
*********************************************************
- See online documentation at http://localhost/mimetex/
+ See online documentation at
+ %%DOCSDIR%%/%%PORTDOCS%%
+ or
+ %%WWW_DIR%%/index.html
*********************************************************
diff --git a/www/mimetex/pkg-plist b/www/mimetex/pkg-plist
index a8a645252c45..155953d95dbe 100644
--- a/www/mimetex/pkg-plist
+++ b/www/mimetex/pkg-plist
@@ -1,6 +1,6 @@
@comment $FreeBSD$
-%%PORTDOCS%%%%DOCSDIR%%/mimetex.html
-%%PORTDOCS%%www/data/mimetex/index.html
-www/cgi-bin/mimetex.cgi
-%%PORTDOCS%%@dirrm %%DOCSDIR%%
-%%PORTDOCS%%@dirrm www/data/mimetex
+%%PORTDOCS%%%%WWW_DIR%%/index.html
+%%CGI_BIN%%/mimetex.cgi
+@dirrm %%CGI_BIN%%
+%%PORTDOCS%%@dirrm %%WWW_DIR%%
+%%PORTDOCS%%@dirrm %%WWWDIR%%