aboutsummaryrefslogtreecommitdiffstats
path: root/www/mknmz-wwwoffle
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2004-05-05 22:41:53 +0800
committerpav <pav@FreeBSD.org>2004-05-05 22:41:53 +0800
commit9ca3e129ff213d5c80cbc785301b714d002fa2ec (patch)
treedd64a981dbbd58e19afacd9cb40858cf4cef5c07 /www/mknmz-wwwoffle
parentaea8f88512c4323acf4c703e38d967ee5cf528dc (diff)
downloadfreebsd-ports-gnome-9ca3e129ff213d5c80cbc785301b714d002fa2ec.tar.gz
freebsd-ports-gnome-9ca3e129ff213d5c80cbc785301b714d002fa2ec.tar.zst
freebsd-ports-gnome-9ca3e129ff213d5c80cbc785301b714d002fa2ec.zip
Add mknmz-wwwoffle, a tool which performs full-text search over the cache created by
WWWOFFLE, using full-text search system Namazu (http://www.namazu.org/). mknmz-wwwoffle adds a filter for mknmz which is used to generate index files for cache entries in WWWOFFLE. PR: ports/66168 Submitted by: Andrey Slusar <vasallia@ukr.net>
Diffstat (limited to 'www/mknmz-wwwoffle')
-rw-r--r--www/mknmz-wwwoffle/Makefile34
-rw-r--r--www/mknmz-wwwoffle/distinfo2
-rw-r--r--www/mknmz-wwwoffle/pkg-descr6
-rw-r--r--www/mknmz-wwwoffle/pkg-plist2
4 files changed, 44 insertions, 0 deletions
diff --git a/www/mknmz-wwwoffle/Makefile b/www/mknmz-wwwoffle/Makefile
new file mode 100644
index 000000000000..4b3daf4f999f
--- /dev/null
+++ b/www/mknmz-wwwoffle/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: mknmz-wwwoffle
+# Date created: 2 May 2004
+# Whom: Andrey Slusar <vasallia@ukr.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mknmz-wwwoffle
+PORTVERSION= 0.7.2
+CATEGORIES= databases www textproc
+MASTER_SITES= http://www.naney.org/comp/distrib/mknmz-wwwoffle/archive/
+
+MAINTAINER= vasallia@ukr.net
+COMMENT= WWWOFFLE cache indexer for full-text search system Namazu
+
+RUN_DEPENDS= ${LOCALBASE}/bin/wwwoffle:${PORTSDIR}/www/wwwoffle
+BUILD_DEPENDS= ${LOCALBASE}/bin/mknmz:${PORTSDIR}/databases/namazu2
+
+USE_PERL5= yes
+HAS_CONFIGURE= yes
+
+MAN1= mknmz-wwwoffle.1
+PORTDOCS= AUTHORS COPYING INSTALL INSTALL.ja NEWS README README.ja THANKS
+
+post-build:
+.if !defined(NOPORTDOCS)
+post-install:
+ ${MKDIR} ${DOCSDIR}
+.for a in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${a} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/www/mknmz-wwwoffle/distinfo b/www/mknmz-wwwoffle/distinfo
new file mode 100644
index 000000000000..31329bee6bb4
--- /dev/null
+++ b/www/mknmz-wwwoffle/distinfo
@@ -0,0 +1,2 @@
+MD5 (mknmz-wwwoffle-0.7.2.tar.gz) = 9258fa92d31d4894e898e61805d48d04
+SIZE (mknmz-wwwoffle-0.7.2.tar.gz) = 64070
diff --git a/www/mknmz-wwwoffle/pkg-descr b/www/mknmz-wwwoffle/pkg-descr
new file mode 100644
index 000000000000..9c4fb44cca65
--- /dev/null
+++ b/www/mknmz-wwwoffle/pkg-descr
@@ -0,0 +1,6 @@
+mknmz-wwwoffle performs full-text search over the cache created by WWWOFFLE,
+using full-text search system Namazu (http://www.namazu.org/). mknmz-wwwoffle
+adds a filter for mknmz which is used to generate index files for cache entries
+in WWWOFFLE.
+
+WWW: http://www.naney.org/comp/distrib/mknmz-wwwoffle/
diff --git a/www/mknmz-wwwoffle/pkg-plist b/www/mknmz-wwwoffle/pkg-plist
new file mode 100644
index 000000000000..3257cc53973b
--- /dev/null
+++ b/www/mknmz-wwwoffle/pkg-plist
@@ -0,0 +1,2 @@
+bin/mknmz-wwwoffle
+share/namazu/filter/wwwofflecache.pl