aboutsummaryrefslogtreecommitdiffstats
path: root/www/mod_accounting/Makefile
diff options
context:
space:
mode:
authorkrion <krion@FreeBSD.org>2003-07-30 18:29:50 +0800
committerkrion <krion@FreeBSD.org>2003-07-30 18:29:50 +0800
commit0abef68361769c86e77630f6b9d44b752f762791 (patch)
treec3697e13592b1b0edda814291e1a0e4e6723a845 /www/mod_accounting/Makefile
parentfcc994ecc4f3939d43736e59aef31b40a72d6936 (diff)
downloadfreebsd-ports-gnome-0abef68361769c86e77630f6b9d44b752f762791.tar.gz
freebsd-ports-gnome-0abef68361769c86e77630f6b9d44b752f762791.tar.zst
freebsd-ports-gnome-0abef68361769c86e77630f6b9d44b752f762791.zip
- update to cvs version
- fix typo PR: 55042 Submitted by: maintainer Approved by: fjoe (mentor) (implicit)
Diffstat (limited to 'www/mod_accounting/Makefile')
-rw-r--r--www/mod_accounting/Makefile11
1 files changed, 8 insertions, 3 deletions
diff --git a/www/mod_accounting/Makefile b/www/mod_accounting/Makefile
index d3d4a4a87c2c..7a90284ce4c8 100644
--- a/www/mod_accounting/Makefile
+++ b/www/mod_accounting/Makefile
@@ -7,10 +7,15 @@
PORTNAME= mod_accounting
PORTVERSION= 0.5
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= mod-acct
+PATCH_SITES= http://www.cultdeadsheep.org/FreeBSD/ports/download/distfiles/
+PATCHFILES= mod_accounting-patch-0.5_to_0.6-cvs.gz
+PATCH_DIST_STRIP=-p1
+
MAINTAINER= sheepkiller@cultdeadsheep.org
COMMENT= An Apache module that records traffic statistics into a database
@@ -38,7 +43,6 @@ MYSQL_VER= 41
MYSQL_VER= 323
.endif
-
.if defined(WITHOUT_PGSQL)
MAKE_ARGS+= WITHOUT_PGSQL=YES
.else
@@ -51,7 +55,7 @@ MAKE_ARGS+= WITHOUT_MYSQL=YES
LIB_DEPENDS+= mysqlclient.${MYSQL${MYSQL_VER}_LIBVER}:${PORTSDIR}/databases/mysql${MYSQL_VER}-client
.endif
-DOCS= README FAQ.txt LICENSE
+DOCS= README docs/FAQ.txt LICENSE
pre-everything::
@${ECHO} ""
@@ -63,11 +67,12 @@ pre-everything::
@${ECHO} ""
@${ECHO} " WITHOUT_MYSQL Disable MySQL support"
@${ECHO} " WITHOUT_PGSQL Disable PostgreSQL support"
+ @${ECHO} " WITHOUT_PLAINTEXT Disable file (plain text) support"
@${ECHO} ""
post-install:
@${MKDIR} ${PREFIX}/share/${PORTNAME}
- ${INSTALL_DATA} ${WRKSRC}/schema.sql ${PREFIX}/share/${PORTNAME}
+ ${INSTALL_DATA} ${WRKSRC}/docs/schema.sql ${PREFIX}/share/${PORTNAME}
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
.for doc in ${DOCS}