aboutsummaryrefslogtreecommitdiffstats
path: root/www/mod_auth_openid
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2008-08-17 14:27:23 +0800
committeredwin <edwin@FreeBSD.org>2008-08-17 14:27:23 +0800
commitd4efe8c2e4f40079c68da3479526de163adc645b (patch)
tree5e08b03f8a7dedada94e9b9490aa94ce2bcd0725 /www/mod_auth_openid
parent508e717aa0ad92192029f6eb83b10fd5a464e940 (diff)
downloadfreebsd-ports-gnome-d4efe8c2e4f40079c68da3479526de163adc645b.tar.gz
freebsd-ports-gnome-d4efe8c2e4f40079c68da3479526de163adc645b.tar.zst
freebsd-ports-gnome-d4efe8c2e4f40079c68da3479526de163adc645b.zip
New port: www/mod_auth_openid An authentication module for the
Apache 2 webserver with OpenID mod_auth_openid is an authentication module for the Apache 2 webserver. It handles the functions of an OpenID consumer as specified in the OpenID 2.0 specification. WWW: http://trac.butterfat.net/public/mod_auth_openid PR: ports/126218 Submitted by: Sutra Zhou <zhoushuqun@gmail.com>
Diffstat (limited to 'www/mod_auth_openid')
-rw-r--r--www/mod_auth_openid/Makefile29
-rw-r--r--www/mod_auth_openid/distinfo3
-rw-r--r--www/mod_auth_openid/pkg-deinstall57
-rw-r--r--www/mod_auth_openid/pkg-descr5
4 files changed, 94 insertions, 0 deletions
diff --git a/www/mod_auth_openid/Makefile b/www/mod_auth_openid/Makefile
new file mode 100644
index 000000000000..28fd4749a206
--- /dev/null
+++ b/www/mod_auth_openid/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: mod_auth_openid
+# Date created: 3 August 2008
+# Whom: Sutra Zhou <zhoushuqun@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mod_auth_openid
+PORTVERSION= 0.3
+CATEGORIES= www
+MASTER_SITES= http://butterfat.net/releases/mod_auth_openid/
+
+MAINTAINER= zhoushuqun@gmail.com
+COMMENT= An authentication module for the Apache 2 webserver with OpenID
+
+BUILD_DEPENDS= apr-1-config:${PORTSDIR}/devel/apr
+LIB_DEPENDS= opkele:${PORTSDIR}/devel/libopkele \
+ sqlite3:${PORTSDIR}/databases/sqlite34
+
+PLIST_FILES= ${APACHEMODDIR}/mod_auth_openid.so
+
+USE_APACHE= 2.0+
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-pcre=${LOCALBASE}
+
+CFLAGS+= -I${LOCALBASE}/include
+
+.include <bsd.port.mk>
diff --git a/www/mod_auth_openid/distinfo b/www/mod_auth_openid/distinfo
new file mode 100644
index 000000000000..52191c967bc3
--- /dev/null
+++ b/www/mod_auth_openid/distinfo
@@ -0,0 +1,3 @@
+MD5 (mod_auth_openid-0.3.tar.gz) = 6467856c05662eb6f1c24cbf7057a21b
+SHA256 (mod_auth_openid-0.3.tar.gz) = 99476b7984214c0a01d124a654f9f5a2b9c77dab5d5d1f719c448a6f77038295
+SIZE (mod_auth_openid-0.3.tar.gz) = 336753
diff --git a/www/mod_auth_openid/pkg-deinstall b/www/mod_auth_openid/pkg-deinstall
new file mode 100644
index 000000000000..0fa1787dfa1d
--- /dev/null
+++ b/www/mod_auth_openid/pkg-deinstall
@@ -0,0 +1,57 @@
+#!/bin/sh
+#
+# Try to de-activate authopenid_module in the installed httpd.conf and warn
+# if this fails.
+#
+# $FreeBSD$
+#
+
+if [ "$2" != "POST-DEINSTALL" ]; then
+ exit 0
+fi
+
+TMPDIR=${TMPDIR:=/tmp}
+PKG_TMPDIR=${PKG_TMPDIR:=${TMPDIR}}
+
+apxscmd=${PKG_PREFIX}/sbin/apxs
+tmpdir=${PKG_TMPDIR}/deinstmod_dav_svn.$$
+
+if [ ! -x ${apxscmd} ]; then
+ echo Can\'t find the apxs program: ${apxscmd}.
+ exit 1
+fi
+
+confdir=`${apxscmd} -q SYSCONFDIR`
+
+if [ ! -d ${confdir} ]; then
+ echo Can\'t find Apache conf dir: ${confdir}
+ exit 1
+fi
+
+if [ -f ${confdir}/httpd.conf ]; then
+ conffile=httpd.conf
+fi
+if [ -f ${confdir}/httpd.conf.default ]; then
+ conffile="${conffile} httpd.conf.default"
+fi
+if [ -z "${conffile}" ]; then
+ echo Can\'t find either of ${confdir}/httpd.conf or
+ echo ${confdir}/httpd.conf.default.
+ exit 1
+fi
+
+if ! mkdir ${tmpdir}; then
+ echo Can\'t create temporary directory: ${tmpdir}
+ exit 1
+fi
+
+for i in ${conffile}; do
+ awk '{if (!/^LoadModule authopenid_module/) \
+ print $0}' < ${confdir}/$i > ${tmpdir}/$i
+ echo Removing authopenid_module from $i in config dir: ${confdir}
+ cat ${tmpdir}/$i > ${confdir}/$i
+done
+
+rm -rf ${tmpdir}
+
+exit 0
diff --git a/www/mod_auth_openid/pkg-descr b/www/mod_auth_openid/pkg-descr
new file mode 100644
index 000000000000..5bf25b1fafa0
--- /dev/null
+++ b/www/mod_auth_openid/pkg-descr
@@ -0,0 +1,5 @@
+mod_auth_openid is an authentication module for the Apache 2 webserver.
+It handles the functions of an OpenID consumer as specified in the OpenID
+2.0 specification.
+
+WWW: http://trac.butterfat.net/public/mod_auth_openid