aboutsummaryrefslogtreecommitdiffstats
path: root/www/mod_clamav
diff options
context:
space:
mode:
authorclement <clement@FreeBSD.org>2004-04-22 04:39:23 +0800
committerclement <clement@FreeBSD.org>2004-04-22 04:39:23 +0800
commit819e3385ab110cdbf7929b0e2e354307471ea80f (patch)
tree5bf816ef02a1ebd706152a6a57810fb32a681f09 /www/mod_clamav
parent19f5bcd89e08fae4fd4dd8468373375ef208de4f (diff)
downloadfreebsd-ports-gnome-819e3385ab110cdbf7929b0e2e354307471ea80f.tar.gz
freebsd-ports-gnome-819e3385ab110cdbf7929b0e2e354307471ea80f.tar.zst
freebsd-ports-gnome-819e3385ab110cdbf7929b0e2e354307471ea80f.zip
- Fix build on 4.x
Approved by: maintainer, portmgr (marcus)
Diffstat (limited to 'www/mod_clamav')
-rw-r--r--www/mod_clamav/Makefile8
-rw-r--r--www/mod_clamav/files/patch-mod_clamav.c19
2 files changed, 25 insertions, 2 deletions
diff --git a/www/mod_clamav/Makefile b/www/mod_clamav/Makefile
index 1eeafbf9eef9..a337dc39518b 100644
--- a/www/mod_clamav/Makefile
+++ b/www/mod_clamav/Makefile
@@ -28,8 +28,12 @@ CLAMAV_PORT= security/clamav
CONFIGURE_ARGS= --with-apxs=${PREFIX}/sbin/apxs \
--libdir=${PREFIX}/lib/apache2
CFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
-CONFIGURE_ENV+= LDFLAGS="${LDFLAGS}"
+CPPFLAGS+= -I${LOCALBASE}/include \
+ ${PTHREAD_CFLAGS}
+LDFLAGS+= -L${LOCALBASE}/lib \
+ ${PTHREAD_LIBS}
+CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS}" \
+ LDFLAGS="${LDFLAGS}"
post-install:
@${CAT} ${PKGMESSAGE}
diff --git a/www/mod_clamav/files/patch-mod_clamav.c b/www/mod_clamav/files/patch-mod_clamav.c
new file mode 100644
index 000000000000..cf2ec9f46cde
--- /dev/null
+++ b/www/mod_clamav/files/patch-mod_clamav.c
@@ -0,0 +1,19 @@
+--- mod_clamav.c.orig Wed Apr 21 18:29:42 2004
++++ mod_clamav.c Wed Apr 21 18:30:07 2004
+@@ -310,6 +310,7 @@
+ int rc = 1, i, l;
+ char *ct;
+ const char *action;
++ clamav_safeuri *p;
+
+ /* requests with only headers can be bypassed */
+ if (f->r->header_only) {
+@@ -339,7 +340,7 @@
+ }
+
+ /* check safe uri */
+- clamav_safeuri *p = (clamav_safeuri *)(rec->safeuris->elts);
++ p = (clamav_safeuri *)(rec->safeuris->elts);
+ for (i = 0; i < rec->safeuris->nelts; i++) {
+ switch (p[i].matchtype) {
+ case MATCH_SAFE_URI: