aboutsummaryrefslogtreecommitdiffstats
path: root/www/mod_dtcl
diff options
context:
space:
mode:
authormi <mi@FreeBSD.org>2009-06-14 04:11:34 +0800
committermi <mi@FreeBSD.org>2009-06-14 04:11:34 +0800
commit27655390c41a167e8265059a1e1829634ca6b066 (patch)
tree930823fa68529d20b5fedf401044112ed83dba57 /www/mod_dtcl
parent2a1043d1666ec404002ff2a4e8a2eac8663872ce (diff)
downloadfreebsd-ports-gnome-27655390c41a167e8265059a1e1829634ca6b066.tar.gz
freebsd-ports-gnome-27655390c41a167e8265059a1e1829634ca6b066.tar.zst
freebsd-ports-gnome-27655390c41a167e8265059a1e1829634ca6b066.zip
Add a hunk to fix a 32-bit-specific warning. Unbreak.
Reported by: erwin, pav
Diffstat (limited to 'www/mod_dtcl')
-rw-r--r--www/mod_dtcl/Makefile2
-rw-r--r--www/mod_dtcl/files/patch-warning8
2 files changed, 8 insertions, 2 deletions
diff --git a/www/mod_dtcl/Makefile b/www/mod_dtcl/Makefile
index 512195809abc..3b34e39e1dc4 100644
--- a/www/mod_dtcl/Makefile
+++ b/www/mod_dtcl/Makefile
@@ -18,8 +18,6 @@ BUILD_DEPENDS= ${APXS}:${PORTSDIR}/${APACHE_PORT}
USE_TCL= yes
USE_TCL_BUILD= yes
-BROKEN= does not build
-
WRKSRC= ${WRKDIR}/mod_dtcl
MAKEFILE= ${FILESDIR}/Makefile.bsd
USE_APACHE= 1.3
diff --git a/www/mod_dtcl/files/patch-warning b/www/mod_dtcl/files/patch-warning
index 0b0341eaa3f1..9850ab02baa3 100644
--- a/www/mod_dtcl/files/patch-warning
+++ b/www/mod_dtcl/files/patch-warning
@@ -31,6 +31,14 @@
+ print_error(r, 0, Tcl_GetVar(interp, "errorInfo", 0));
print_error(r, 1, "<p><b>OUTPUT BUFFER:</b></p>");
print_error(r, 0, Tcl_GetStringFromObj(outbuf, (int *)NULL));
+@@ -382,5 +381,6 @@
+ {
+ hashKey = ap_psprintf(r->pool, "%s%lx%lx%d", filename,
+- mtime, ctime, toplevel);
++ (unsigned long)mtime, (unsigned long)ctime,
++ toplevel);
+ entry = Tcl_CreateHashEntry(dsc->objCache, hashKey, &isNew);
+ }
--- channel.c 2001-09-05 08:01:22.000000000 -0400
+++ channel.c 2009-04-11 23:03:43.000000000 -0400
@@ -19,5 +19,6 @@