aboutsummaryrefslogtreecommitdiffstats
path: root/www/mod_encoding
diff options
context:
space:
mode:
authorohauer <ohauer@FreeBSD.org>2014-04-28 17:57:02 +0800
committerohauer <ohauer@FreeBSD.org>2014-04-28 17:57:02 +0800
commit39d4b3400a95c22ec37d7dedc201fedb4fd9cb25 (patch)
treefbada8832eaa4d76a6ef2a5ba9723a652f36cfe9 /www/mod_encoding
parent0f6cb96a112ef3ca2c2d17171b3569b3d0c4703d (diff)
downloadfreebsd-ports-gnome-39d4b3400a95c22ec37d7dedc201fedb4fd9cb25.tar.gz
freebsd-ports-gnome-39d4b3400a95c22ec37d7dedc201fedb4fd9cb25.tar.zst
freebsd-ports-gnome-39d4b3400a95c22ec37d7dedc201fedb4fd9cb25.zip
- add stage support
- use pkg-plist
Diffstat (limited to 'www/mod_encoding')
-rw-r--r--www/mod_encoding/Makefile16
-rw-r--r--www/mod_encoding/pkg-plist4
2 files changed, 12 insertions, 8 deletions
diff --git a/www/mod_encoding/Makefile b/www/mod_encoding/Makefile
index 16a96592dc60..bd79bea48588 100644
--- a/www/mod_encoding/Makefile
+++ b/www/mod_encoding/Makefile
@@ -3,7 +3,7 @@
PORTNAME= mod_encoding
PORTVERSION= 20021209
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= www
MASTER_SITES= http://webdav.todo.gr.jp/download/
PKGNAMEPREFIX= ${APACHE_PKGNAMEPREFIX}
@@ -11,10 +11,7 @@ PKGNAMEPREFIX= ${APACHE_PKGNAMEPREFIX}
MAINTAINER= apache@FreeBSD.org
COMMENT= Apache module for non-ASCII filename interoperability
-
-# This port will work with the following version of Apache and anything newer.
-# Mostly because of the dependency of mod_dav.
-#APACHE_VERSION= 1.3.6
+LICENSE= APACHE11
USE_APACHE= 22+
USES= iconv gmake
@@ -32,8 +29,6 @@ CONFIGURE_ENV= LIBS='-L${LOCALBASE}/lib' \
PATH="${PREFIX}/bin:${PREFIX}/sbin:${PATH}"
CPPFLAGS+= -I${APACHEINCLUDEDIR} -I${LOCALBASE}/include
-PLIST_FILES= ${APACHEMODDIR}/mod_encoding.so
-
EXTRA_PATCHES= ${PATCHDIR}/apache22_patch
.if !defined(WITHOUT_ICONV_FIX)
@@ -44,5 +39,10 @@ EXTRA_PATCHES+= ${PATCHDIR}/iconv_hook-20040430.patch
EXTRA_PATCHES+= ${PATCHDIR}/queryfix-patch22
.endif
-NO_STAGE= yes
+do-install:
+ @${MKDIR} ${STAGEDIR}${PREFIX}/${APACHEMODDIR}
+ $(APXS) -S LIBEXECDIR=${STAGEDIR}${PREFIX}/${APACHEMODDIR} \
+ -i -n ${MODULENAME} ${WRKSRC}/${MODULENAME}.la
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/${APACHEMODDIR}/${MODULENAME}.so
+
.include <bsd.port.mk>
diff --git a/www/mod_encoding/pkg-plist b/www/mod_encoding/pkg-plist
new file mode 100644
index 000000000000..f621973725bc
--- /dev/null
+++ b/www/mod_encoding/pkg-plist
@@ -0,0 +1,4 @@
+@unexec /usr/bin/sed -i '' -E '/LoadModule[[:blank:]]+%%AP_NAME%%_module/d' %D/%%APACHEETCDIR%%/httpd.conf
+%%APACHEMODDIR%%/%%AP_MODULE%%
+@exec %D/sbin/apxs -e %%AP_MOD_EN%% -n %%AP_NAME%% %D/%F
+@unexec echo "Don't forget to remove all mod_encoding-related directives in your httpd.conf"