aboutsummaryrefslogtreecommitdiffstats
path: root/www/mod_evasive
diff options
context:
space:
mode:
authorohauer <ohauer@FreeBSD.org>2013-12-16 06:11:20 +0800
committerohauer <ohauer@FreeBSD.org>2013-12-16 06:11:20 +0800
commit5550b7ffd82b6ef9b5c833ae012ffb2e3589c786 (patch)
tree04a297afc1f15cc989bfa9a4b4fac1df43caa203 /www/mod_evasive
parent421b9565c6097dd51d21c912380898ffa548a7aa (diff)
downloadfreebsd-ports-gnome-5550b7ffd82b6ef9b5c833ae012ffb2e3589c786.tar.gz
freebsd-ports-gnome-5550b7ffd82b6ef9b5c833ae012ffb2e3589c786.tar.zst
freebsd-ports-gnome-5550b7ffd82b6ef9b5c833ae012ffb2e3589c786.zip
- add stage support
- add license - minor cleanups with hat apache@
Diffstat (limited to 'www/mod_evasive')
-rw-r--r--www/mod_evasive/Makefile23
1 files changed, 8 insertions, 15 deletions
diff --git a/www/mod_evasive/Makefile b/www/mod_evasive/Makefile
index af70d80168d3..635b0e3e7e17 100644
--- a/www/mod_evasive/Makefile
+++ b/www/mod_evasive/Makefile
@@ -10,33 +10,26 @@ DISTNAME= mod_evasive_${PORTVERSION}
DIST_SUBDIR= apache2
MAINTAINER= kiwi@oav.net
-COMMENT= An Apache module to try to protect the HTTP Server from DoS/DDoS attacks
+COMMENT= Apache module to try to protect the HTTP Server from DoS/DDoS attacks
+LICENSE= GPLv2
WRKSRC= ${WRKDIR}/${PORTNAME}
USE_APACHE= 22
AP_FAST_BUILD= yes
AP_GENPLIST= yes
-
-PORTDOCS= LICENSE README test.pl
-
-NO_STAGE= yes
-.include <bsd.port.pre.mk>
-
MODULENAME= ${PORTNAME}20
+PORTDOCS= README test.pl
+
post-patch:
@${REINPLACE_CMD} -e "s|/bin/mail|/usr/bin/mail|g" \
${WRKSRC}/mod_evasive.c ${WRKSRC}/mod_evasive20.c \
${WRKSRC}/mod_evasiveNSAPI.c
post-install:
-.if !defined (NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
-. for f in ${PORTDOCS}
- @${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
-. endfor
-.endif
-
-.include <bsd.port.post.mk>
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ @${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
+
+.include <bsd.port.mk>