aboutsummaryrefslogtreecommitdiffstats
path: root/www/mod_geoip2/Makefile
diff options
context:
space:
mode:
authorjylefort <jylefort@FreeBSD.org>2005-10-02 23:47:43 +0800
committerjylefort <jylefort@FreeBSD.org>2005-10-02 23:47:43 +0800
commit4d738b2ec5440c3724f7e5c8bb6d35945de1aa73 (patch)
tree6afd021ffe3fe364d4d78e2ace0fadecb514c531 /www/mod_geoip2/Makefile
parentb89dba1ba4a6c7b74bd7d2985e7bc99b8382d9c4 (diff)
downloadfreebsd-ports-gnome-4d738b2ec5440c3724f7e5c8bb6d35945de1aa73.tar.gz
freebsd-ports-gnome-4d738b2ec5440c3724f7e5c8bb6d35945de1aa73.tar.zst
freebsd-ports-gnome-4d738b2ec5440c3724f7e5c8bb6d35945de1aa73.zip
Add mod_geoip2.
mod_geoip2 is an Apache2 module that looks up the country code for the IP address making the request without using reverse DNS. WWW: http://www.maxmind.com/app/mod_geoip PR: ports/86777 Submitted by: Jukka A. Ukkonen <jau@iki.fi>
Diffstat (limited to 'www/mod_geoip2/Makefile')
-rw-r--r--www/mod_geoip2/Makefile39
1 files changed, 39 insertions, 0 deletions
diff --git a/www/mod_geoip2/Makefile b/www/mod_geoip2/Makefile
new file mode 100644
index 000000000000..9d27bad49d7e
--- /dev/null
+++ b/www/mod_geoip2/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: mod_geoip2
+# Date created: 26 Aug 2005
+# Whom: Jukka A. Ukkonen <jau@iki.fi>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mod_geoip2
+PORTVERSION= 1.1.7
+CATEGORIES= www
+MASTER_SITES= http://www.maxmind.com/download/geoip/api/mod_geoip2/
+DISTNAME= ${PORTNAME}_${PORTVERSION}
+
+MAINTAINER= jau@iki.fi
+COMMENT= An Apache module that provides the country code of the client's IP
+
+LIB_DEPENDS= GeoIP.4:${PORTSDIR}/net/GeoIP
+
+CONFLICTS= mod_geoip-[0-9]*
+
+USE_APACHE= yes
+WITH_APACHE2= yes
+
+SUB_FILES= pkg-message
+PORTDOCS= Changes INSTALL README README.php
+
+do-build:
+ @cd ${WRKSRC} && \
+ ${APXS} -c -L${LOCALBASE}/lib -I${LOCALBASE}/include -lGeoIP mod_geoip.c
+
+do-install:
+ ${APXS} -i -A -n geoip ${WRKSRC}/.libs/mod_geoip.so
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
+.endif
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>