aboutsummaryrefslogtreecommitdiffstats
path: root/www/mod_http2-devel
diff options
context:
space:
mode:
authorbrnrd <brnrd@FreeBSD.org>2016-03-02 04:25:40 +0800
committerbrnrd <brnrd@FreeBSD.org>2016-03-02 04:25:40 +0800
commit5dbfa8648e08725890fbe0e141b2d2d37d34421e (patch)
tree54e92df3403d23aa568f2532bf418b736d988800 /www/mod_http2-devel
parent3fd79b390c93ee941f615aaa0ad773d70c45b1a8 (diff)
downloadfreebsd-ports-gnome-5dbfa8648e08725890fbe0e141b2d2d37d34421e.tar.gz
freebsd-ports-gnome-5dbfa8648e08725890fbe0e141b2d2d37d34421e.tar.zst
freebsd-ports-gnome-5dbfa8648e08725890fbe0e141b2d2d37d34421e.zip
www/mod_http2-devel: Fix build on i386
- Fix apr_uint64_t format error on i386 - Fix pre-processor error in configure Reviewed by: feld (mentor) Approved by: feld (mentor) Differential Revision: D5506
Diffstat (limited to 'www/mod_http2-devel')
-rw-r--r--www/mod_http2-devel/Makefile2
-rw-r--r--www/mod_http2-devel/files/patch-mod__http2_h2__push.c14
2 files changed, 16 insertions, 0 deletions
diff --git a/www/mod_http2-devel/Makefile b/www/mod_http2-devel/Makefile
index 1aa77701afc4..b14c3cee835b 100644
--- a/www/mod_http2-devel/Makefile
+++ b/www/mod_http2-devel/Makefile
@@ -3,6 +3,7 @@
PORTNAME= mod_http2-devel
PORTVERSION= 1.2.7
+PORTREVISION= 1
DISTVERSIONPREFIX= v
CATEGORIES= www
@@ -27,6 +28,7 @@ USE_APACHE= 24+
MODULENAME= ${GH_PROJECT}
CFLAGS+= -I${LOCALBASE}/include
+CPPFLAGS+= -I${LOCALBASE}/include
post-install:
# Rename mod_http2 to the mod_h2 to avoid conflict with Apache24
diff --git a/www/mod_http2-devel/files/patch-mod__http2_h2__push.c b/www/mod_http2-devel/files/patch-mod__http2_h2__push.c
new file mode 100644
index 000000000000..7cb42853698c
--- /dev/null
+++ b/www/mod_http2-devel/files/patch-mod__http2_h2__push.c
@@ -0,0 +1,14 @@
+Upstream fix for i386 build
+https://github.com/icing/mod_h2/pull/89
+
+--- mod_http2/h2_push.c.orig 2016-02-29 13:59:13 UTC
++++ mod_http2/h2_push.c
+@@ -792,7 +792,7 @@ static apr_status_t gset_encode_next(gse
+ flex_bits = (delta >> encoder->fixed_bits);
+ ap_log_perror(APLOG_MARK, GCSLOG_LEVEL, 0, encoder->pool,
+ "h2_push_diary_enc: val=%"APR_UINT64_T_HEX_FMT", delta=%"
+- APR_UINT64_T_HEX_FMT" flex_bits=%ld, "
++ APR_UINT64_T_HEX_FMT" flex_bits=%"APR_UINT64_T_FMT", "
+ "fixed_bits=%d, fixed_val=%"APR_UINT64_T_HEX_FMT,
+ pval, delta, flex_bits, encoder->fixed_bits, delta&encoder->fixed_mask);
+ for (; flex_bits != 0; --flex_bits) {