aboutsummaryrefslogtreecommitdiffstats
path: root/www/mod_musicindex
diff options
context:
space:
mode:
authorohauer <ohauer@FreeBSD.org>2012-07-27 06:20:34 +0800
committerohauer <ohauer@FreeBSD.org>2012-07-27 06:20:34 +0800
commit1a8fb9b6b11562deb2a1760080ac4c9cbc8ef3d7 (patch)
tree493b4b25f9a56d56218b41dfa37cea83c63e61b1 /www/mod_musicindex
parentb005e55e60859c2b74231d1de7946cb7c1365318 (diff)
downloadfreebsd-ports-gnome-1a8fb9b6b11562deb2a1760080ac4c9cbc8ef3d7.tar.gz
freebsd-ports-gnome-1a8fb9b6b11562deb2a1760080ac4c9cbc8ef3d7.tar.zst
freebsd-ports-gnome-1a8fb9b6b11562deb2a1760080ac4c9cbc8ef3d7.zip
- fix support for non default options
with options NG and usage of APACHE_PKGNAMEPREFIX bsd.port.pre.mk has to be included before OPTIONS else OPTIONFILE points a non existing location and additional options are ignored no version bump, it affects only non default options
Diffstat (limited to 'www/mod_musicindex')
-rw-r--r--www/mod_musicindex/Makefile8
1 files changed, 5 insertions, 3 deletions
diff --git a/www/mod_musicindex/Makefile b/www/mod_musicindex/Makefile
index ca421a62fe7f..fa9aa65158cf 100644
--- a/www/mod_musicindex/Makefile
+++ b/www/mod_musicindex/Makefile
@@ -16,6 +16,10 @@ COMMENT= Apache module that allows downloading and streaming of audio
LICENSE= LGPL21
+USE_APACHE= 20+
+
+.include <bsd.port.pre.mk>
+
OPTIONS_DEFINE= NLS FLAC MP3 MP4 VORBIS LIBARCHIVE FILECACHE MYSQLCACHE
OPTIONS_DEFAULT=NLS MP3 LIBARCHIVE FILECACHE
@@ -27,8 +31,6 @@ MYSQLCACHE_DESC= MySQL caching support
MAKE_JOBS_SAFE= yes
-USE_APACHE= 20+
-
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
@@ -119,4 +121,4 @@ post-install:
@${CAT} ${PKGMESSAGE}
@${ECHO_MSG} ""
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>