aboutsummaryrefslogtreecommitdiffstats
path: root/www/mod_ntlm
diff options
context:
space:
mode:
authorskv <skv@FreeBSD.org>2007-12-13 07:29:17 +0800
committerskv <skv@FreeBSD.org>2007-12-13 07:29:17 +0800
commit8e5e1ec1494b90a1f70e95211cc7f5b2b42a8145 (patch)
tree3bd11e5755bc2ca763de33caa369c93b2eaa0488 /www/mod_ntlm
parentda4f823f1971c6e0a4bab59d0c15f42613ed99d8 (diff)
downloadfreebsd-ports-gnome-8e5e1ec1494b90a1f70e95211cc7f5b2b42a8145.tar.gz
freebsd-ports-gnome-8e5e1ec1494b90a1f70e95211cc7f5b2b42a8145.tar.zst
freebsd-ports-gnome-8e5e1ec1494b90a1f70e95211cc7f5b2b42a8145.zip
Unbreak build with GCC 4.2
PR: ports/117540 Submitted by: pluknet xx gmail.com
Diffstat (limited to 'www/mod_ntlm')
-rw-r--r--www/mod_ntlm/Makefile11
1 files changed, 5 insertions, 6 deletions
diff --git a/www/mod_ntlm/Makefile b/www/mod_ntlm/Makefile
index 01209739c4c1..d1f1b4249dd5 100644
--- a/www/mod_ntlm/Makefile
+++ b/www/mod_ntlm/Makefile
@@ -17,12 +17,17 @@ COMMENT= NTLM authentication module for the Apache webserver
USE_APACHE= YES
MAKE_ENV= APXS=${APXS}
+.include <bsd.port.pre.mk>
+
post-patch:
${FIND} ${WRKSRC}/smbval -name "*.inc.c" -type f|${XARGS} \
${REINPLACE_CMD} -e "s/malloc.h/stdlib.h/g"
${REINPLACE_CMD} -e "s/APXS=.*//" ${WRKSRC}/Makefile
${REINPLACE_CMD} -e "s!#include <sys/vfs.*!!" \
${WRKSRC}/smbval/smbencrypt.inc.c
+.if ${OSVERSION} >= 700042
+ ${REINPLACE_CMD} -e "s/extern/static/" ${WRKSRC}/smbval/smblib-priv.h
+.endif
post-install:
.ifndef(NOPORTDOCS)
@@ -31,10 +36,4 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/Documentation/mod_ntlm.html ${DOCSDIR}
.endif
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 700042
-BROKEN= Does not compile with GCC 4.2
-.endif
-
.include <bsd.port.post.mk>