aboutsummaryrefslogtreecommitdiffstats
path: root/www/mod_perl/Makefile
diff options
context:
space:
mode:
authorsheldonh <sheldonh@FreeBSD.org>2001-05-29 04:52:46 +0800
committersheldonh <sheldonh@FreeBSD.org>2001-05-29 04:52:46 +0800
commita87a4fb7b9cccf87dc42fb6b284770baa94cb3da (patch)
treeae283f287ea90569bdc924a01ad6c3e7cd703590 /www/mod_perl/Makefile
parent33912e311100193dae1e2edb6cf4f65d2fb6c2cb (diff)
downloadfreebsd-ports-gnome-a87a4fb7b9cccf87dc42fb6b284770baa94cb3da.tar.gz
freebsd-ports-gnome-a87a4fb7b9cccf87dc42fb6b284770baa94cb3da.tar.zst
freebsd-ports-gnome-a87a4fb7b9cccf87dc42fb6b284770baa94cb3da.zip
On deinstall, deactivate mod_perl in whichever of httpd.conf and
httpd.conf.default exist. This is a best attempt at resolving the problem where the system is left changed from before a mod_perl installation after mod_perl is removed. If only apxs had an option to revert module activation. Requested by: asami
Diffstat (limited to 'www/mod_perl/Makefile')
-rw-r--r--www/mod_perl/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/www/mod_perl/Makefile b/www/mod_perl/Makefile
index 0c495348127a..4575a755a24b 100644
--- a/www/mod_perl/Makefile
+++ b/www/mod_perl/Makefile
@@ -54,4 +54,7 @@ post-install:
${INSTALL_PROGRAM} ${WRKSRC}/apaci/libperl.so ${PREFIX}/libexec/apache
@PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
+post-deinstall:
+ @PKG_PREFIX=${PREFIX} ${SH} ${PKGDEINSTALL} ${PKGNAME} POST-DEINSTALL
+
.include <bsd.port.post.mk>