aboutsummaryrefslogtreecommitdiffstats
path: root/www/mod_perl2
diff options
context:
space:
mode:
authorsheldonh <sheldonh@FreeBSD.org>2001-03-06 19:39:27 +0800
committersheldonh <sheldonh@FreeBSD.org>2001-03-06 19:39:27 +0800
commit422ecc24ae5919bc6ac107172c5f75856f46cf80 (patch)
tree47a1277f9e4082f2cfedb529ae0b6a044459ded5 /www/mod_perl2
parenta53fcee7be8d3127cecdeb46fa6ce9b6c0edd40b (diff)
downloadfreebsd-ports-gnome-422ecc24ae5919bc6ac107172c5f75856f46cf80.tar.gz
freebsd-ports-gnome-422ecc24ae5919bc6ac107172c5f75856f46cf80.tar.zst
freebsd-ports-gnome-422ecc24ae5919bc6ac107172c5f75856f46cf80.zip
Fix the execution of the pkg-install script for the port's post-install
case. When I tested my porting work, I kept on using ``make package'' and testing the installation of the package, without testing the "install from the port" case. Reported by: Mike Harding <mvh@corp.namesafe.com>
Diffstat (limited to 'www/mod_perl2')
-rw-r--r--www/mod_perl2/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/www/mod_perl2/Makefile b/www/mod_perl2/Makefile
index 6e66540e728b..e369ec38780b 100644
--- a/www/mod_perl2/Makefile
+++ b/www/mod_perl2/Makefile
@@ -56,6 +56,6 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/src/modules/perl/*.h \
${PREFIX}/include/apache/modules/perl
${INSTALL_PROGRAM} ${WRKSRC}/apaci/libperl.so ${PREFIX}/libexec/apache
- ${SH} ${PKGINSTALL}
+ @PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} POST-INSTALL
.include <bsd.port.post.mk>