aboutsummaryrefslogtreecommitdiffstats
path: root/www/mod_perl
diff options
context:
space:
mode:
authorerwin <erwin@FreeBSD.org>2007-04-26 02:46:30 +0800
committererwin <erwin@FreeBSD.org>2007-04-26 02:46:30 +0800
commit1d6810baa6e6bb03459ab5b25670a0b806f6883c (patch)
treee043ac03827b22e81e158b11fc9c05ca092abaac /www/mod_perl
parent9aa567de60cc40be83a17aeb3eaf3562d959310f (diff)
downloadfreebsd-ports-gnome-1d6810baa6e6bb03459ab5b25670a0b806f6883c.tar.gz
freebsd-ports-gnome-1d6810baa6e6bb03459ab5b25670a0b806f6883c.tar.zst
freebsd-ports-gnome-1d6810baa6e6bb03459ab5b25670a0b806f6883c.zip
Update to 1.30
PR: 111844 Submitted by: "Philip M. Gollucci" <pgollucci@p6m7g8.com> Security: http://www.vuxml.org/freebsd/ef2ffb03-f2b0-11db-ad25-0010b5a0a860.html
Diffstat (limited to 'www/mod_perl')
-rw-r--r--www/mod_perl/Makefile9
-rw-r--r--www/mod_perl/distinfo6
-rw-r--r--www/mod_perl/files/patch-Makefile.PL23
-rw-r--r--www/mod_perl/pkg-plist1
4 files changed, 19 insertions, 20 deletions
diff --git a/www/mod_perl/Makefile b/www/mod_perl/Makefile
index 0d078b2c6bfc..09a190b9ac99 100644
--- a/www/mod_perl/Makefile
+++ b/www/mod_perl/Makefile
@@ -6,19 +6,18 @@
#
PORTNAME= mod_perl
-PORTVERSION= 1.29
-PORTREVISION= 2
+PORTVERSION= 1.30
CATEGORIES= www perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= Apache
-MAINTAINER= apache@FreeBSD.org
+MAINTAINER= pgollucci@p6m7g8.com
COMMENT= Embeds a Perl interpreter in the Apache server
BUILD_DEPENDS= ${SITE_PERL}/LWP.pm:${PORTSDIR}/www/p5-libwww
RUN_DEPENDS= ${BUILD_DEPENDS}
-USE_APACHE= YES
+USE_APACHE= yes
PERL_CONFIGURE= yes
CONFIGURE_ARGS+= USE_APXS=1 EVERYTHING=1 INSTALLSITELIB=${SITE_PERL} \
INSTALLSITEARCH=${SITE_PERL}/${PERL_ARCH} \
@@ -37,7 +36,7 @@ MAN3= Apache.3 Apache::Constants.3 Apache::ExtUtils.3 \
Bundle::Apache.3 \
Apache::Debug.3 mod_perl.3 Apache::SIG.3 Apache::Resource.3 \
Apache::RegistryLoader.3 Apache::StatINC.3 Apache::Include.3 \
- Apache::PerlSections.3 cgi_to_mod_perl.3 \
+ Apache::PerlSections.3 Apache::fork.3 cgi_to_mod_perl.3 \
mod_perl_cvs.3 mod_perl_method_handlers.3 mod_perl_traps.3 \
mod_perl_tuning.3
.if defined(APACHE_PORT)
diff --git a/www/mod_perl/distinfo b/www/mod_perl/distinfo
index e641f7e7d887..9e7d591edfc5 100644
--- a/www/mod_perl/distinfo
+++ b/www/mod_perl/distinfo
@@ -1,3 +1,3 @@
-MD5 (mod_perl-1.29.tar.gz) = 1491931790509b9af06fc037d02b0e7a
-SHA256 (mod_perl-1.29.tar.gz) = b401efaa105dd5f82d6e61f0efa372d4018db15e0748ca34a52d8daa209dea6b
-SIZE (mod_perl-1.29.tar.gz) = 378877
+MD5 (mod_perl-1.30.tar.gz) = bfd6f6cff1ab1cc3dbb58a236701d169
+SHA256 (mod_perl-1.30.tar.gz) = af6e1380a9197750b2d443f02a7a0dba3586c3fc0c8269beaafef09159184a08
+SIZE (mod_perl-1.30.tar.gz) = 389029
diff --git a/www/mod_perl/files/patch-Makefile.PL b/www/mod_perl/files/patch-Makefile.PL
index b8df70a4f89d..6e82ef6f2e4a 100644
--- a/www/mod_perl/files/patch-Makefile.PL
+++ b/www/mod_perl/files/patch-Makefile.PL
@@ -1,15 +1,14 @@
---- Makefile.PL.orig Thu Feb 15 12:39:35 2001
-+++ Makefile.PL Thu Feb 15 12:41:28 2001
-@@ -1300,7 +1300,11 @@
+--- Makefile.PL.orig Wed Apr 18 22:00:41 2007
++++ Makefile.PL Wed Apr 18 22:01:40 2007
+@@ -1380,7 +1380,10 @@
my $string = $self->MM::install;
my $add = "";
- if($USE_APXS) {
-- $add = "apxs_install";
-+# XXX The FreeBSD port for mod_perl takes care of installing libperl.so
-+# itself via the pkg-install script.
-+#
-+# $add = "apxs_install";
-+ print "Disabling apxs_install target; deferred to pkg-install\n";
+ if ($USE_APXS) {
+- $add = "apxs_install";
++ # XXX The FreeBSD port for mod_perl takes care of installing libperl.so
++ # itself via the pkg-install script.
++ #
++ # $add = "apxs_install";
}
- elsif ($win32_auto and $win32_args{INSTALL_DLL}) {
- $add = 'amp_install';
+ elsif ($win32_auto and
+ ($win32_args{INSTALL_DLL} or $win32_args{INSTALL_LIB})) {
diff --git a/www/mod_perl/pkg-plist b/www/mod_perl/pkg-plist
index c38fcda33a25..784db6cdcd44 100644
--- a/www/mod_perl/pkg-plist
+++ b/www/mod_perl/pkg-plist
@@ -37,6 +37,7 @@ include/apache/modules/perl/perl_PL.h
%%SITE_PERL%%/%%PERL_ARCH%%/Apache/Table.pm
%%SITE_PERL%%/%%PERL_ARCH%%/Apache/URI.pm
%%SITE_PERL%%/%%PERL_ARCH%%/Apache/Util.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/Apache/fork.pm
%%SITE_PERL%%/%%PERL_ARCH%%/Apache/httpd_conf.pm
%%SITE_PERL%%/%%PERL_ARCH%%/Apache/src.pm
%%SITE_PERL%%/%%PERL_ARCH%%/Apache/testold.pm