aboutsummaryrefslogtreecommitdiffstats
path: root/www/mod_php3
diff options
context:
space:
mode:
authordirk <dirk@FreeBSD.org>2000-03-02 06:45:34 +0800
committerdirk <dirk@FreeBSD.org>2000-03-02 06:45:34 +0800
commit0c59bc601205215c7b0e315613852516101a82b8 (patch)
tree23f7a24a71ecefc259536003cfadab9052dae554 /www/mod_php3
parent62b812cff2d9e5b1e4389280b5448f588c2af2e2 (diff)
downloadfreebsd-ports-gnome-0c59bc601205215c7b0e315613852516101a82b8.tar.gz
freebsd-ports-gnome-0c59bc601205215c7b0e315613852516101a82b8.tar.zst
freebsd-ports-gnome-0c59bc601205215c7b0e315613852516101a82b8.zip
sybase and sybase-ct are mutually exclusive. So split Sybase into SybaseDB
and SybaseCT and yell if there are selected both. Reported by: Dmitry Petrov <DPetrov@nchcapital.com>
Diffstat (limited to 'www/mod_php3')
-rw-r--r--www/mod_php3/scripts/configure.php21
1 files changed, 18 insertions, 3 deletions
diff --git a/www/mod_php3/scripts/configure.php b/www/mod_php3/scripts/configure.php
index 0380f9a54d41..606f2140e4e6 100644
--- a/www/mod_php3/scripts/configure.php
+++ b/www/mod_php3/scripts/configure.php
@@ -25,7 +25,8 @@ IMAP "PHP: IMAP support" OFF \
MySQL "PHP: MySQL database support" ON \
PostgreSQL "PHP: PostgreSQL database support" OFF \
mSQL "PHP: mSQL database support" OFF \
-Sybase "PHP: Sybase/MS-SQL database support" OFF \
+SybaseDB "PHP: Sybase/MS-SQL database support (DB-lib)" OFF \
+SybaseCT "PHP: Sybase/MS-SQL database support (CT-lib)" OFF \
dBase "PHP: dBase database support" OFF \
OpenLDAP "PHP: OpenLDAP support" OFF \
SNMP "PHP: SNMP support" OFF \
@@ -111,11 +112,25 @@ while [ "$1" ]; do
echo "BUILD_DEPENDS+= msql:\${PORTSDIR}/databases/msql"
echo "PHP_CONF_ARGS+= --with-msql=\${PREFIX}"
;;
- \"Sybase\")
+ \"SybaseDB\")
echo "LIB_DEPENDS+= sybdb.0:\${PORTSDIR}/databases/freetds"
- echo "LIB_DEPENDS+= ct.0:\${PORTSDIR}/databases/freetds"
echo "PHP_CONF_ARGS+= --with-sybase=\${PREFIX}"
+ if [ "$SYBASECT" ]; then
+ echo "SybaseDB and SybaseCT are mutually exclusive." > /dev/stderr
+ rm -f ${WRKDIRPREFIX}${CURDIR}/Makefile.inc
+ exit 1
+ fi
+ SYBASEDB=1
+ ;;
+ \"SybaseCT\")
+ echo "LIB_DEPENDS+= ct.0:\${PORTSDIR}/databases/freetds"
echo "PHP_CONF_ARGS+= --with-sybase-ct=\${PREFIX}"
+ if [ "$SYBASEDB" ]; then
+ echo "SybaseDB and SybaseCT are mutually exclusive." > /dev/stderr
+ rm -f ${WRKDIRPREFIX}${CURDIR}/Makefile.inc
+ exit 1
+ fi
+ SYBASECT=1
;;
\"dBase\")
echo "PHP_CONF_ARGS+= --with-dbase"