aboutsummaryrefslogtreecommitdiffstats
path: root/www/mod_php3
diff options
context:
space:
mode:
authordirk <dirk@FreeBSD.org>1998-12-23 08:44:50 +0800
committerdirk <dirk@FreeBSD.org>1998-12-23 08:44:50 +0800
commitb19be21384c0c39fe417e3e7df74af390ae616d1 (patch)
tree2319b87565e67a27ade9c3a8fc4bde1b5959608b /www/mod_php3
parentc73ad7d7870dc4a76f58e89f190bd6a12b02caf6 (diff)
downloadfreebsd-ports-gnome-b19be21384c0c39fe417e3e7df74af390ae616d1.tar.gz
freebsd-ports-gnome-b19be21384c0c39fe417e3e7df74af390ae616d1.tar.zst
freebsd-ports-gnome-b19be21384c0c39fe417e3e7df74af390ae616d1.zip
- BATCH mode: if ${BATCH} is defined apache with a plain PHP3 module
is created, i. e. no additional support for e. g. databases It is possible to build an apache13-php3 package now. - honor ${CC} and ${CFLAGS} while compiling PHP3 - make apache13-php3 ${WRKDIRPREFIX} clean - added OpenLDAP support Requested by: Kurt D. Zeilenga <Kurt@OpenLDAP.Org> - upgrade to mod_ssl-2.1.3
Diffstat (limited to 'www/mod_php3')
-rw-r--r--www/mod_php3/Makefile22
-rw-r--r--www/mod_php3/distinfo2
-rw-r--r--www/mod_php3/pkg-message9
-rw-r--r--www/mod_php3/pkg-plist1
-rw-r--r--www/mod_php3/scripts/configure.php57
5 files changed, 61 insertions, 30 deletions
diff --git a/www/mod_php3/Makefile b/www/mod_php3/Makefile
index e6d94e4b5098..46ebd302bbed 100644
--- a/www/mod_php3/Makefile
+++ b/www/mod_php3/Makefile
@@ -3,7 +3,7 @@
# Date created: So 21 Jun 1998 16:09:39 CEST
# Whom: Stefan Herrmann <stefan@asterix.webaffairs.net>
#
-# $Id: Makefile,v 1.59 1998/12/05 09:36:59 obrien Exp $
+# $Id: Makefile,v 1.58 1998/12/02 20:32:02 billf Exp $
#
DISTNAME= apache_${VERSION_APACHE}
@@ -18,14 +18,11 @@ MASTER_SITES= ftp://www.apache.org/apache/dist/ \
http://www.php3.de/distributions/
DISTFILES= apache_${VERSION_APACHE}.tar.gz php-${VERSION_PHP3}.tar.gz
-MAINTAINER= Dirk Froemberg <ibex@physik.TU-Berlin.DE>
+MAINTAINER= dirk@FreeBSD.ORG
VERSION_APACHE= 1.3.3
VERSION_PHP3= 3.0.5
-IS_INTERACTIVE= yes
-NO_PACKAGE= Support for different databases
-
#
# Set APACHE_PERF_TUNING env. variable to YES to get maximum performance
#
@@ -74,14 +71,21 @@ PHP3_CONF_ARGS= --prefix=${PREFIX} \
--enable-track-vars
pre-fetch:
+.if !defined(BATCH)
@${SETENV} ${SCRIPTS_ENV} ${SH} ${SCRIPTDIR}/configure.php
+.endif
pre-configure:
@cd ${WRKSRC} \
&& ./configure > /dev/null \
&& cd ${WRKDIR}/php-${VERSION_PHP3} \
&& ${ECHO_MSG} "===> Configuring for PHP-${VERSION_PHP3}" \
- && CFLAGS= CPPFLAGS="-I${PREFIX}/include -I${PREFIX}/include/gd" LDFLAGS=-L${PREFIX}/lib ./configure ${PHP3_CONF_ARGS} \
+ && CC="${CC}" \
+ ac_cv_path_CC="${CC}" \
+ CFLAGS="${CFLAGS}" \
+ CPPFLAGS="-I${PREFIX}/include -I${PREFIX}/include/gd" \
+ LDFLAGS=-L${PREFIX}/lib \
+ ./configure ${PHP3_CONF_ARGS} \
&& ${ECHO_MSG} "===> Building for PHP-${VERSION_PHP3}" \
&& ${MAKE} install \
&& ${ECHO_MSG} "===> Configuring for Apache-${VERSION_APACHE}"
@@ -132,9 +136,9 @@ clean:
${ECHO_MSG} "===> ${WRKDIR} not writable, skipping"; \
fi; \
fi
- @${RM} -f Makefile.inc
+ @${RM} -f ${WRKDIRPREFIX}${.CURDIR}/Makefile.inc
-.if exists(Makefile.inc)
-.include "Makefile.inc"
+.if exists(${WRKDIRPREFIX}${.CURDIR}/Makefile.inc)
+.include "${WRKDIRPREFIX}${.CURDIR}/Makefile.inc"
.endif
.include <bsd.port.mk>
diff --git a/www/mod_php3/distinfo b/www/mod_php3/distinfo
index 17aa8a15baff..ad5089dc145a 100644
--- a/www/mod_php3/distinfo
+++ b/www/mod_php3/distinfo
@@ -1,3 +1,3 @@
MD5 (apache_1.3.3.tar.gz) = bb6f14bbb369097a55969482d395d1ae
MD5 (php-3.0.5.tar.gz) = f5d78d425bfe642a25871ff3e375fec2
-MD5 (mod_ssl-2.0.14-1.3.3.tar.gz) = 0a60f9b131d7ce93c3ff3ebbc524e75c
+MD5 (mod_ssl-2.1.3-1.3.3.tar.gz) = 76bd1f0d5f5c9623a71fea336312a753
diff --git a/www/mod_php3/pkg-message b/www/mod_php3/pkg-message
new file mode 100644
index 000000000000..03d6311ac5a9
--- /dev/null
+++ b/www/mod_php3/pkg-message
@@ -0,0 +1,9 @@
+*****************************************************************************
+You have just installed the apache13-php3 package.
+
+Have a look at the apache13-php3 port if you need additional support for
+databases or SSL.
+
+You can find it at
+ftp://ftp.freebsd.org/pub/FreeBSD/FreeBSD-current/ports/www/apache13-php3.tar
+*****************************************************************************
diff --git a/www/mod_php3/pkg-plist b/www/mod_php3/pkg-plist
index 8628c1c97757..f87fa9c662eb 100644
--- a/www/mod_php3/pkg-plist
+++ b/www/mod_php3/pkg-plist
@@ -274,6 +274,7 @@ www/icons/uu.gif
www/icons/uuencoded.gif
www/icons/world1.gif
www/icons/world2.gif
+@exec mkdir -p %D/www/proxy
@dirrm etc/apache
@dirrm include/apache
@dirrm libexec/apache
diff --git a/www/mod_php3/scripts/configure.php b/www/mod_php3/scripts/configure.php
index 8241d9244726..5db50034679a 100644
--- a/www/mod_php3/scripts/configure.php
+++ b/www/mod_php3/scripts/configure.php
@@ -1,12 +1,12 @@
#!/bin/sh
-if [ -f ${CURDIR}/Makefile.inc ]; then
+if [ -f ${WRKDIRPREFIX}${CURDIR}/Makefile.inc ]; then
exit
fi
/usr/bin/dialog --title "configuration options" --clear \
--checklist "\n\
-Please select desired options:" -1 -1 9 \
+Please select desired options:" -1 -1 10 \
tuning "Apache: performance tuning" OFF \
modssl "Apache: SSL support" OFF \
GD "PHP3: GD library support" ON \
@@ -15,7 +15,9 @@ zlib "PHP3: zlib library support" ON \
MySQL "PHP3: MySQL database support" ON \
PostgreSQL "PHP3: PostgreSQL database support" OFF \
mSQL "PHP3: mSQL database support" OFF \
-dBase "PHP3: dBase database support" OFF 2> /tmp/checklist.tmp.$$
+dBase "PHP3: dBase database support" OFF \
+OpenLDAP "PHP3: OpenLDAP support" OFF \
+2> /tmp/checklist.tmp.$$
retval=$?
@@ -34,49 +36,61 @@ case $retval in
;;
esac
-> ${CURDIR}/Makefile.inc
+mkdir -p ${WRKDIRPREFIX}${CURDIR}
+> ${WRKDIRPREFIX}${CURDIR}/Makefile.inc
while [ "$1" ]; do
case $1 in
\"tuning\")
- echo "APACHE_PERF_TUNING= YES" >> ${CURDIR}/Makefile.inc
+ echo "APACHE_PERF_TUNING= YES" >> ${WRKDIRPREFIX}${CURDIR}/Makefile.inc
;;
\"GD\")
- echo "BUILD_DEPENDS+= \${PREFIX}/lib/libgd.a:\${PORTSDIR}/graphics/gd" >> ${CURDIR}/Makefile.inc
- echo "PHP3_CONF_ARGS+= --with-gd" >> ${CURDIR}/Makefile.inc
+ echo "BUILD_DEPENDS+= \${PREFIX}/lib/libgd.a:\${PORTSDIR}/graphics/gd" >> ${WRKDIRPREFIX}${CURDIR}/Makefile.inc
+ echo "PHP3_CONF_ARGS+= --with-gd" >> ${WRKDIRPREFIX}${CURDIR}/Makefile.inc
GD=1
;;
\"FreeType\")
- echo "LIB_DEPENDS+= ttf.3:\${PORTSDIR}/print/freetype" >> ${CURDIR}/Makefile.inc
+ echo "LIB_DEPENDS+= ttf.3:\${PORTSDIR}/print/freetype" >> ${WRKDIRPREFIX}${CURDIR}/Makefile.inc
if [ -z "$GD" ]; then
set $* \"GD\"
fi
;;
\"zlib\")
- echo "PHP3_CONF_ARGS+= --with-zlib" >> ${CURDIR}/Makefile.inc
+ echo "PHP3_CONF_ARGS+= --with-zlib" >> ${WRKDIRPREFIX}${CURDIR}/Makefile.inc
;;
\"MySQL\")
- echo "BUILD_DEPENDS+= mysql:\${PORTSDIR}/databases/mysql321" >> ${CURDIR}/Makefile.inc
- echo "PHP3_CONF_ARGS+= --with-mysql=\${PREFIX}" >> ${CURDIR}/Makefile.inc
+ echo "BUILD_DEPENDS+= mysql:\${PORTSDIR}/databases/mysql321" >> ${WRKDIRPREFIX}${CURDIR}/Makefile.inc
+ echo "PHP3_CONF_ARGS+= --with-mysql=\${PREFIX}" >> ${WRKDIRPREFIX}${CURDIR}/Makefile.inc
;;
\"PostgreSQL\")
- echo "BUILD_DEPENDS+= \${PREFIX}/pgsql/bin/psql:\${PORTSDIR}/databases/postgresql" >> ${CURDIR}/Makefile.inc
- echo "PHP3_CONF_ARGS+= --with-pgsql=\${PREFIX}/pgsql" >> ${CURDIR}/Makefile.inc
+ echo "BUILD_DEPENDS+= \${PREFIX}/pgsql/bin/psql:\${PORTSDIR}/databases/postgresql" >> ${WRKDIRPREFIX}${CURDIR}/Makefile.inc
+ echo "PHP3_CONF_ARGS+= --with-pgsql=\${PREFIX}/pgsql" >> ${WRKDIRPREFIX}${CURDIR}/Makefile.inc
;;
\"mSQL\")
- echo "BUILD_DEPENDS+= msql:\${PORTSDIR}/databases/msql" >> ${CURDIR}/Makefile.inc
- echo "PHP3_CONF_ARGS+= --with-msql=\${PREFIX}" >> ${CURDIR}/Makefile.inc
+ echo "BUILD_DEPENDS+= msql:\${PORTSDIR}/databases/msql" >> ${WRKDIRPREFIX}${CURDIR}/Makefile.inc
+ echo "PHP3_CONF_ARGS+= --with-msql=\${PREFIX}" >> ${WRKDIRPREFIX}${CURDIR}/Makefile.inc
;;
\"dBase\")
- echo "PHP3_CONF_ARGS+= --with-dbase" >> ${CURDIR}/Makefile.inc
+ echo "PHP3_CONF_ARGS+= --with-dbase" >> ${WRKDIRPREFIX}${CURDIR}/Makefile.inc
+ ;;
+ \"OpenLDAP\")
+ echo "BUILD_DEPENDS+= \${PREFIX}/lib/libldap.a:\${PORTSDIR}/net/openldap" >> ${WRKDIRPREFIX}${CURDIR}/Makefile.inc
+ echo "BUILD_DEPENDS+= \${PREFIX}/lib/liblber.a:\${PORTSDIR}/net/openldap" >> ${WRKDIRPREFIX}${CURDIR}/Makefile.inc
+ echo "PHP3_CONF_ARGS+= --with-ldap=\${PREFIX}" >> ${WRKDIRPREFIX}${CURDIR}/Makefile.inc
;;
\"modssl\")
- cat << EOF >> ${CURDIR}/Makefile.inc
+ cat << EOF >> ${WRKDIRPREFIX}${CURDIR}/Makefile.inc
PKGNAME= apache-php\${VERSION_PHP3}-\${VERSION_APACHE}+mod_ssl-\${VERSION_MODSSL}
MASTER_SITES+= http://www.engelschall.com/sw/mod_ssl/distrib/ \\
ftp://ftp.engelschall.com/sw/mod_ssl/ \\
+ ftp://ftp.nvg.ntnu.no/pub/unix/mod_ssl/ \\
ftp://ftp.ulpgc.es/pub/mod_ssl/ \\
- ftp://glock.missouri.edu/pub/mod_ssl/
+ ftp://glock.missouri.edu/pub/mod_ssl/ \\
+ ftp://ftp.infoscience.co.jp/pub/Crypto/SSL/mod_ssl/ \\
+ ftp://ftp.uni-trier.de/pub/unix/security/mod_ssl/ \\
+ ftp://ftp.blatzheim.com/pub/mod_ssl/ \\
+ ftp://ftp.fu-berlin.de/unix/security/mod_ssl/ \\
+ ftp://ftp.ntrl.net/pub/mirror/ralfsw/mod_ssl/
DISTFILES+= mod_ssl-\${VERSION_MODSSL}-\${VERSION_APACHE}\${EXTRACT_SUFX}
BUILD_DEPENDS+= ssleay:\${PORTSDIR}/security/SSLeay \\
@@ -84,7 +98,7 @@ BUILD_DEPENDS+= ssleay:\${PORTSDIR}/security/SSLeay \\
\${PREFIX}/lib/libcrypto.a:\${PORTSDIR}/security/SSLeay
RUN_DEPENDS+= ssleay:\${PORTSDIR}/security/SSLeay
-VERSION_MODSSL= 2.0.14
+VERSION_MODSSL= 2.1.3
RESTRICTED= "Contains cryptography"
@@ -98,7 +112,7 @@ SSL= ssl
pre-patch:
@cd \${WRKDIR}/mod_ssl-\${VERSION_MODSSL}-\${VERSION_APACHE} \\
&& \${ECHO_MSG} "===> Applying mod_ssl-\${VERSION_MODSSL} extension" \\
- && ./configure --with-apache=../\${DISTNAME}
+ && ./configure --with-apache=../\${DISTNAME} --expert
post-patch:
@cd \${WRKSRC} \\
@@ -106,12 +120,15 @@ post-patch:
post-build:
@cd \${WRKSRC} \\
+ && \${ECHO_MSG} "===> Creating Dummy Certificate for Server (SnakeOil)" \\
+ && \${ECHO_MSG} " [use 'make certificate' to create a real one]" \\
&& \${MAKE} certificate TYPE=dummy >/dev/null 2>&1
certificate:
@cd \${WRKSRC} \\
&& \${ECHO_MSG} "===> Creating Test Certificate for Server" \\
&& \${MAKE} certificate TYPE=\$(TYPE) CRT=\$(CRT) KEY=\$(KEY)
+
EOF
;;
esac
c'>Update to 2.2.1ahze2004-12-3012-48/+9 * [1] Try to respect PTHREAD_LIBS, to unbreak the build on 4.x.anholt2004-12-302-4/+5 * Upgrade to 1.2.8ache2004-12-293-4/+4 * Chase the new location for update-desktop-database by allowing the commandmarcus2004-12-293-3/+3 * Add use_imake to get makedependedwin2004-12-291-0/+1 * - Create empty share/gimp/fonts directory in package installpav2004-12-293-0/+3 * - Update GIMP plugin for GIMP 2.2pav2004-12-292-3/+3 * Fix plist.bland2004-12-286-6/+6 * Update to 1.3.25vs2004-12-272-5/+5 * Back out the previous change. Mita-san will continue tohrs2004-12-271-1/+1 * Fix MASTER_SITES.krion2004-12-271-2/+2 * - In case we building GNOME version of GIMP link it against pthreadsbland2004-12-266-3/+6 * Upgrade to 1.52.kuriyama2004-12-261-1/+1 * Update to 1.7.0.knu2004-12-263-13/+23 * Now builds on FreeBSD 6.xkris2004-12-251-4/+0 * Patch vulnerability in imported xpdf code. Bump PORTREVISION.josef2004-12-252-0/+37 * - Remove gimp-devel for now, 2.2 is stablepav2004-12-2523-4605/+0 * - Fix python plugin: it expects a png logo, which is not includedpav2004-12-253-0/+33 * - Update to 2.2.0pav2004-12-2517-761/+1160 * Bump PORTREVISION for previous commit.anholt2004-12-241-0/+1 * [1] Link against libexpat so that the drivers actually work.anholt2004-12-244-11/+45 * Reset bouncing maintainer address.linimon2004-12-241-1/+1 * - Update to bsd.java.mk 2.0hq2004-12-241-17/+18 * Fix packaging on non-i386anholt2004-12-241-1/+1 * Utilize USE_GNOME=pkgconfig.nork2004-12-232-2/+2 * Add rmdir libdata/pkgconfig. But I don't bump PORTREVISION.nork2004-12-231-1/+2 * Update to version 1.2.4krion2004-12-233-11/+22 * Patch vulnerability in imported xpdf code. Bump PORTREVISION.lofi2004-12-234-0/+78 * Update to version 2.0.7krion2004-12-234-23/+22 * Bump shlib version for graphics/simagekrion2004-12-231-2/+2 * Update to version 1.6.1krion2004-12-233-22/+14 * Update to version 2.0.13krion2004-12-233-4/+5 * Update to version 0.9.7krion2004-12-232-8/+5 * Reset MAINTAINER to ports@.nork2004-12-2314-14/+14 * [NEW PORT] graphics/linux-sdl_image: A simple library to load imagesedwin2004-12-2313-0/+178 * Fix build without imake.lesi2004-12-231-0/+1 * Update X.Org ports to 6.8.1, and the DRI port to use Mesa 6.2. Because Mesa 6.2anholt2004-12-2313-59/+133 * Fix security problem.nork2004-12-232-1/+37 * - Update to version 1.2markus2004-12-233-6/+19 * Update to 1.2.5vs2004-12-222-3/+3 * - update to 3.7.1dinoex2004-12-226-135/+98 * Fix plist.krion2004-12-211-1/+2 * Fix plist.krion2004-12-212-1/+2 * Fix pkg-plist.vanilla2004-12-211-0/+1 * Update to version 0.28.8krion2004-12-203-9/+9 * Update to version 2.1.5krion2004-12-209-354/+55 * Update to version 2.1.5krion2004-12-204-40/+37 * Don't remove system locale directories (not listed in the relevantkris2004-12-202-9/+2 * This port is scheduled to be removed on 2005-02-18 if it is stillkris2004-12-198-0/+16 * Reset bouncing maintainer address:kris2004-12-191-1/+1 * - Chase pdflib updatepav2004-12-181-1/+1 * After a bit of discussion with CPAN maintainer of this module, make itlesi2004-12-182-2/+38 * Update Imagemagick to lastest versionjosef2004-12-182-21/+6 * Make port depend on linux/libpng.so.3 instead of .2edwin2004-12-171-1/+1 * Clean up handling of locale directories at deinstall-time:kris2004-12-165-0/+28 * New port: graphics/hugin - a gui system to mount panoramic imagesedwin2004-12-166-0/+575 * . Add USE_GNOME=pkgconfig as this port installs pkgconfig meta data. Thisglewis2004-12-162-0/+2 * Update to version 0.3.2 [1].kwm2004-12-168-59/+58 * New port: graphics/linux-panorama-tools - another program to mount panoramic ...edwin2004-12-155-0/+68 * New port: graphics/libpano12 - program to mount panorama picturesedwin2004-12-156-0/+95 * New port: graphics/vigra - another program to mount panoramic imagesedwin2004-12-155-0/+564 * - Update to 6.1.6.7pav2004-12-152-5/+4 * Fix MASTER_SITE_SUBDIR.lofi2004-12-152-2/+2 * Add py-pydot 0.9.9, a Python interface to the Graphviz Dot language.vs2004-12-144-0/+41 * - Update to 1.8sem2004-12-144-19/+42 * Fix pkg-plist.krion2004-12-141-0/+1 * upgrade to 4.4.0mharo2004-12-145-23/+21 * Update to KDE 3.3.2lofi2004-12-1415-138/+18 * Update to version 2.0markus2004-12-149-135/+294 * Updated to 0.37skv2004-12-132-3/+3 * Update to 0.6ahze2004-12-132-3/+3 * - Update to 6.1.6.6pav2004-12-132-3/+3 * Fix the build if you don't have gnomepanel installed.mezz2004-12-122-0/+6 * Now fetchable againkris2004-12-121-2/+0 * Add libggigcp, a libggi extension for advanced color and palette handling. Itpav2004-12-125-0/+97 * Add libggimisc, a libggi extension providing support for a range of hard topav2004-12-125-0/+70 * Add libggiwmh, a libggi extension whereby wmh stands for 'Window Managerpav2004-12-125-0/+82 * BROKEN: Does not buildkris2004-12-121-4/+2 * BROKEN: Does not compilekris2004-12-122-8/+4 * BROKEN on 4.x: Does not compilekris2004-12-121-1/+7 * Temporarily remove cairographics.org from MASTER_SITES since the distfile eitherahze2004-12-126-12/+6 * Update to version 0.7.3krion2004-12-123-11/+13 * Update to version 1.4krion2004-12-122-3/+3 * Update to version 0.28.7krion2004-12-122-3/+3 * Add bmp-rootvis, a Beep Media Player plugin which renders a spectrumpav2004-12-124-0/+31 * - Update to 6.1.6.4pav2004-12-122-3/+3 * Add missing file and bump PORTREVISIONkris2004-12-112-1/+2 * -Fix the pkg-plist. [1]mezz2004-12-114-8/+20 * - Update to 6.1.6.3pav2004-12-113-8/+16 * - ImageMagick authors pulled tarball of "stable" release from sites again.pav2004-12-101-3/+3 * Unbreak on 4.X.danfe2004-12-101-1/+3 * Unbreak on 4.X.danfe2004-12-101-0/+20 * Fix the pkg-plist.mezz2004-12-102-2/+5 * BROKEN: Does not compile on 4.xkrion2004-12-091-1/+7 * - ImageMagick 6.1.6.0 is always installing it's own copy of libltdl,pav2004-12-092-1/+12 * BROKEN: Does not compile on 4.xkrion2004-12-091-1/+7 * Fix build on 4-xkrion2004-12-091-1/+1 * PyQt doesn't like python 2.4, restrict it and ports depending on it tolofi2004-12-082-2/+2 * Fix build without imake.lesi2004-12-081-0/+1 * Fix pixieplus compilation with the new ImageMagickarved2004-12-085-1/+261 * Depend on libltdlarved2004-12-081-0/+2 * Chase ImageMagick update.josef2004-12-071-2/+2 * Update to 1.2.5ahze2004-12-072-3/+3 * Update to 2.8.1ahze2004-12-072-4/+3 * - Update to 2.1.0pav2004-12-074-36/+25 * - Update to 2.6.2pav2004-12-072-3/+3 * Upgrade to 8.2.2 (bugfix release).thierry2004-12-062-5/+4 * Add py-cairoahze2004-12-065-0/+53 * Update to version 0.28.4krion2004-12-063-5/+6 * Update to version 3.06krion2004-12-062-8/+5 * Bump portrevision and dependency on ImageMagickjosef2004-12-059-15/+19 * Update ImageMagick to 6.1.6-0.josef2004-12-053-75/+25 * With portmgr hat on, reset Roger's maintainership of these ports. Whilelinimon2004-12-051-1/+1 * - Fix fetch by using new MASTER_SITE and adding MASTER_SITE_LOCAL to mixahze2004-12-042-4/+4 * BROKEN on 4.x: Does not buildkris2004-12-043-0/+12 * BROKEN: Unfetchablekris2004-12-041-0/+2 * Mark port forbidden due to security vulnerability.josef2004-12-021-0/+1 * Correct typo in previouskris2004-12-021-1/+1 * Update WWW: lineahze2004-12-022-2/+2 * Add digikamimageplugins 0.7.0, a collection of image editor plugins formarkus2004-12-025-0/+326 * Unbreak by updating to version 0.7markus2004-12-02