aboutsummaryrefslogtreecommitdiffstats
path: root/www/mod_php4
diff options
context:
space:
mode:
authordirk <dirk@FreeBSD.org>2001-03-05 06:41:12 +0800
committerdirk <dirk@FreeBSD.org>2001-03-05 06:41:12 +0800
commit24729f89a8b09bc1723371feabf31df902386974 (patch)
treeb1713261708a38cdfec934708817fab25f4ca9d2 /www/mod_php4
parentc6dd1347e26270d014fc011a0a179336df14f03e (diff)
downloadfreebsd-ports-gnome-24729f89a8b09bc1723371feabf31df902386974.tar.gz
freebsd-ports-gnome-24729f89a8b09bc1723371feabf31df902386974.tar.zst
freebsd-ports-gnome-24729f89a8b09bc1723371feabf31df902386974.zip
Solve the multiple post-extract targets problem.
Diffstat (limited to 'www/mod_php4')
-rw-r--r--www/mod_php4/Makefile10
1 files changed, 8 insertions, 2 deletions
diff --git a/www/mod_php4/Makefile b/www/mod_php4/Makefile
index ee3cc9e41334..a467a671072a 100644
--- a/www/mod_php4/Makefile
+++ b/www/mod_php4/Makefile
@@ -62,8 +62,6 @@ PLIST_SUB= PHPDOCDIR=${PHPDOCDIR:S/^${PREFIX}\///} \
pre-fetch:
@${SETENV} ${SCRIPTS_ENV} ${SH} ${SCRIPTDIR}/configure.php
-post-extract: post-extract-jstring post-extract-ming
-
post-install:
.if !defined(STANDALONE)
@${ECHO} "Restarting Apache..."
@@ -103,4 +101,12 @@ post-clean:
.include "${WRKDIRPREFIX}${.CURDIR}/Makefile.inc"
.endif
+post-extract:
+.if target(post-extract-jstring)
+ ${MAKE} post-extract-jstring
+.endif
+.if target(post-extract-ming)
+ ${MAKE} post-extract-ming
+.endif
+
.include <bsd.port.mk>