aboutsummaryrefslogtreecommitdiffstats
path: root/www/mod_php4
diff options
context:
space:
mode:
authordirk <dirk@FreeBSD.org>1999-01-15 05:22:29 +0800
committerdirk <dirk@FreeBSD.org>1999-01-15 05:22:29 +0800
commitab00ea47fccc9e23b676c4de97a59b629323e81f (patch)
treef34a291259b41401d1f6a6d8ffe116bd4857facb /www/mod_php4
parent9c0370e88ff70c4ae290e9f21dfbf24a0ca9f2f7 (diff)
downloadfreebsd-ports-gnome-ab00ea47fccc9e23b676c4de97a59b629323e81f.tar.gz
freebsd-ports-gnome-ab00ea47fccc9e23b676c4de97a59b629323e81f.tar.zst
freebsd-ports-gnome-ab00ea47fccc9e23b676c4de97a59b629323e81f.zip
Change the dependencies to MySQL:
The default is mysql322 now, but take mysql321 if it is installed. (mysql321 installs a static libmysqlclient.a only, mysql322 installs a static and shared version of the library. Note that the build dependency to mysql321 is a no op actually. It is in there to improve understanding(?).)
Diffstat (limited to 'www/mod_php4')
-rw-r--r--www/mod_php4/scripts/configure.php6
1 files changed, 5 insertions, 1 deletions
diff --git a/www/mod_php4/scripts/configure.php b/www/mod_php4/scripts/configure.php
index df97a974aefe..56b3b2544021 100644
--- a/www/mod_php4/scripts/configure.php
+++ b/www/mod_php4/scripts/configure.php
@@ -59,7 +59,11 @@ while [ "$1" ]; do
echo "PHP3_CONF_ARGS+= --with-zlib" >> ${WRKDIRPREFIX}${CURDIR}/Makefile.inc
;;
\"MySQL\")
- echo "BUILD_DEPENDS+= mysql:\${PORTSDIR}/databases/mysql321" >> ${WRKDIRPREFIX}${CURDIR}/Makefile.inc
+ echo ".if !exists(\${PREFIX}/lib/mysql/libmysqlclient.a) || exists(\${PREFIX}/lib/mysql/libmysqlclient.so)" >> ${WRKDIRPREFIX}${CURDIR}/Makefile.inc
+ echo "LIB_DEPENDS+= mysqlclient.5:\${PORTSDIR}/databases/mysql322" >> ${WRKDIRPREFIX}${CURDIR}/Makefile.inc
+ echo ".else" >> ${WRKDIRPREFIX}${CURDIR}/Makefile.inc
+ echo "BUILD_DEPENDS+= \${PREFIX}/lib/mysql/libmysqlclient.a:\${PORTSDIR}/databases/mysql321" >> ${WRKDIRPREFIX}${CURDIR}/Makefile.inc
+ echo ".endif" >> ${WRKDIRPREFIX}${CURDIR}/Makefile.inc
echo "PHP3_CONF_ARGS+= --with-mysql=\${PREFIX}" >> ${WRKDIRPREFIX}${CURDIR}/Makefile.inc
;;
\"PostgreSQL\")