aboutsummaryrefslogtreecommitdiffstats
path: root/www/mod_php4
diff options
context:
space:
mode:
authordirk <dirk@FreeBSD.org>2000-12-13 16:43:16 +0800
committerdirk <dirk@FreeBSD.org>2000-12-13 16:43:16 +0800
commit00a75821b69cd4b416598ef6f5c44f743758c655 (patch)
tree83f303dff09189afc331c2f25ba8f4eb8b91b5b2 /www/mod_php4
parent3a889614eae02e252401411006cb3192ea0e2166 (diff)
downloadfreebsd-ports-gnome-00a75821b69cd4b416598ef6f5c44f743758c655.tar.gz
freebsd-ports-gnome-00a75821b69cd4b416598ef6f5c44f743758c655.tar.zst
freebsd-ports-gnome-00a75821b69cd4b416598ef6f5c44f743758c655.zip
Add support for jstring.
Submitted by: kuriyama
Diffstat (limited to 'www/mod_php4')
-rw-r--r--www/mod_php4/Makefile3
-rw-r--r--www/mod_php4/distinfo1
-rw-r--r--www/mod_php4/scripts/configure.php17
3 files changed, 20 insertions, 1 deletions
diff --git a/www/mod_php4/Makefile b/www/mod_php4/Makefile
index 6e44cd3f2d03..aa7ad0246c64 100644
--- a/www/mod_php4/Makefile
+++ b/www/mod_php4/Makefile
@@ -43,7 +43,8 @@ CONFIGURE_ARGS= --with-apxs=${APXS} \
SCRIPTS_ENV= WRKDIRPREFIX="${WRKDIRPREFIX}" \
TOUCH="${TOUCH}" \
- MKDIR="${MKDIR}"
+ MKDIR="${MKDIR}" \
+ CAT="${CAT}"
.if exists(${APXS})
AP_LIBEXEC!= ${APXS} -q LIBEXEC
diff --git a/www/mod_php4/distinfo b/www/mod_php4/distinfo
index 4c282c697b1f..40a10a52870a 100644
--- a/www/mod_php4/distinfo
+++ b/www/mod_php4/distinfo
@@ -1 +1,2 @@
MD5 (php-4.0.3pl1.tar.gz) = 6969bc69588400557f70a014ab1536c1
+MD5 (php-4.0RC2_jstring-1.0.tar.gz) = 9a159030cf6cab58b1131c70780f0eb0
diff --git a/www/mod_php4/scripts/configure.php b/www/mod_php4/scripts/configure.php
index 1baa169123b7..ce54f697a785 100644
--- a/www/mod_php4/scripts/configure.php
+++ b/www/mod_php4/scripts/configure.php
@@ -29,6 +29,7 @@ SNMP "SNMP support" OFF \
XML "XML support" OFF \
FTP "File Transfer Protocol support" OFF \
gettext "gettext library support" OFF \
+jstring "jstring module" OFF \
2> /tmp/checklist.tmp.$$
retval=$?
@@ -157,6 +158,22 @@ while [ "$1" ]; do
echo "LIB_DEPENDS+= intl.1:\${PORTSDIR}/devel/gettext"
echo "CONFIGURE_ARGS+=--with-gettext=\${PREFIX}"
;;
+ \"jstring\")
+ ${CAT} << EOF
+MASTER_SITES+= ftp://night.fminn.nagano.nagano.jp/php4/
+DISTFILES= \${DISTNAME}\${EXTRACT_SUFX} php-4.0RC2_jstring-1.0.tar.gz
+CONFIGURE_ARGS+=--enable-jstring
+BUILD_DEPENDS+= automake:\${PORTSDIR}/devel/automake
+BUILD_DEPENDS+= autoconf:\${PORTSDIR}/devel/autoconf
+
+post-extract:
+ [ -d \${WRKDIR}/jstring ] && \\
+ (cd \${WRKSRC}; \\
+ \${MV} ${WRKDIR}/jstring ext; \\
+ \${RM} configure; \\
+ ./buildconf)
+EOF
+ ;;
*)
echo "Invalid option(s): $*" > /dev/stderr
rm -f ${WRKDIRPREFIX}${CURDIR}/Makefile.inc