aboutsummaryrefslogtreecommitdiffstats
path: root/www/mod_php5
diff options
context:
space:
mode:
authordirk <dirk@FreeBSD.org>2002-05-12 00:49:32 +0800
committerdirk <dirk@FreeBSD.org>2002-05-12 00:49:32 +0800
commitfa8bf262876a4641a68ee06f7b39d68132b451cb (patch)
treeafa4bb30cfa9fd874a6ae908264159cafd0f216a /www/mod_php5
parent6e8000a9dd93fab19345acc85d968ae132e22749 (diff)
downloadfreebsd-ports-gnome-fa8bf262876a4641a68ee06f7b39d68132b451cb.tar.gz
freebsd-ports-gnome-fa8bf262876a4641a68ee06f7b39d68132b451cb.tar.zst
freebsd-ports-gnome-fa8bf262876a4641a68ee06f7b39d68132b451cb.zip
- extension dir is no-debug-zts-20010901 if WITH_APACHE2 is set
- extension dir has to be created if installed as a package since it is empty - move PLIST_SUB into if-clause so it actually works Submitted by: Alex Dupre <sysadmin@alexdupre.com>
Diffstat (limited to 'www/mod_php5')
-rw-r--r--www/mod_php5/Makefile6
-rw-r--r--www/mod_php5/pkg-plist3
2 files changed, 6 insertions, 3 deletions
diff --git a/www/mod_php5/Makefile b/www/mod_php5/Makefile
index 9b7c401f859c..bae9bf9669da 100644
--- a/www/mod_php5/Makefile
+++ b/www/mod_php5/Makefile
@@ -55,12 +55,14 @@ MAKE_ENV= STANDALONE="${STANDALONE}"
.if defined(WITH_APACHE2)
CONFIGURE_ARGS= --with-apxs2=${PREFIX}/sbin/apxs \
--with-tsrm-pth
-PLIST_SUB= MOD_DIR=libexec/apache2
+PLIST_SUB= MOD_DIR=libexec/apache2 \
+ NON=
.else
CONFIGURE_ARGS= --with-apxs=${PREFIX}/sbin/apxs
+PLIST_SUB= MOD_DIR=libexec/apache \
+ NON=non-
.endif
CONFIGURE_ARGS+=--with-config-file-path=${PREFIX}/etc
-PLIST_SUB= MOD_DIR=libexec/apache
.endif
CONFIGURE_ARGS+=--enable-versioning \
diff --git a/www/mod_php5/pkg-plist b/www/mod_php5/pkg-plist
index f0b897bbdbf1..c86cc458b445 100644
--- a/www/mod_php5/pkg-plist
+++ b/www/mod_php5/pkg-plist
@@ -270,6 +270,7 @@ lib/php/build/shtool
@dirrm lib/php/Schedule
@dirrm lib/php/XML
@dirrm lib/php/build
-@dirrm lib/php/extensions/no-debug-non-zts-20010901
+@dirrm lib/php/extensions/no-debug-%%NON%%zts-20010901
@dirrm lib/php/extensions
@dirrm lib/php
+@exec mkdir -p %D/lib/php/extensions/no-debug-%%NON%%zts-20010901