aboutsummaryrefslogtreecommitdiffstats
path: root/www/mod_python3/files
diff options
context:
space:
mode:
authorperky <perky@FreeBSD.org>2005-05-18 12:11:39 +0800
committerperky <perky@FreeBSD.org>2005-05-18 12:11:39 +0800
commit5590c7723668df4417c7c2e62226f1675e4c435d (patch)
treecc52f3379b488785240093827c42bf019d82a984 /www/mod_python3/files
parent526c5385e8ee7e7aa7bb367060641484c2f75351 (diff)
downloadfreebsd-ports-gnome-5590c7723668df4417c7c2e62226f1675e4c435d.tar.gz
freebsd-ports-gnome-5590c7723668df4417c7c2e62226f1675e4c435d.tar.zst
freebsd-ports-gnome-5590c7723668df4417c7c2e62226f1675e4c435d.zip
Convert a LD_PRELOAD black magic to a white one utilizing python
shared library which is provided on modern python ports. This also unbreaks build on amd64 and ia64. Requested by: lioux
Diffstat (limited to 'www/mod_python3/files')
-rw-r--r--www/mod_python3/files/patch-configure11
1 files changed, 11 insertions, 0 deletions
diff --git a/www/mod_python3/files/patch-configure b/www/mod_python3/files/patch-configure
new file mode 100644
index 000000000000..354e95a5596f
--- /dev/null
+++ b/www/mod_python3/files/patch-configure
@@ -0,0 +1,11 @@
+--- configure.orig Sun Jan 30 06:25:27 2005
++++ configure Wed May 18 12:06:06 2005
+@@ -2643,7 +2643,7 @@
+ PyLIBP=${PyEXEC_INSTALLDIR}/lib/python${PyVERSION}
+ PyLIBPL=${PyLIBP}/config
+ PyPYTHONLIBS=${PyLIBPL}/libpython${PyVERSION}.a
+-PyLIBS=`grep "^LIB[SMC]=" ${PyLIBPL}/Makefile | cut -f2 -d= | tr '\011\012\015' ' '`
++PyLIBS=`ldd $PYTHON_BIN | sed -n 's,^.* => [^ ]*/lib\(.*\)\.so[^ ]* \((.*)\),-l\1,p' | grep -v '^-lc$' | xargs echo`
+ PyMODLIBS=`grep "^LOCALMODLIBS=" ${PyLIBPL}/Makefile | cut -f2 -d= | tr '\011\012\015' ' '`
+ PyFRAMEWORK=`grep "^PYTHONFRAMEWORK=" ${PyLIBPL}/Makefile | cut -f2 -d= | tr '\011\012\015' ' '`
+ PyFRAMEWORKDIR=`grep "^PYTHONFRAMEWORKDIR=" ${PyLIBPL}/Makefile | cut -f2 -d= | tr '\011\012\015' ' ' | awk '{print $1}'`