aboutsummaryrefslogtreecommitdiffstats
path: root/www/mod_python33
diff options
context:
space:
mode:
authorohauer <ohauer@FreeBSD.org>2014-04-17 06:31:32 +0800
committerohauer <ohauer@FreeBSD.org>2014-04-17 06:31:32 +0800
commit84abfe3b8cf2fc408b48c80201268a7539a0d4bf (patch)
tree20141268b1598f622c75e1caadcde56da28fb082 /www/mod_python33
parent27c03d830b3b98e53515fe062cec898e6aae6ec2 (diff)
downloadfreebsd-ports-gnome-84abfe3b8cf2fc408b48c80201268a7539a0d4bf.tar.gz
freebsd-ports-gnome-84abfe3b8cf2fc408b48c80201268a7539a0d4bf.tar.zst
freebsd-ports-gnome-84abfe3b8cf2fc408b48c80201268a7539a0d4bf.zip
- fix filesystem touch before install (mod_python33)
- add CONFLICTS_INSTALL - install egg-info to shut up the qa script (no cherry picking ;( - rework module installation - bump PORTREVISION Noted by swills@
Diffstat (limited to 'www/mod_python33')
-rw-r--r--www/mod_python33/Makefile7
-rw-r--r--www/mod_python33/files/patch-Makefile.in10
-rw-r--r--www/mod_python33/pkg-plist6
3 files changed, 9 insertions, 14 deletions
diff --git a/www/mod_python33/Makefile b/www/mod_python33/Makefile
index e5c7101a35b3..3bdb2654e50c 100644
--- a/www/mod_python33/Makefile
+++ b/www/mod_python33/Makefile
@@ -3,7 +3,7 @@
PORTNAME= mod_python
PORTVERSION= 3.3.1
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= www python
MASTER_SITES= ${MASTER_SITE_APACHE_HTTPD}
MASTER_SITE_SUBDIR= modpython
@@ -16,11 +16,12 @@ COMMENT= Apache module that embeds the Python interpreter within the server
LICENSE= APACHE20
+CONFLICTS_INSTALL= ap2[24]-mod_python3[^3]*
+
USE_APACHE= 22
USE_PYTHON= yes
USES= tar:tgz
-INSTALLS_EGGINFO= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --with-apxs="${APXS}" \
--with-python="${PYTHON_CMD}" \
@@ -29,6 +30,8 @@ CONFIGURE_ARGS+= --with-apxs="${APXS}" \
LDFLAGS+= -L${LOCALBASE}/lib
MAKE_ARGS+= APXS=${APXS}
MAKE_ENV= EXPR_COMPAT=yes
+PLIST_SUB+= PORTVERSION=${PORTVERSION} \
+ PYTHON_VER=${PYTHON_VER}
# You need to install apache & mod_python before you run this
regression-test: build
diff --git a/www/mod_python33/files/patch-Makefile.in b/www/mod_python33/files/patch-Makefile.in
deleted file mode 100644
index bde1f5bc7fff..000000000000
--- a/www/mod_python33/files/patch-Makefile.in
+++ /dev/null
@@ -1,10 +0,0 @@
---- ./Makefile.in.orig 2010-06-08 21:02:59.711010209 -0400
-+++ ./Makefile.in 2010-06-08 21:06:55.645681728 -0400
-@@ -61,6 +61,7 @@
- @echo
- $(INSTALL) -d $(DESTDIR)$(LIBEXECDIR)
- $(INSTALL) src/mod_python.so $(DESTDIR)$(LIBEXECDIR)
-+ ${APXS} -e -a -n python $(DESTDIR)$(LIBEXECDIR)/mod_python.so
- @echo
- @echo "Now don't forget to edit your main config and add"
- @echo " LoadModule python_module $(LIBEXECDIR)/mod_python.so"
diff --git a/www/mod_python33/pkg-plist b/www/mod_python33/pkg-plist
index 329677302b98..958ee2e1bdcd 100644
--- a/www/mod_python33/pkg-plist
+++ b/www/mod_python33/pkg-plist
@@ -1,3 +1,4 @@
+%%PYTHON_SITELIBDIR%%/mod_python-%%PORTVERSION%%-py%%PYTHON_VER%%.egg-info
%%PYTHON_SITELIBDIR%%/mod_python/Cookie.py
%%PYTHON_SITELIBDIR%%/mod_python/Cookie.pyc
%%PYTHON_SITELIBDIR%%/mod_python/Cookie.pyo
@@ -35,7 +36,8 @@
%%PYTHON_SITELIBDIR%%/mod_python/util.py
%%PYTHON_SITELIBDIR%%/mod_python/util.pyc
%%PYTHON_SITELIBDIR%%/mod_python/util.pyo
+@unexec /usr/bin/sed -i '' '/LoadModule %%AP_NAME%%_module/d' %D/%%APACHEETCDIR%%/httpd.conf
%%APACHEMODDIR%%/%%AP_MODULE%%
-@exec %D/sbin/apxs -e -a -n %%AP_NAME%% %D/%F
-@unexec %D/sbin/apxs -e -A -n %%AP_NAME%% %D/%F
+@exec %D/sbin/apxs -e %%AP_MOD_EN%% -n %%AP_NAME%% %D/%F
+@unexec echo "Don't forget to remove all mod_%%AP_NAME%%-related directives in your httpd.conf"
@dirrm %%PYTHON_SITELIBDIR%%/mod_python