aboutsummaryrefslogtreecommitdiffstats
path: root/www/mod_python3
diff options
context:
space:
mode:
authorperky <perky@FreeBSD.org>2006-08-09 09:10:14 +0800
committerperky <perky@FreeBSD.org>2006-08-09 09:10:14 +0800
commit8ebc95274103aa174de61a92e080b9a02a2142af (patch)
tree49b10bb9383d9159f1b9821ad81b434baa319657 /www/mod_python3
parent226ba1ecbeef3479c5cda993cd48cd2ff6961c6d (diff)
downloadfreebsd-ports-gnome-8ebc95274103aa174de61a92e080b9a02a2142af.tar.gz
freebsd-ports-gnome-8ebc95274103aa174de61a92e080b9a02a2142af.tar.zst
freebsd-ports-gnome-8ebc95274103aa174de61a92e080b9a02a2142af.zip
Update to 3.2.10 which is compatible with Apache 2.2 also.
PR: 100208 Submitted by: Mark Evenson <mark.evenson@gmx.at>, Nick Pavlica <znpmail@yahoo.com>, Nikolai Nespor <nikolai.nespor@utanet.at>
Diffstat (limited to 'www/mod_python3')
-rw-r--r--www/mod_python3/Makefile2
-rw-r--r--www/mod_python3/distinfo6
-rw-r--r--www/mod_python3/files/patch-configure8
-rw-r--r--www/mod_python3/files/patch-src_include_mod_python.h.in13
4 files changed, 8 insertions, 21 deletions
diff --git a/www/mod_python3/Makefile b/www/mod_python3/Makefile
index d7d65d7307a4..6350f2728e66 100644
--- a/www/mod_python3/Makefile
+++ b/www/mod_python3/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= mod_python
-PORTVERSION= 3.2.8
+PORTVERSION= 3.2.10
CATEGORIES= www python
MASTER_SITES= ${MASTER_SITE_APACHE_HTTPD}
MASTER_SITE_SUBDIR= modpython
diff --git a/www/mod_python3/distinfo b/www/mod_python3/distinfo
index 4128b06a0332..ccb70446a8b4 100644
--- a/www/mod_python3/distinfo
+++ b/www/mod_python3/distinfo
@@ -1,3 +1,3 @@
-MD5 (mod_python-3.2.8.tgz) = d03452979a6a334f73cc2b95b39db331
-SHA256 (mod_python-3.2.8.tgz) = 414c0a8b149381f9f1c2e3f045269f64fcd96beab12a6720dfedf34154095813
-SIZE (mod_python-3.2.8.tgz) = 353131
+MD5 (mod_python-3.2.10.tgz) = cc6439f546a6e70cfff7ca51b8c62541
+SHA256 (mod_python-3.2.10.tgz) = ac404c02ee052dcfbd8e303fe9148866c561be9b9a8a12cffee25276e147f13c
+SIZE (mod_python-3.2.10.tgz) = 365768
diff --git a/www/mod_python3/files/patch-configure b/www/mod_python3/files/patch-configure
index 354e95a5596f..e979f312021d 100644
--- a/www/mod_python3/files/patch-configure
+++ b/www/mod_python3/files/patch-configure
@@ -1,7 +1,7 @@
---- configure.orig Sun Jan 30 06:25:27 2005
-+++ configure Wed May 18 12:06:06 2005
-@@ -2643,7 +2643,7 @@
- PyLIBP=${PyEXEC_INSTALLDIR}/lib/python${PyVERSION}
+--- configure.orig Sat Aug 5 09:51:23 2006
++++ configure Sat Aug 5 09:57:47 2006
+@@ -2899,7 +2899,7 @@
+ PyLIBP=${PY_STD_LIB}
PyLIBPL=${PyLIBP}/config
PyPYTHONLIBS=${PyLIBPL}/libpython${PyVERSION}.a
-PyLIBS=`grep "^LIB[SMC]=" ${PyLIBPL}/Makefile | cut -f2 -d= | tr '\011\012\015' ' '`
diff --git a/www/mod_python3/files/patch-src_include_mod_python.h.in b/www/mod_python3/files/patch-src_include_mod_python.h.in
deleted file mode 100644
index 68d2d97fceaa..000000000000
--- a/www/mod_python3/files/patch-src_include_mod_python.h.in
+++ /dev/null
@@ -1,13 +0,0 @@
---- src/include/mod_python.h.in.orig Fri Mar 24 20:30:57 2006
-+++ src/include/mod_python.h.in Fri Mar 24 20:31:35 2006
-@@ -117,6 +117,10 @@
- #define LONG_LONG PY_LONG_LONG
- #endif
-
-+#ifndef APR_STATUS_IS_SUCCESS
-+#define APR_STATUS_IS_SUCCESS(s) ((s) == APR_SUCCESS )
-+#endif
-+
- /* structure to hold interpreter data */
- typedef struct {
- PyInterpreterState *istate;