aboutsummaryrefslogtreecommitdiffstats
path: root/www/mod_python3
diff options
context:
space:
mode:
authorpetef <petef@FreeBSD.org>2001-11-06 22:24:29 +0800
committerpetef <petef@FreeBSD.org>2001-11-06 22:24:29 +0800
commitba501e97ac14eed576a42c266ef08faf3cdb3886 (patch)
treeb0bd1f2739afbd6c879ee629f6424c18bf4bb2ef /www/mod_python3
parent68dd498d86d21c384ceea783479ea457c3e40ad2 (diff)
downloadfreebsd-ports-gnome-ba501e97ac14eed576a42c266ef08faf3cdb3886.tar.gz
freebsd-ports-gnome-ba501e97ac14eed576a42c266ef08faf3cdb3886.tar.zst
freebsd-ports-gnome-ba501e97ac14eed576a42c266ef08faf3cdb3886.zip
- Remove old maintainer from pkg-descr
- Fix pkg-req script -Set NO_PACKAGE, as this port requires Python without threads support PR: 31273 Submitted by: Anders Nordby <anders@fix.no>
Diffstat (limited to 'www/mod_python3')
-rw-r--r--www/mod_python3/Makefile3
-rw-r--r--www/mod_python3/pkg-descr2
-rw-r--r--www/mod_python3/pkg-req.threads6
3 files changed, 5 insertions, 6 deletions
diff --git a/www/mod_python3/Makefile b/www/mod_python3/Makefile
index 4607721957a2..f41eca5fc62c 100644
--- a/www/mod_python3/Makefile
+++ b/www/mod_python3/Makefile
@@ -18,6 +18,7 @@ MAINTAINER= ports@FreeBSD.org
BUILD_DEPENDS= ${LOCALBASE}/sbin/apxs:${PORTSDIR}/www/apache13
RUN_DEPENDS= ${LOCALBASE}/sbin/apxs:${PORTSDIR}/www/apache13
+NO_PACKAGE= "Requires Python without threads support"
USE_PYTHON= yes
.include <bsd.port.pre.mk>
@@ -44,7 +45,7 @@ pre-patch:
.endif
post-configure:
- @${SH} ${PKGREQ}.threads ${PYTHON_CMD} ${PYTHON_BASE}
+ @${SH} ${PKGREQ}.threads ${PYTHON_CMD}
.if defined(OPTIONAL_LIBS)
${SED} 's/^\(LIBS=.*\)/\1 ${OPTIONAL_LIBS}/' ${WRKSRC}/src/Makefile \
> ${WRKSRC}/src/Makefile.tmp && \
diff --git a/www/mod_python3/pkg-descr b/www/mod_python3/pkg-descr
index 91ea4859de0f..ddf915e4d8f5 100644
--- a/www/mod_python3/pkg-descr
+++ b/www/mod_python3/pkg-descr
@@ -7,5 +7,3 @@ developed by Gregory Trubetskoy <grisha@modpython.org> and others
This port requires a Python installation without threads support. Build &
(re)install Python with WITHOUT_THREADS set.
-
-- Anders Nordby <anders@fix.no>
diff --git a/www/mod_python3/pkg-req.threads b/www/mod_python3/pkg-req.threads
index d3526527fe90..5328a30cedb5 100644
--- a/www/mod_python3/pkg-req.threads
+++ b/www/mod_python3/pkg-req.threads
@@ -1,18 +1,18 @@
#! /bin/sh
# anders@fix.no, 2001-08-07
-mydir=`dirname $0`
+pydir=`dirname $1 | sed "s/\/bin//"`
mylibc=`ldd $1 | tail +2 | awk '{print $1}' | cut -d'.' -f1 | grep ^libc`
case $mylibc in
libc_r)
- echo "Error: Python installation in $2 uses threads. mod_python requires"
+ echo "Error: Python installation in $pydir uses threads. mod_python requires"
echo "it to be built without threads. Please deinstall & rebuild/reinstall Python with"
echo "WITHOUT_THREADS set."
exit 1
;;
libc)
- echo "Using a no-threads Python installation (PREFIX $2). Good."
+ echo "Using a no-threads Python installation (in $pydir). Good."
exit 0
;;
*)