aboutsummaryrefslogtreecommitdiffstats
path: root/www/mod_python
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2002-09-10 02:30:10 +0800
committerdinoex <dinoex@FreeBSD.org>2002-09-10 02:30:10 +0800
commit6c46a7461e8f359392cd8a6bb9c1a9272893dfb1 (patch)
tree3384b1a80aa47eb892ecce3af73f9fd8396a1438 /www/mod_python
parentc9881ccf7b121fbd9d1a735601e15d1e3d438bde (diff)
downloadfreebsd-ports-gnome-6c46a7461e8f359392cd8a6bb9c1a9272893dfb1.tar.gz
freebsd-ports-gnome-6c46a7461e8f359392cd8a6bb9c1a9272893dfb1.tar.zst
freebsd-ports-gnome-6c46a7461e8f359392cd8a6bb9c1a9272893dfb1.zip
support appache13-modssl by defining APACHE_PORT in /etc/make.conf
others variants of the apache ports can be used too.
Diffstat (limited to 'www/mod_python')
-rw-r--r--www/mod_python/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/www/mod_python/Makefile b/www/mod_python/Makefile
index 591db4ae4e58..dd217311cd59 100644
--- a/www/mod_python/Makefile
+++ b/www/mod_python/Makefile
@@ -15,8 +15,8 @@ EXTRACT_SUFX= .tgz
MAINTAINER= ports@FreeBSD.org
-BUILD_DEPENDS= ${LOCALBASE}/sbin/apxs:${PORTSDIR}/www/apache13
-RUN_DEPENDS= ${LOCALBASE}/sbin/apxs:${PORTSDIR}/www/apache13
+BUILD_DEPENDS= ${APXS}:${APACHE_PORT}
+RUN_DEPENDS= ${APXS}:${APACHE_PORT}
NO_PACKAGE= "Requires Python without threads support"
USE_PYTHON= yes
@@ -24,6 +24,7 @@ USE_PYTHON= yes
.include <bsd.port.pre.mk>
APXS?= ${LOCALBASE}/sbin/apxs
+APACHE_PORT?= ${PORTSDIR}/www/apache13
GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --with-apxs=${APXS}