aboutsummaryrefslogtreecommitdiffstats
path: root/www/mod_webapp-apache2
diff options
context:
space:
mode:
authorznerd <znerd@FreeBSD.org>2002-10-19 04:20:54 +0800
committerznerd <znerd@FreeBSD.org>2002-10-19 04:20:54 +0800
commit3a7c23aab1e514b27646fe491c08120683d7edab (patch)
tree797f23c4171cf0f1c7385c150173b37a0e8d0e5a /www/mod_webapp-apache2
parent8efcc15dd5272ca2cfe274fc4b3ec59fdc565a37 (diff)
downloadfreebsd-ports-gnome-3a7c23aab1e514b27646fe491c08120683d7edab.tar.gz
freebsd-ports-gnome-3a7c23aab1e514b27646fe491c08120683d7edab.tar.zst
freebsd-ports-gnome-3a7c23aab1e514b27646fe491c08120683d7edab.zip
New port: mod_webapp for Apache 2.x.
This is an Apache module that integrates with Tomcat 4.x. PR: 43952 Submitted by: Andrew Gerweck <andy@gerweck.dyndns.org>
Diffstat (limited to 'www/mod_webapp-apache2')
-rw-r--r--www/mod_webapp-apache2/Makefile73
-rw-r--r--www/mod_webapp-apache2/distinfo1
-rw-r--r--www/mod_webapp-apache2/pkg-comment1
-rw-r--r--www/mod_webapp-apache2/pkg-descr8
-rw-r--r--www/mod_webapp-apache2/pkg-plist3
5 files changed, 86 insertions, 0 deletions
diff --git a/www/mod_webapp-apache2/Makefile b/www/mod_webapp-apache2/Makefile
new file mode 100644
index 000000000000..2eca0cf246b2
--- /dev/null
+++ b/www/mod_webapp-apache2/Makefile
@@ -0,0 +1,73 @@
+# Ports collection makefile for: mod_webapp for Apache 2.x
+# Date created: Oct 11 2002
+# Whom: Andy Gerweck <gerweck@yahoo.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mod_webapp
+PORTVERSION= 4.1.12
+CATEGORIES= www
+MASTER_SITES= http://jakarta.apache.org/builds/jakarta-tomcat-4.0/release/v${TOMCAT_RELEASE}/src/
+PKGNAMESUFFIX= -apache2
+DISTNAME= jakarta-tomcat-connectors-${CONNECTORS_RELEASE}-src
+DIST_SUBDIR= ${PORTNAME}
+
+MAINTAINER= gerweck@yahoo.com
+
+BUILD_DEPENDS= ${NONEXISTENT}:${PORTSDIR}/www/apache2:extract \
+ ${AUTOCONF}:${PORTSDIR}/devel/autoconf \
+ ${LIBTOOL}:${PORTSDIR}/devel/libtool
+RUN_DEPENDS= ${APXS}:${PORTSDIR}/www/apache2
+
+USE_GMAKE= yes
+ALL_TARGET= lib-build apache-2.0-build
+
+# Release information for distribution files.
+TOMCAT_RELEASE= ${PORTVERSION}
+CONNECTORS_RELEASE= ${PORTVERSION}
+
+.include <bsd.port.pre.mk>
+
+# Apache locations.
+APXS?= ${LOCALBASE}/sbin/apxs
+APACHECTL?= ${LOCALBASE}/sbin/apachectl
+APR_LIB?= ${LOCALBASE}/lib/apache2/
+APR_INCLUDE?= ${LOCALBASE}/include/apache2/
+APACHE_MODULES?= libexec/apache2/
+APR_SRC?= ${PORTSDIR}/www/apache2/work/httpd-*/srclib/apr
+LIBTOOL?= ${LOCALBASE}/bin/libtool
+AUTOCONF?= ${LOCALBASE}/bin/autoconf
+
+# If the user's changed the modules directory, pack things correctly.
+PLIST_SUB= APACHE_MODULES=${APACHE_MODULES}
+
+# Build options.
+VERSION_2!= ${APACHECTL} -v | ${GREP} Apache/2 || true
+.if empty(VERSION_2)
+BROKEN= "Either can't find apachectl or you seem to be using Apache 1.3, which is unsupported"
+.endif
+WRKSRC= ${WRKDIR}/${DISTNAME}/webapp
+HAS_CONFIGURE= yes
+CONFIGURE_ARGS= --with-apxs=${APXS} \
+ --with-apr-lib=${APR_LIB} \
+ --with-apr-include=${APR_INCLUDE} \
+ --with-apr=${APR_SRC}
+
+pre-configure:
+ cd ${WRKSRC} && ${AUTOCONF}
+
+pre-build:
+ ${MKDIR} ${WRKSRC}/build
+ ${MKDIR} ${WRKSRC}/build/objs
+
+do-install:
+ ${APXS} -i -a ${WRKSRC}/apache-2.0/mod_webapp.so
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${PREFIX}/share/doc/mod_webapp
+ ${INSTALL_MAN} ${WRKSRC}/INSTALL.txt ${PREFIX}/share/doc/mod_webapp
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/www/mod_webapp-apache2/distinfo b/www/mod_webapp-apache2/distinfo
new file mode 100644
index 000000000000..fc1fc776dde8
--- /dev/null
+++ b/www/mod_webapp-apache2/distinfo
@@ -0,0 +1 @@
+MD5 (mod_webapp/jakarta-tomcat-connectors-4.1.12-src.tar.gz) = 669254eae8d7a6dda6f58053fedc978b
diff --git a/www/mod_webapp-apache2/pkg-comment b/www/mod_webapp-apache2/pkg-comment
new file mode 100644
index 000000000000..7df639b4ecb1
--- /dev/null
+++ b/www/mod_webapp-apache2/pkg-comment
@@ -0,0 +1 @@
+Apache module mounts Tomcat web applications
diff --git a/www/mod_webapp-apache2/pkg-descr b/www/mod_webapp-apache2/pkg-descr
new file mode 100644
index 000000000000..75ed5c9595e1
--- /dev/null
+++ b/www/mod_webapp-apache2/pkg-descr
@@ -0,0 +1,8 @@
+Mod_webapp is an Apache module that allows Tomcat applications to be
+mounted into an Apache server. Tomcat is a Java servlet and jsp engine.
+Apache is the popular webserver.
+
+WWW: http://jakarta.apache.org/tomcat/
+
+- Andy Gerweck
+gerweck@yahoo.com
diff --git a/www/mod_webapp-apache2/pkg-plist b/www/mod_webapp-apache2/pkg-plist
new file mode 100644
index 000000000000..fdc1d699fc82
--- /dev/null
+++ b/www/mod_webapp-apache2/pkg-plist
@@ -0,0 +1,3 @@
+%%APACHE_MODULES%%/mod_webapp.so
+%%PORTDOCS%%share/doc/mod_webapp/INSTALL.txt
+%%PORTDOCS%%@dirrm share/doc/mod_webapp