aboutsummaryrefslogtreecommitdiffstats
path: root/www/mozilla-devel
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2004-07-09 00:57:32 +0800
committermarcus <marcus@FreeBSD.org>2004-07-09 00:57:32 +0800
commitd1481a6de0cada627eceb9611481b57bf9ff113d (patch)
tree94d89423260065a6280651be35a9633c14a2395b /www/mozilla-devel
parentf62bd49bf52d14397b433486ef7ed4eca89ea444 (diff)
downloadfreebsd-ports-gnome-d1481a6de0cada627eceb9611481b57bf9ff113d.tar.gz
freebsd-ports-gnome-d1481a6de0cada627eceb9611481b57bf9ff113d.tar.zst
freebsd-ports-gnome-d1481a6de0cada627eceb9611481b57bf9ff113d.zip
Fix a build problem with -Bsymbolic on Alpha and ia64.
Reported by: Randy Sato <rsato@mac.com>
Diffstat (limited to 'www/mozilla-devel')
-rw-r--r--www/mozilla-devel/files/patch-security::coreconf::FreeBSD.mk19
1 files changed, 17 insertions, 2 deletions
diff --git a/www/mozilla-devel/files/patch-security::coreconf::FreeBSD.mk b/www/mozilla-devel/files/patch-security::coreconf::FreeBSD.mk
index caabfc098e9f..b2dbddeea6df 100644
--- a/www/mozilla-devel/files/patch-security::coreconf::FreeBSD.mk
+++ b/www/mozilla-devel/files/patch-security::coreconf::FreeBSD.mk
@@ -1,5 +1,5 @@
--- security/coreconf/FreeBSD.mk.orig Wed Mar 26 20:17:25 2003
-+++ security/coreconf/FreeBSD.mk Fri Mar 19 15:52:59 2004
++++ security/coreconf/FreeBSD.mk Thu Jul 8 12:56:24 2004
@@ -35,16 +35,18 @@
include $(CORE_DEPTH)/coreconf/UNIX.mk
@@ -22,12 +22,27 @@
OS_CFLAGS = $(DSO_CFLAGS) -ansi -Wall -DFREEBSD -DHAVE_STRERROR -DHAVE_BSD_FLOCK
-@@ -71,7 +73,7 @@
+@@ -57,8 +59,8 @@
+ ifndef CLASSIC_NSPR
+ USE_PTHREADS = 1
+ DEFINES += -D_THREAD_SAFE -D_REENTRANT
+-OS_LIBS += -pthread
+-DSO_LDOPTS += -pthread
++OS_LIBS += -lpthread
++DSO_LDOPTS += -lpthread
+ endif
+
+ ARCH = freebsd
+@@ -71,7 +73,11 @@
DLL_SUFFIX = so.1.0
endif
-MKSHLIB = $(CC) $(DSO_LDOPTS)
++ifneq (,$(filter alpha ia64,$(OS_TEST)))
++MKSHLIB = $(CC) -Wl,-Bsymbolic -lc $(DSO_LDOPTS) -o $@
++else
+MKSHLIB = $(CC) -Wl,-Bsymbolic $(DSO_LDOPTS) -o $@
++endif
ifdef MAPFILE
# Add LD options to restrict exported symbols to those in the map file
endif