aboutsummaryrefslogtreecommitdiffstats
path: root/www/mozilla-devel
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2004-02-26 17:41:11 +0800
committermarcus <marcus@FreeBSD.org>2004-02-26 17:41:11 +0800
commit57014111aa63a12acceea0f84c4f00e7352e45d5 (patch)
treebf30e8de5c40cf64373b74e647096e2455a8894f /www/mozilla-devel
parent2c53f1f0924a7b1d3b9c96d3dd9dd79ae5a6df03 (diff)
downloadfreebsd-ports-gnome-57014111aa63a12acceea0f84c4f00e7352e45d5.tar.gz
freebsd-ports-gnome-57014111aa63a12acceea0f84c4f00e7352e45d5.tar.zst
freebsd-ports-gnome-57014111aa63a12acceea0f84c4f00e7352e45d5.zip
* Fix a compilation issue on -STABLE [1]
* Correct the path to libfreetype to fix an initialization error in the SVG renderer Reported by: adamw [1]
Diffstat (limited to 'www/mozilla-devel')
-rw-r--r--www/mozilla-devel/Makefile4
-rw-r--r--www/mozilla-devel/files/extra-patch-nsSVGLibartGlyphMetricsFT.cpp43
2 files changed, 46 insertions, 1 deletions
diff --git a/www/mozilla-devel/Makefile b/www/mozilla-devel/Makefile
index 0fef9580fd96..d5bad320d02e 100644
--- a/www/mozilla-devel/Makefile
+++ b/www/mozilla-devel/Makefile
@@ -7,7 +7,7 @@
PORTNAME?= mozilla
PORTVERSION= 1.7.a
-PORTREVISION?= 0
+PORTREVISION?= 1
PORTEPOCH?= 2
CATEGORIES?= www
MASTER_SITES= ${MASTER_SITE_MOZILLA}
@@ -223,6 +223,8 @@ post-patch:
${WRKSRC}/configure \
${WRKSRC}/intl/uconv/native/nsNativeUConvService.cpp \
${WRKSRC}/xpcom/io/nsNativeCharsetUtils.cpp
+ @${REINPLACE_CMD} -e 's|libfreetype.so.6|libfreetype.so.9|g' \
+ ${WRKSRC}/modules/libpref/src/init/all.js
@for pcfile in ${PKGCONFIG_FILES}; do \
${REINPLACE_CMD} -e 's|mozilla-xpcom|mozilla-xpcom${MOZ_SUFX}${PKGNAMESUFFIX}|g ; \
s|mozilla-nspr|mozilla-nspr${MOZ_SUFX}${PKGNAMESUFFIX}|g' \
diff --git a/www/mozilla-devel/files/extra-patch-nsSVGLibartGlyphMetricsFT.cpp b/www/mozilla-devel/files/extra-patch-nsSVGLibartGlyphMetricsFT.cpp
new file mode 100644
index 000000000000..be76e019d074
--- /dev/null
+++ b/www/mozilla-devel/files/extra-patch-nsSVGLibartGlyphMetricsFT.cpp
@@ -0,0 +1,43 @@
+--- layout/svg/renderer/src/libart/nsSVGLibartGlyphMetricsFT.cpp.orig Thu Feb 26 02:13:35 2004
++++ layout/svg/renderer/src/libart/nsSVGLibartGlyphMetricsFT.cpp Thu Feb 26 03:27:56 2004
+@@ -56,6 +57,13 @@
+ #include "nsArray.h"
+ #include "nsDataHashtable.h"
+
++
++#ifdef HAVE_CPP_2BYTE_WCHAR_T
++ typedef nsDependentString nsLiteralString;
++#else
++ typedef NS_ConvertASCIItoUTF16 nsLiteralString;
++#endif
++
+ /**
+ * \addtogroup libart_renderer Libart Rendering Engine
+ * @{
+@@ -112,7 +120,7 @@
+ nsCOMPtr<nsISVGGlyphMetricsSource> mSource;
+
+ public:
+- static nsDataHashtable<nsStringHashKey,nsDependentString*> sFontAliases;
++ static nsDataHashtable<nsStringHashKey,nsLiteralString*> sFontAliases;
+ };
+
+ /** @} */
+@@ -120,7 +128,7 @@
+ //----------------------------------------------------------------------
+ // nsSVGLibartGlyphMetricsFT implementation:
+
+-nsDataHashtable<nsStringHashKey,nsDependentString*>
++nsDataHashtable<nsStringHashKey,nsLiteralString*>
+ nsSVGLibartGlyphMetricsFT::sFontAliases;
+
+
+@@ -406,7 +414,7 @@
+ }
+ else {
+ // try alias if there is one:
+- nsDependentString *alias = nsnull;
++ nsLiteralString *alias = nsnull;
+ nsSVGLibartGlyphMetricsFT::sFontAliases.Get(NS_ConvertUTF8toUCS2(family_name),
+ &alias);
+ if (alias) {