aboutsummaryrefslogtreecommitdiffstats
path: root/www/mozilla-headers-devel/Makefile
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2002-04-14 01:06:30 +0800
committermarcus <marcus@FreeBSD.org>2002-04-14 01:06:30 +0800
commit1caadb6517f2445949ddd167e1934429c8a29a64 (patch)
tree88a6c657616965969da0e297fed2adfb14135b8c /www/mozilla-headers-devel/Makefile
parent51f19cd19f8734caa6d726efd82cc0f70ffdad01 (diff)
downloadfreebsd-ports-gnome-1caadb6517f2445949ddd167e1934429c8a29a64.tar.gz
freebsd-ports-gnome-1caadb6517f2445949ddd167e1934429c8a29a64.tar.zst
freebsd-ports-gnome-1caadb6517f2445949ddd167e1934429c8a29a64.zip
Allow installed files to have correct permissions when built by a non-root
user. PR: 35980 Submitted by: Alan Eldridge <ports@geeksrus.net> Reviewed by: sobomax Approved by: sobomax
Diffstat (limited to 'www/mozilla-headers-devel/Makefile')
-rw-r--r--www/mozilla-headers-devel/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/www/mozilla-headers-devel/Makefile b/www/mozilla-headers-devel/Makefile
index 6d584cc42f88..993322d945d8 100644
--- a/www/mozilla-headers-devel/Makefile
+++ b/www/mozilla-headers-devel/Makefile
@@ -27,9 +27,10 @@ USE_GMAKE= yes
ALL_TARGET= export
do-install:
+ -${RM} -fr ${PREFIX}/include/mozilla
${MKDIR} ${PREFIX}/include/mozilla
${CHMOD} 755 ${PREFIX}/include/mozilla
- ${TAR} -C ${WRKSRC}/dist/include -chf - . | \
- ${TAR} -C ${PREFIX}/include/mozilla --unlink -xf -
+ cd ${WRKSRC}/dist/include && ${FIND} . | \
+ cpio -pdm -L -R ${INCOWN}:${INCGRP} ${PREFIX}/include/mozilla
.include <bsd.port.mk>