aboutsummaryrefslogtreecommitdiffstats
path: root/www/mozilla/Makefile
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2003-04-04 15:04:20 +0800
committermarcus <marcus@FreeBSD.org>2003-04-04 15:04:20 +0800
commit488ea48034914a7539b772a518379eac4934191b (patch)
tree7d203f19ccf48da83dfdfd4c51f6b78378c73bec /www/mozilla/Makefile
parentbd912bdbcf2382d728fe88d869f258a94a7cb6b1 (diff)
downloadfreebsd-ports-gnome-488ea48034914a7539b772a518379eac4934191b.tar.gz
freebsd-ports-gnome-488ea48034914a7539b772a518379eac4934191b.tar.zst
freebsd-ports-gnome-488ea48034914a7539b772a518379eac4934191b.zip
* Update to 1.3
* Default to building with -O2 optimizations [1] * Fix a bug where dead keys could not be used [2] PR: 49010 [2] Obtained from: www/phoenix [1] http://bugzilla.mozilla.org/show_bug.cgi?id=176713 [2]
Diffstat (limited to 'www/mozilla/Makefile')
-rw-r--r--www/mozilla/Makefile46
1 files changed, 32 insertions, 14 deletions
diff --git a/www/mozilla/Makefile b/www/mozilla/Makefile
index e5f73de8c6d5..1dbd257cf310 100644
--- a/www/mozilla/Makefile
+++ b/www/mozilla/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME?= mozilla
-PORTVERSION= 1.2.1
-PORTREVISION?= 1
+PORTVERSION= 1.3
PORTEPOCH?= 2
CATEGORIES?= www
MASTER_SITES= ${MASTER_SITE_MOZILLA} \
@@ -15,7 +14,7 @@ MASTER_SITES= ${MASTER_SITE_MOZILLA} \
MASTER_SITE_SUBDIR= mozilla/releases/${PORTNAME}${PORTVERSION:S/.rc/rc/}/src \
marcus/:local
DISTFILES= ${PORTNAME}-source-${PORTVERSION:S/.rc/rc/}${EXTRACT_SUFX} \
- libart_lgpl-${PORTVERSION}${EXTRACT_SUFX}:local
+ libart_lgpl${EXTRACT_SUFX}:local
MAINTAINER= gnome@FreeBSD.org
COMMENT= The open source, standards compliant web browser
@@ -31,13 +30,12 @@ WRKSRC= ${WRKDIR}/${PORTNAME}
MOZILLA?= mozilla
-WITHOUT_CHATZILLA= "Contains a buffer overflow reported at http://online.securityfocus.com/archive/1/270249"
-
.if defined(WITH_GTK2)
LIB_DEPENDS+= gtk-x11-2.0.200:${PORTSDIR}/x11-toolkits/gtk20 \
ORBit-2.0:${PORTSDIR}/devel/ORBit2
.else
-USE_GNOME= gtk12
+USE_GNOMENG= yes
+USE_GNOME= gtk12 orbit
.endif
.if !defined(WITHOUT_XFT)
@@ -48,13 +46,17 @@ BROKEN= Mozilla and Xft2 render the mozilla-fonts \
.endif
.endif
+.if defined(WITH_CALENDAR) && (defined(WITHOUT_MAILNEWS) || \
+ defined(WITHOUT_COMPOSER))
+BROKEN= "Calendar requires Composer and Mailnews support."
+.endif
+
.if defined(WITH_CALENDAR)
-DISTFILES+= ${PORTNAME}-calendar-${PORTVERSION}${EXTRACT_SUFX}:local
LIB_DEPENDS+= ical.0:${PORTSDIR}/devel/libical
.endif
-USE_BZIP2= yes
LATEST_LINK= ${MOZILLA}
+USE_BZIP2= yes
EXTRACT_AFTER_ARGS= | ${TAR} -xf - --exclude */CVS/* \
--exclude */macbuild/*\
--exclude */package/* \
@@ -77,22 +79,19 @@ CONFIGURE_ARGS= \
--enable-mathml \
--disable-md \
--disable-pedantic \
+ --disable-bidi \
--disable-plaintext-editor-only \
--enable-strip \
--enable-svg \
--disable-tests \
--disable-xterm-updates \
--enable-xinerama \
+ --with-system-zlib \
--with-system-jpeg=${LOCALBASE} \
--with-system-mng=${LOCALBASE} \
--with-system-png=${LOCALBASE} \
--with-pthreads
-.if !defined(WITH_GTK2)
-USE_GNOMENG= yes
-USE_GNOME+= orbit
-.endif
-
PLIST= ${WRKDIR}/pkg-plist
# LDAP is only used by mail and news so disable both together
.if defined(WITHOUT_MAILNEWS)
@@ -116,6 +115,9 @@ CONFIGURE_ENV= MOZ_INTERNAL_LIBART_LGPL=1
.if defined(WITH_JAVASCRIPT_DEBUGGER)
CONFIGURE_ARGS+= --enable-jsd \
--enable-dtd-debug
+.else
+CONFIGURE_ARGS+= --disable-jsd \
+ --disable-dtd-debug
.endif
.if defined(WITH_CALENDAR)
@@ -129,9 +131,9 @@ CONFIGURE_ARGS+= --disable-composer
.if defined(WITH_GTK2)
CONFIGURE_ARGS+= --enable-default-toolkit=gtk2
-EXTRA_PATCHES= ${FILESDIR}/mozilla_12b_patch
PKGCONFIG_FILES= mozilla-gtkmozembed.pc mozilla-js.pc mozilla-xpcom.pc \
mozilla-nspr.pc mozilla-nss.pc
+EXTRA_PATCHES= ${FILESDIR}/xim_dekita2.patch
.else
CONFIGURE_ARGS+= --enable-default-toolkit=gtk
.endif
@@ -150,7 +152,12 @@ ALL_TARGET= default
CONFIGURE_ARGS+= --enable-reorder
.endif
+.if !defined(WITHOUT_OPTIMIZE) && ${ARCH} != "alpha"
+CFLAGS+= -O2
+.endif
+
.if ${ARCH} == "alpha"
+CFLAGS+= -O0
BROKEN= "core dumps on alpha during post-build"
.endif
@@ -159,6 +166,17 @@ BROKEN="You must upgrade your freetype port to 1.3.1_2 or higher before installi
.endif
pre-everything::
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} "Mozilla has the following tunable option(s):"
+ @${ECHO_MSG} " WITHOUT_XFT=yes Disables Xft anti-aliasing support"
+ @${ECHO_MSG} " WITH_CALENDAR=yes Enables the Calendar module (requires Mailnews and Composer modules)"
+ @${ECHO_MSG} " WITHOUT_MAILNEWS=yes Disables the Mail and News modules"
+ @${ECHO_MSG} " WITHOUT_COMPOSER=yes Disables the HTML Composer module"
+ @${ECHO_MSG} " WITHOUT_LDAP=yes Disables LDAP support within the Mailnews module"
+ @${ECHO_MSG} " WITHOUT_CHATZILLA=yes Disable the Chatzilla IRC module"
+ @${ECHO_MSG} " WITH_JAVASCRIPT_DEBUGGER=yes Enable the DTD and JavaScript debuggers"
+ @${ECHO_MSG} " WITHOUT_OPTIMIZE=yes Disable -O2 optimization"
+ @${ECHO_MSG} ""
.if defined(WITH_CALENDAR)
@${ECHO_MSG} "Calendar is still beta software."
@${ECHO_MSG} "Use at your own risk."