aboutsummaryrefslogtreecommitdiffstats
path: root/www/mozilla/Makefile
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2002-10-22 11:42:24 +0800
committermarcus <marcus@FreeBSD.org>2002-10-22 11:42:24 +0800
commitdb683278d52320231ff347aa9f90bdf1f8cfc942 (patch)
tree818a0db385ad1a1818c7c6820cba4c37a2368ddd /www/mozilla/Makefile
parent0058b4bc54d23e482a66a6870ca65af242a7cbe2 (diff)
downloadfreebsd-ports-gnome-db683278d52320231ff347aa9f90bdf1f8cfc942.tar.gz
freebsd-ports-gnome-db683278d52320231ff347aa9f90bdf1f8cfc942.tar.zst
freebsd-ports-gnome-db683278d52320231ff347aa9f90bdf1f8cfc942.zip
This commit includes:
* mozilla-*vendor ports (currently for Mozilla 1.0.1) * mozilla* ports (currently for Mozilla 1.1) * mozilla-*devel ports (currently for Mozilla 1.2b) Special thanks goes to trevor for auto-generating plist patches, cy for pointing out that the Mozilla startup scripts need to be tailored for each version of Mozilla, grog for suggesting that some verbage needs to be added to explain the Java plugin messages at startup, and John Merryweather Cooper for suggesting a common plugin directory. Of course, thanks also goes to the user community for suggestions and support. These ports offer: * Complete coexistence with each other * A universal ${PREFIX}/lib/browser_plugins directory * Auto-generated plists for ease of maintenance * More accurate pkg-descr's * A pkg-message pointing users to java/jdk13 for the Java plugin PR: 42870 42941 Reviewed by: ports gnome
Diffstat (limited to 'www/mozilla/Makefile')
-rw-r--r--www/mozilla/Makefile51
1 files changed, 34 insertions, 17 deletions
diff --git a/www/mozilla/Makefile b/www/mozilla/Makefile
index f37a11884302..bae061b373f4 100644
--- a/www/mozilla/Makefile
+++ b/www/mozilla/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= mozilla
-PORTVERSION= 1.0.1
-PORTREVISION= 2
+PORTVERSION= 1.1
PORTEPOCH= 2
CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_MOZILLA} \
@@ -30,13 +29,19 @@ WRKSRC= ${WRKDIR}/${PORTNAME}
WITHOUT_CHATZILLA= "Contains a buffer overflow reported at http://online.securityfocus.com/archive/1/270249"
-USE_BZIP2= yes
-EXTRACT_AFTER_ARGS= | tar -xf - -X ${FILESDIR}/tar-exclude
+EXTRACT_AFTER_ARGS= | ${TAR} -xf - --exclude */CVS/* \
+ --exclude */macbuild/*\
+ --exclude */package/* \
+ --exclude .cvsignore \
+ --exclude makefile.win \
+ --exclude MANIFEST
+
USE_X_PREFIX= yes
USE_PERL5= yes
USE_GMAKE= yes
USE_GNOMENG= yes
USE_GNOME= orbit gtk12
+USE_REINPLACE= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= \
--disable-auto-deps \
@@ -64,30 +69,23 @@ CONFIGURE_ARGS= \
--with-system-png=${LOCALBASE} \
--with-pthreads
+PLIST= ${WRKSRC}/pkg-plist
# LDAP is only used by mail and news so disable both together
.if defined(WITHOUT_MAILNEWS)
CONFIGURE_ARGS+= --disable-ldap --disable-mailnews
-PLIST_SUB+= MOZILLAMAILNEWS="@comment "
-PLIST_SUB+= MOZILLALDAP="@comment "
.else
# mail and news desired, but not LDAP
.if defined(WITHOUT_LDAP)
CONFIGURE_ARGS+= --disable-ldap --enable-mailnews
-PLIST_SUB+= MOZILLAMAILNEWS=""
-PLIST_SUB+= MOZILLALDAP="@comment "
.else
CONFIGURE_ARGS+= --enable-ldap --enable-mailnews
-PLIST_SUB+= MOZILLAMAILNEWS=""
-PLIST_SUB+= MOZILLALDAP=""
-.endif
+.endif
.endif
.if !defined(WITHOUT_CHATZILLA)
CONFIGURE_ARGS+= --enable-extensions=default,irc,xmlterm
-PLIST_SUB+= CHATZILLA=""
.else
CONFIGURE_ARGS+= --enable-extensions=default,xmlterm
-PLIST_SUB+= CHATZILLA="@comment "
.endif
CONFIGURE_ENV= MOZ_INTERNAL_LIBART_LGPL=1
@@ -109,24 +107,43 @@ BROKEN= "core dumps on alpha during post-build"
BROKEN="You must upgrade your freetype port to 1.3.1_2 or higher before installing Mozilla. If you have 1.3.1_2 installed, please remove ${LOCALBASE}/include/freetype, then build Mozilla"
.endif
+post-patch:
+ @${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|g' \
+ ${WRKSRC}/build/unix/run-mozilla.sh
+
post-build:
${SED} -e "s;@PREFIX@;${PREFIX};g" \
${FILESDIR}/mozilla.sh >${WRKSRC}/mozilla
(cd ${WRKSRC}/dist/bin; \
${SETENV} LD_LIBRARY_PATH=. MOZILLA_FIVE_HOME=. ./regxpcom; \
- ${ECHO_CMD} skin,install,select,classic/1.0 >> chrome/installed-chrome.txt; \
- ${ECHO_CMD} locale,install,select,en-US >> chrome/installed-chrome.txt; \
- ${SETENV} LD_LIBRARY_PATH=. MOZILLA_FIVE_HOME=. ./regchrome)
+ ${SETENV} LD_LIBRARY_PATH=. MOZILLA_FIVE_HOME=. ./regchrome; \
+ ${TOUCH} ./chrome/user-skins.rdf ./chrome/user-locales.rdf)
${FIND} ${WRKSRC}/dist/bin -type d | /usr/bin/sort -r | \
${XARGS} ${RMDIR} 2> /dev/null || ${TRUE}
+pre-install:
+ ${ECHO_CMD} bin/mozilla > ${PLIST}
+ ${TEST} ! -L ${PREFIX}/lib/browser_plugins/libjavaplugin_oji.so && \
+ ${ECHO_CMD} lib/browser_plugins/libjavaplugin_oji.so >> ${PLIST}
+ cd ${WRKSRC}/dist/bin && ${FIND} -s * -type f -o -type l | \
+ ${SED} -e 's:^:lib/mozilla/:' >> ${PLIST} \
+ && ${FIND} -d * -type d | \
+ ${SED} -e 's:^:@dirrm lib/mozilla/:' >> ${PLIST}
+ ${ECHO_CMD} @dirrm lib/mozilla >> ${PLIST}
+
do-install:
${MKDIR} ${PREFIX}/lib/mozilla
${CHMOD} 755 ${PREFIX}/lib/mozilla
cd ${WRKSRC}/dist/bin && ${FIND} . | \
cpio -pdm -L -R ${LIBOWN}:${LIBGRP} ${PREFIX}/lib/mozilla
${INSTALL_SCRIPT} ${WRKSRC}/mozilla ${PREFIX}/bin
+ ${TEST} -d ${PREFIX}/lib/browser_plugins && \
+ ${MKDIR} ${PREFIX}/lib/browser_plugins
+ ${TEST} ! -L ${PREFIX}/lib/browser_plugins/libjavaplugin_oji.so && \
${LN} -sf ${LOCALBASE}/jdk1.3.1/jre/plugin/i386/ns600/libjavaplugin_oji.so \
- ${PREFIX}/lib/mozilla/plugins/libjavaplugin_oji.so
+ ${PREFIX}/lib/browser_plugins/libjavaplugin_oji.so
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
.include <bsd.port.post.mk>