aboutsummaryrefslogtreecommitdiffstats
path: root/www/mozilla
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2004-06-28 10:18:58 +0800
committermarcus <marcus@FreeBSD.org>2004-06-28 10:18:58 +0800
commita7402b215ffcf66c4668c44f1baa85077d81d60a (patch)
tree7d68b0dc529cd7b82c2e5c340c121efa8efd8dcd /www/mozilla
parentdc8c5e7bbf30a809fa6ce92c0467e6fb475c72a1 (diff)
downloadfreebsd-ports-gnome-a7402b215ffcf66c4668c44f1baa85077d81d60a.tar.gz
freebsd-ports-gnome-a7402b215ffcf66c4668c44f1baa85077d81d60a.tar.zst
freebsd-ports-gnome-a7402b215ffcf66c4668c44f1baa85077d81d60a.zip
* Update to 1.7
* Build the chrome and component registries in a pkg-install script so that the resulting paths are correct [1] For a list of all the changes in 1.7, see http://www.mozilla.org/releases/mozilla1.7. This port features support for the GSSAPI extension as well as optional gnome-vfs support. PR: 65590 [1] Submitted by: thierry [1]
Diffstat (limited to 'www/mozilla')
-rw-r--r--www/mozilla/Makefile180
-rw-r--r--www/mozilla/distinfo4
-rw-r--r--www/mozilla/files/extra-patch-nsSVGLibartGlyphMetricsFT.cpp43
-rw-r--r--www/mozilla/files/patch-build_unix_run-mozilla.sh4
-rw-r--r--www/mozilla/files/patch-config_autoconf.mk.in14
-rw-r--r--www/mozilla/files/patch-directory-c-sdk-ldap-libraries-liblber-lber-int.h30
-rw-r--r--www/mozilla/files/patch-extensions_negotiateauth_Makefile.in12
-rw-r--r--www/mozilla/files/patch-modules::libpref::src::unix::unix.js14
-rw-r--r--www/mozilla/files/patch-nsprpub-pr-src-io-prprf.c14
-rw-r--r--www/mozilla/files/patch-other-licenses_libical_src_libical_Makefile.in11
-rw-r--r--www/mozilla/files/patch-qt22
-rw-r--r--www/mozilla/files/patch-security::coreconf::FreeBSD.mk4
-rw-r--r--www/mozilla/files/patch-xpcom::reflect::xptcall::public::xptcstubsdecl.inc10
-rw-r--r--www/mozilla/pkg-install.in29
14 files changed, 224 insertions, 167 deletions
diff --git a/www/mozilla/Makefile b/www/mozilla/Makefile
index 0e5f951b1c83..6923cdb6f81c 100644
--- a/www/mozilla/Makefile
+++ b/www/mozilla/Makefile
@@ -6,12 +6,14 @@
#
PORTNAME?= mozilla
-PORTVERSION= 1.6
-PORTREVISION?= 4
+PORTVERSION= 1.7
+PORTREVISION?= 0
PORTEPOCH?= 2
CATEGORIES?= www
-MASTER_SITES= ${MASTER_SITE_MOZILLA}
-MASTER_SITE_SUBDIR= mozilla/releases/${PORTNAME}${PORTVERSION}/src
+MASTER_SITES= ${MASTER_SITE_MOZILLA} \
+ ${MASTER_SITE_LOCAL:S/$/:local/}
+MASTER_SITE_SUBDIR= mozilla/releases/${PORTNAME}${PORTVERSION}/src \
+ marcus/:local
DISTFILES= ${PORTNAME}-source-${PORTVERSION}${EXTRACT_SUFX}
MAINTAINER= gnome@FreeBSD.org
@@ -28,6 +30,7 @@ LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
WRKSRC= ${WRKDIR}/${PORTNAME}
MOZILLA?= mozilla
+MOZ_SUFX=
.if defined(WITH_GTK1)
PKGNAMESUFFIX= -gtk1
@@ -36,19 +39,6 @@ USE_GNOME= gtk12 orbit
USE_GNOME= gtk20 libidl
.endif
-.if !defined(WITHOUT_XFT)
-LIB_DEPENDS+= Xft.2:${PORTSDIR}/x11-fonts/libXft
-.if exists(${X11BASE}/lib/X11/fonts/mozilla/fonts.dir)
-BROKEN= Mozilla${MOZ_SUFX} and Xft2 render the mozilla-fonts \
- illegibly. Please remove the mozilla-fonts package.
-.endif
-.endif
-
-.if defined(WITH_CALENDAR) && (defined(WITHOUT_MAILNEWS) || \
- defined(WITHOUT_COMPOSER))
-BROKEN= "Calendar requires Composer and Mailnews support."
-.endif
-
LATEST_LINK= ${MOZILLA}
EXTRACT_AFTER_ARGS= | ${TAR} -xf - --exclude */CVS/* \
--exclude */macbuild/*\
@@ -59,7 +49,9 @@ EXTRACT_AFTER_ARGS= | ${TAR} -xf - --exclude */CVS/* \
USE_BZIP2= yes
USE_X_PREFIX= yes
USE_PERL5= yes
+USE_ICONV= yes
USE_GMAKE= yes
+WANT_GNOME= yes
USE_REINPLACE= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= \
@@ -68,7 +60,6 @@ CONFIGURE_ARGS= \
--disable-cpp-exceptions \
--disable-cpp-rtti \
--enable-crypto \
- --disable-debug \
--disable-gtktest \
--disable-freetypetest \
--disable-installer \
@@ -79,8 +70,8 @@ CONFIGURE_ARGS= \
--disable-pedantic \
--disable-bidi \
--disable-plaintext-editor-only \
- --enable-strip \
--enable-svg \
+ --enable-svg-renderer-libart \
--disable-tests \
--disable-xterm-updates \
--enable-xinerama \
@@ -88,9 +79,71 @@ CONFIGURE_ARGS= \
--with-system-jpeg=${LOCALBASE} \
--with-system-mng=${LOCALBASE} \
--with-system-png=${LOCALBASE} \
+ --with-gssapi=/usr \
--with-pthreads
-PLIST= ${WRKDIR}/pkg-plist
+PLIST= ${WRKDIR}/pkg-plist
+MOZ_EXTENSIONS= default
+CONFIGURE_ENV= MOZ_INTERNAL_LIBART_LGPL=1 \
+ LOCALBASE=${LOCALBASE}
+PKGINSTALL= ${WRKDIR}/pkg-install
+
+.if defined(WITH_GTK1)
+CONFIGURE_ARGS+= --enable-default-toolkit=gtk
+.else
+CONFIGURE_ARGS+= --enable-default-toolkit=gtk2
+.endif
+
+ESD_LIB= libesd.so.2
+FREETYPE_LIB= libfreetype.so.9
+PKGCONFIG_FILES=mozilla-gtkmozembed mozilla-js mozilla-xpcom \
+ mozilla-nspr mozilla-nss mozilla-plugin
+
+# JPI stuff. List paths to Java Plug-ins here in the order to try.
+JPI_LIST?=\
+ ${LOCALBASE}/jdk1.4.2/jre/plugin/${ARCH}/ns610/libjavaplugin_oji.so \
+ ${LOCALBASE}/jdk1.4.1/jre/plugin/${ARCH}/ns610/libjavaplugin_oji.so \
+ ${LOCALBASE}/diablo-jdk1.3.1/jre/plugin/${ARCH}/ns600/libjavaplugin_oji.so \
+ ${LOCALBASE}/jdk1.3.1/jre/plugin/${ARCH}/ns600/libjavaplugin_oji.so
+
+OPTIONS=XFT "Enable Xft font anti-aliasing" on \
+ CALENDAR "Enable the Calendar module" off \
+ MAILNEWS "Enable Mail and News modules" on \
+ COMPOSER "Enable the HTML Composer module" on \
+ DEBUG "Enable debugging (i.e. gdb) support" off \
+ LDAP "Enable LDAP support for Mailnews" on \
+ CHATZILLA "Enable the Chatzilla IRC module" on \
+ XMLTERM "Enable the XMLTerm module" on \
+ JAVASCRIPT_DEBUGGER "Enable the DTD and JavaScript debuggers" off \
+ OPTIMIZED_CFLAGS "Enable -O2 optimizations" off \
+ SMB "Enable smb:// URI support using gnomevfs" off
+
+.include <bsd.port.pre.mk>
+
+.if !defined(WITHOUT_XFT)
+LIB_DEPENDS+= Xft.2:${PORTSDIR}/x11-fonts/libXft
+CONFIGURE_ARGS+=--enable-xft
+.if exists(${X11BASE}/lib/X11/fonts/mozilla/fonts.dir)
+BROKEN= Mozilla${MOZ_SUFX} and Xft2 render the mozilla-fonts \
+ illegibly. Please remove the mozilla-fonts package.
+.endif
+.else
+CONFIGURE_ARGS+=--disable-xft
+.endif
+
+.if defined(WITH_DEBUG)
+CONFIGURE_ARGS+=--enable-debug \
+ --disable-strip
+.else
+CONFIGURE_ARGS+=--disable-debug \
+ --enable-strip
+.endif
+
+.if defined(WITH_CALENDAR) && (defined(WITHOUT_MAILNEWS) || \
+ defined(WITHOUT_COMPOSER))
+BROKEN= "Calendar requires Composer and Mailnews support."
+.endif
+
# LDAP is only used by mail and news so disable both together
.if defined(WITHOUT_MAILNEWS)
CONFIGURE_ARGS+= --disable-ldap --disable-mailnews
@@ -102,7 +155,6 @@ CONFIGURE_ARGS+= --disable-ldap --enable-mailnews
CONFIGURE_ARGS+= --enable-ldap --enable-mailnews
.endif
.endif
-MOZ_EXTENSIONS= default
.if !defined(WITHOUT_CHATZILLA)
MOZ_EXTENSIONS:= ${MOZ_EXTENSIONS},irc
.endif
@@ -110,8 +162,6 @@ MOZ_EXTENSIONS:= ${MOZ_EXTENSIONS},irc
MOZ_EXTENSIONS:= ${MOZ_EXTENSIONS},xmlterm
.endif
CONFIGURE_ARGS+= --enable-extensions=${MOZ_EXTENSIONS}
-CONFIGURE_ENV= MOZ_INTERNAL_LIBART_LGPL=1 \
- LOCALBASE=${LOCALBASE}
.if defined(WITH_JAVASCRIPT_DEBUGGER)
CONFIGURE_ARGS+= --enable-jsd \
@@ -129,38 +179,22 @@ CONFIGURE_ARGS+= --enable-calendar
CONFIGURE_ARGS+= --disable-composer
.endif
-.if defined(WITH_GTK1)
-CONFIGURE_ARGS+= --enable-default-toolkit=gtk
-.else
-CONFIGURE_ARGS+= --enable-default-toolkit=gtk2
-.endif
-
-.if !defined(WITHOUT_XFT)
-CONFIGURE_ARGS+= --enable-xft
-.else
-CONFIGURE_ARGS+= --disable-xft
-.endif
-
-ESD_LIB= libesd.so.2
-FREETYPE_LIB= libfreetype.so.9
-PKGCONFIG_FILES=mozilla-gtkmozembed mozilla-js mozilla-xpcom \
- mozilla-nspr mozilla-nss mozilla-plugin
-
-# JPI stuff. List paths to Java Plug-ins here in the order to try.
-JPI_LIST?=\
- ${LOCALBASE}/jdk1.4.2/jre/plugin/${ARCH}/ns610/libjavaplugin_oji.so \
- ${LOCALBASE}/jdk1.4.1/jre/plugin/${ARCH}/ns610/libjavaplugin_oji.so \
- ${LOCALBASE}/diablo-jdk1.3.1/jre/plugin/${ARCH}/ns600/libjavaplugin_oji.so \
- ${LOCALBASE}/jdk1.3.1/jre/plugin/${ARCH}/ns600/libjavaplugin_oji.so
-
-.include <bsd.port.pre.mk>
-
MAKE_ENV= LD_LIBRARY_PATH=${WRKSRC}/dist/bin \
MOZ_INTERNAL_LIBART_LGPL=1
ALL_TARGET= default
-.if ${ARCH} == "i386"
-CONFIGURE_ARGS+= --enable-reorder
+#.if ${ARCH} == "i386"
+#CONFIGURE_ARGS+= --enable-reorder
+#.endif
+
+.if ${OSVERSION} < 500035
+EXTRA_PATCHES+= ${FILESDIR}/extra-patch-nsSVGLibartGlyphMetricsFT.cpp
+.endif
+
+.if defined(WITH_SMB)
+USE_GNOME+= gnomevfs2
+.else
+CONFIGURE_ARGS+=--disable-gnomevfs
.endif
.if defined(WITH_OPTIMIZED_CFLAGS)
@@ -177,22 +211,12 @@ BROKEN="You must upgrade your freetype port to 1.3.1_2 or higher before installi
.endif
pre-everything::
- @${ECHO_MSG} ""
- @${ECHO_MSG} "Mozilla has the following tunable option(s):"
- @${ECHO_MSG} " WITHOUT_XFT=yes Disables Xft anti-aliasing support"
- @${ECHO_MSG} " WITH_CALENDAR=yes Enables the Calendar module (requires Mailnews and Composer modules)"
- @${ECHO_MSG} " WITHOUT_MAILNEWS=yes Disables the Mail and News modules"
- @${ECHO_MSG} " WITHOUT_COMPOSER=yes Disables the HTML Composer module"
- @${ECHO_MSG} " WITHOUT_LDAP=yes Disables LDAP support within the Mailnews module"
- @${ECHO_MSG} " WITHOUT_CHATZILLA=yes Disable the Chatzilla IRC module"
- @${ECHO_MSG} " WITHOUT_XMLTERM=yes Disable the XMLTerm module"
- @${ECHO_MSG} " WITH_JAVASCRIPT_DEBUGGER=yes Enable the DTD and JavaScript debuggers"
- @${ECHO_MSG} " WITH_OPTIMIZED_CFLAGS=yes Enable -O2 optimization"
- @${ECHO_MSG} ""
.if defined(WITH_CALENDAR)
+ @${ECHO_MSG} ""
@${ECHO_MSG} "Calendar is still beta software."
@${ECHO_MSG} "Use at your own risk."
@${ECHO_MSG} "http://mozilla.org/projects/calendar/"
+ @${ECHO_MSG} ""
.endif
post-patch:
@@ -212,22 +236,23 @@ post-patch:
${WRKSRC}/security/coreconf/FreeBSD.mk \
${WRKSRC}/directory/c-sdk/config/FreeBSD.mk \
${WRKSRC}/js/src/Makefile.in
- @${REINPLACE_CMD} -e 's|libesd\.so\.0|${ESD_LIB}|g' \
+ @${REINPLACE_CMD} -E -e 's|libesd\.so\.[0-9]+|${ESD_LIB}|g' \
${WRKSRC}/widget/src/gtk2/nsSound.cpp
@${REINPLACE_CMD} -e '/accessibility.typeaheadfind.enablesound/s/true/false/' \
- ${WRKSRC}/modules/libpref/src/init/all.js \
- ${WRKSRC}/calendar/sunbird/app/profile/all.js
+ ${WRKSRC}/modules/libpref/src/init/all.js
@${REINPLACE_CMD} -e 's|<iconv.h>|\"${LOCALBASE}/include/iconv.h\"|g' \
${WRKSRC}/configure \
${WRKSRC}/intl/uconv/native/nsNativeUConvService.cpp \
${WRKSRC}/xpcom/io/nsNativeCharsetUtils.cpp
- @${REINPLACE_CMD} -e 's|libfreetype.so.6|${FREETYPE_LIB}|g' \
+ @${REINPLACE_CMD} -E -e 's|libfreetype\.so\.[0-9]+|${FREETYPE_LIB}|g' \
${WRKSRC}/modules/libpref/src/init/all.js
@for pcfile in ${PKGCONFIG_FILES}; do \
${REINPLACE_CMD} -e 's|mozilla-xpcom|mozilla-xpcom${MOZ_SUFX}${PKGNAMESUFFIX}|g ; \
s|mozilla-nspr|mozilla-nspr${MOZ_SUFX}${PKGNAMESUFFIX}|g' \
${WRKSRC}/build/unix/$${pcfile}.pc.in; \
done
+ @${SED} -e 's|%%MOZDIR%%|${PREFIX}/lib/${MOZILLA}|g' \
+ < ${MASTERDIR}/pkg-install.in > ${PKGINSTALL}
pre-configure:
@if [ -n "`${PKG_INFO} -xI '^bind[0-9]*-base-[0-9]'`" ]; then \
@@ -238,10 +263,6 @@ pre-configure:
post-build:
${SED} -e "s|%%PREFIX%%|${PREFIX}|g" -e "s|%%MOZILLA%%|${MOZILLA}|g" \
${FILESDIR}/mozilla.sh >${WRKSRC}/${MOZILLA}
- (cd ${WRKSRC}/dist/bin; \
- ${SETENV} LD_LIBRARY_PATH=. MOZILLA_FIVE_HOME=. ./regxpcom; \
- ${SETENV} LD_LIBRARY_PATH=. MOZILLA_FIVE_HOME=. ./regchrome; \
- ${TOUCH} ./chrome/user-skins.rdf ./chrome/user-locales.rdf)
${FIND} ${WRKSRC}/dist/bin -type d | ${SORT} -r | \
${XARGS} ${RMDIR} 2> /dev/null || ${TRUE}
@@ -272,10 +293,10 @@ pre-install:
${ECHO_CMD} libdata/pkgconfig/$${pcfile}${MOZ_SUFX}${PKGNAMESUFFIX}.pc >> ${PLIST} ; \
done
cd ${WRKSRC}/dist/include && ${FIND} -s * -type f -o -type l | \
- ${SED} -e 's:^:include/mozilla/:' >> ${PLIST} \
+ ${SED} -e 's:^:include/${MOZILLA}/:' >> ${PLIST} \
&& ${FIND} -d * -type d | \
- ${SED} -e 's:^:@dirrm include/mozilla/:' >> ${PLIST}
- ${ECHO_CMD} @dirrm include/mozilla >> ${PLIST}
+ ${SED} -e 's:^:@dirrm include/${MOZILLA}/:' >> ${PLIST}
+ ${ECHO_CMD} @dirrm include/${MOZILLA} >> ${PLIST}
do-install:
${MKDIR} ${PREFIX}/lib/${MOZILLA}
@@ -302,14 +323,17 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/build/unix/$${pcfile}.pc \
${PREFIX}/libdata/pkgconfig/$${pcfile}${MOZ_SUFX}${PKGNAMESUFFIX}.pc ; \
done
- -${RM} -fr ${PREFIX}/include/mozilla
- ${MKDIR} ${PREFIX}/include/mozilla
- ${CHMOD} 755 ${PREFIX}/include/mozilla
+ -${RM} -fr ${PREFIX}/include/${MOZILLA}
+ ${MKDIR} ${PREFIX}/include/${MOZILLA}
+ ${CHMOD} 755 ${PREFIX}/include/${MOZILLA}
cd ${WRKSRC}/dist/include && ${FIND} . | \
- ${CPIO} -pdm -L -R ${LIBOWN}:${LIBGRP} ${PREFIX}/include/mozilla
+ ${CPIO} -pdm -L -R ${LIBOWN}:${LIBGRP} ${PREFIX}/include/${MOZILLA}
post-install:
@${CHMOD} -R u-w ${PREFIX}/lib/${MOZILLA}/components
+.if !defined(PACKAGE_BUILDING)
+ @${SETENV} PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
+.endif
@${CAT} ${PKGMESSAGE}
.include <bsd.port.post.mk>
diff --git a/www/mozilla/distinfo b/www/mozilla/distinfo
index dbbf6dbc75b3..4889c53e320f 100644
--- a/www/mozilla/distinfo
+++ b/www/mozilla/distinfo
@@ -1,2 +1,2 @@
-MD5 (mozilla-source-1.6.tar.bz2) = da612f8768320dbafd0bfb3c254c2788
-SIZE (mozilla-source-1.6.tar.bz2) = 31037452
+MD5 (mozilla-source-1.7.tar.bz2) = 5b4494934c4ffaee83bc79a8b181a8c3
+SIZE (mozilla-source-1.7.tar.bz2) = 35174502
diff --git a/www/mozilla/files/extra-patch-nsSVGLibartGlyphMetricsFT.cpp b/www/mozilla/files/extra-patch-nsSVGLibartGlyphMetricsFT.cpp
new file mode 100644
index 000000000000..be76e019d074
--- /dev/null
+++ b/www/mozilla/files/extra-patch-nsSVGLibartGlyphMetricsFT.cpp
@@ -0,0 +1,43 @@
+--- layout/svg/renderer/src/libart/nsSVGLibartGlyphMetricsFT.cpp.orig Thu Feb 26 02:13:35 2004
++++ layout/svg/renderer/src/libart/nsSVGLibartGlyphMetricsFT.cpp Thu Feb 26 03:27:56 2004
+@@ -56,6 +57,13 @@
+ #include "nsArray.h"
+ #include "nsDataHashtable.h"
+
++
++#ifdef HAVE_CPP_2BYTE_WCHAR_T
++ typedef nsDependentString nsLiteralString;
++#else
++ typedef NS_ConvertASCIItoUTF16 nsLiteralString;
++#endif
++
+ /**
+ * \addtogroup libart_renderer Libart Rendering Engine
+ * @{
+@@ -112,7 +120,7 @@
+ nsCOMPtr<nsISVGGlyphMetricsSource> mSource;
+
+ public:
+- static nsDataHashtable<nsStringHashKey,nsDependentString*> sFontAliases;
++ static nsDataHashtable<nsStringHashKey,nsLiteralString*> sFontAliases;
+ };
+
+ /** @} */
+@@ -120,7 +128,7 @@
+ //----------------------------------------------------------------------
+ // nsSVGLibartGlyphMetricsFT implementation:
+
+-nsDataHashtable<nsStringHashKey,nsDependentString*>
++nsDataHashtable<nsStringHashKey,nsLiteralString*>
+ nsSVGLibartGlyphMetricsFT::sFontAliases;
+
+
+@@ -406,7 +414,7 @@
+ }
+ else {
+ // try alias if there is one:
+- nsDependentString *alias = nsnull;
++ nsLiteralString *alias = nsnull;
+ nsSVGLibartGlyphMetricsFT::sFontAliases.Get(NS_ConvertUTF8toUCS2(family_name),
+ &alias);
+ if (alias) {
diff --git a/www/mozilla/files/patch-build_unix_run-mozilla.sh b/www/mozilla/files/patch-build_unix_run-mozilla.sh
index 58df9aaf922a..f93248fd107b 100644
--- a/www/mozilla/files/patch-build_unix_run-mozilla.sh
+++ b/www/mozilla/files/patch-build_unix_run-mozilla.sh
@@ -1,5 +1,7 @@
+$FreeBSD$
+
--- build/unix/run-mozilla.sh.orig Mon Dec 15 12:27:28 2003
-+++ build/unix/run-mozilla.sh Fri Jan 16 22:19:01 2004
++++ build/unix/run-mozilla.sh Wed Feb 11 14:24:17 2004
@@ -355,7 +355,7 @@
fi
##
diff --git a/www/mozilla/files/patch-config_autoconf.mk.in b/www/mozilla/files/patch-config_autoconf.mk.in
index c119b0c2c6a8..9c7c471bec3c 100644
--- a/www/mozilla/files/patch-config_autoconf.mk.in
+++ b/www/mozilla/files/patch-config_autoconf.mk.in
@@ -1,18 +1,18 @@
---- config/autoconf.mk.in.orig Sun Nov 17 14:47:49 2002
-+++ config/autoconf.mk.in Sun Nov 17 14:48:17 2002
-@@ -30,13 +30,13 @@
+--- config/autoconf.mk.in.orig Mon Mar 15 22:56:25 2004
++++ config/autoconf.mk.in Fri Mar 19 15:17:50 2004
+@@ -31,13 +31,13 @@
prefix = @prefix@
exec_prefix = @exec_prefix@
bindir = @bindir@
--includedir = @includedir@/mozilla-$(MOZILLA_VERSION)
+-includedir = @includedir@/$(MOZ_APP_NAME)-$(MOZ_APP_VERSION)
+includedir = @includedir@/mozilla%%HEADERS_SUFX%%
libdir = @libdir@
datadir = @datadir@
mandir = @mandir@
- idldir = @datadir@/idl/mozilla-$(MOZILLA_VERSION)
+ idldir = @datadir@/idl/$(MOZ_APP_NAME)-$(MOZ_APP_VERSION)
--mozappdir = $(libdir)/mozilla-$(MOZILLA_VERSION)
+-mozappdir = $(libdir)/$(MOZ_APP_NAME)-$(MOZ_APP_VERSION)
+mozappdir = $(libdir)/%%MOZILLA%%
- mredir = $(libdir)/mre/mre-$(MOZILLA_VERSION)
+ mredir = $(libdir)/mre/mre-$(MOZ_APP_VERSION)
mrelibdir = $(mredir)/lib
diff --git a/www/mozilla/files/patch-directory-c-sdk-ldap-libraries-liblber-lber-int.h b/www/mozilla/files/patch-directory-c-sdk-ldap-libraries-liblber-lber-int.h
deleted file mode 100644
index edc10f32f824..000000000000
--- a/www/mozilla/files/patch-directory-c-sdk-ldap-libraries-liblber-lber-int.h
+++ /dev/null
@@ -1,30 +0,0 @@
---- directory/c-sdk/ldap/libraries/liblber/lber-int.h Tue Mar 26 13:53:23 2002
-+++ directory/c-sdk/ldap/libraries/liblber/lber-int.h Sat Dec 13 13:02:49 2003
-@@ -236,15 +236,15 @@
- (((_l)&0xff0000)>>8) + (((_l)&0xff000000)>>24))
- #define LBER_NTOHL(_l) LBER_HTONL(_l)
-
--#elif !defined(__alpha) || defined(VMS)
-+#elif !defined(__amd64__) && (!defined(__alpha) || defined(VMS))
-
- #define LBER_HTONL( l ) htonl( l )
- #define LBER_NTOHL( l ) ntohl( l )
-
- #else /* __alpha */
- /*
-- * htonl and ntohl on the DEC Alpha under OSF 1 seem to only swap the
-- * lower-order 32-bits of a (64-bit) long, so we define correct versions
-+ * htonl and ntohl on the 64 bit UNIX platforms only swap the lower-order
-+ * 32-bits of a (64-bit) long, so we define correct versions
- * here.
- */
- #define LBER_HTONL( l ) (((long)htonl( (l) & 0x00000000FFFFFFFF )) << 32 \
-@@ -252,7 +252,7 @@
-
- #define LBER_NTOHL( l ) (((long)ntohl( (l) & 0x00000000FFFFFFFF )) << 32 \
- | ntohl( ( (l) & 0xFFFFFFFF00000000 ) >> 32 ))
--#endif /* __alpha */
-+#endif /* __alpha || __amd64__ */
-
-
- /* function prototypes */
diff --git a/www/mozilla/files/patch-extensions_negotiateauth_Makefile.in b/www/mozilla/files/patch-extensions_negotiateauth_Makefile.in
new file mode 100644
index 000000000000..ca1f969ce5fe
--- /dev/null
+++ b/www/mozilla/files/patch-extensions_negotiateauth_Makefile.in
@@ -0,0 +1,12 @@
+--- extensions/negotiateauth/Makefile.in.orig Tue Apr 13 12:19:44 2004
++++ extensions/negotiateauth/Makefile.in Tue Apr 13 12:19:53 2004
+@@ -68,8 +68,8 @@
+ $(NULL)
+
+ EXTRA_DSO_LDOPTS = \
+- $(MOZ_COMPONENT_LIBS) \
+ $(GSSAPI_LIBS) \
++ $(MOZ_COMPONENT_LIBS) \
+ $(NULL)
+
+ # make sure this component is never statically linked into the main
diff --git a/www/mozilla/files/patch-modules::libpref::src::unix::unix.js b/www/mozilla/files/patch-modules::libpref::src::unix::unix.js
deleted file mode 100644
index bd39a70bf05d..000000000000
--- a/www/mozilla/files/patch-modules::libpref::src::unix::unix.js
+++ /dev/null
@@ -1,14 +0,0 @@
-
-$FreeBSD$
-
---- modules/libpref/src/unix/unix.js 2002/03/14 15:04:20 1.1
-+++ modules/libpref/src/unix/unix.js 2002/03/14 15:04:38
-@@ -227,7 +227,7 @@
-
- // TrueType
- pref("font.FreeType2.enable", false);
--pref("font.freetype2.shared-library", "libfreetype.so.6");
-+pref("font.freetype2.shared-library", "libfreetype.so.9");
- // if libfreetype was built without hinting compiled in
- // it is best to leave hinting off
- pref("font.FreeType2.autohinted", false);
diff --git a/www/mozilla/files/patch-nsprpub-pr-src-io-prprf.c b/www/mozilla/files/patch-nsprpub-pr-src-io-prprf.c
index 8c48ad1e08fb..f9949d6d9c96 100644
--- a/www/mozilla/files/patch-nsprpub-pr-src-io-prprf.c
+++ b/www/mozilla/files/patch-nsprpub-pr-src-io-prprf.c
@@ -1,12 +1,14 @@
---- nsprpub/pr/src/io/prprf.c Wed Feb 26 15:53:42 2003
-+++ nsprpub/pr/src/io/prprf.c Thu Oct 16 22:50:40 2003
-@@ -52,5 +52,8 @@
+--- nsprpub/pr/src/io/prprf.c.orig Mon Mar 8 22:18:19 2004
++++ nsprpub/pr/src/io/prprf.c Fri Mar 19 15:26:55 2004
+@@ -51,7 +51,10 @@
+ ** Note: on some platforms va_list is defined as an array,
** and requires array notation.
*/
--#if (defined(LINUX) && defined(__powerpc__)) || \
+-#if (defined(LINUX) && defined(__x86_64__))
+#if defined(__amd64__)
+#include <stdarg.h>
+#define VARARGS_ASSIGN(foo, bar) va_copy((foo), (bar))
-+#elif (defined(LINUX) && defined(__powerpc__)) || \
++#elif (defined(LINUX) && defined(__x86_64__))
+ #define VARARGS_ASSIGN(foo, bar) __va_copy((foo), (bar))
+ #elif (defined(LINUX) && defined(__powerpc__)) || \
(defined(LINUX) && defined(__s390__)) || \
- (defined(LINUX) && defined(__s390x__)) || \
diff --git a/www/mozilla/files/patch-other-licenses_libical_src_libical_Makefile.in b/www/mozilla/files/patch-other-licenses_libical_src_libical_Makefile.in
deleted file mode 100644
index f7b62d4df6a2..000000000000
--- a/www/mozilla/files/patch-other-licenses_libical_src_libical_Makefile.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- other-licenses/libical/src/libical/Makefile.in.orig Thu Feb 13 15:50:58 2003
-+++ other-licenses/libical/src/libical/Makefile.in Thu Feb 13 15:51:07 2003
-@@ -179,7 +179,7 @@
- $(PERL) $(ICALSCRIPTS)/mkrestrictiontable.pl -i $(srcdir)/icalrestriction.c.in \
- $(DESIGNDATA)/restrictions.csv > icalrestriction.c
-
--ifneq (,$(filter BeOS Darwin OpenVMS,$(OS_ARCH)))
-+ifneq (,$(filter BeOS Darwin OpenVMS FreeBSD,$(OS_ARCH)))
- DEFINES += -D__USE_BSD=1
- endif
-
diff --git a/www/mozilla/files/patch-qt b/www/mozilla/files/patch-qt
index 5420fec2679a..6b72f3f007ae 100644
--- a/www/mozilla/files/patch-qt
+++ b/www/mozilla/files/patch-qt
@@ -1,15 +1,15 @@
---- configure.orig Thu Dec 11 18:32:02 2003
-+++ configure Thu Mar 11 00:51:58 2004
-@@ -9181,7 +9181,7 @@
+--- configure.orig Tue Apr 20 21:39:17 2004
++++ configure Thu Apr 29 14:01:52 2004
+@@ -9362,7 +9362,7 @@
echo $ac_n "(cached) $ac_c" 1>&6
else
ac_save_LIBS="$LIBS"
-LIBS="-liconv $LIBS"
+LIBS="-L$LOCALBASE/lib -liconv $LIBS"
cat > conftest.$ac_ext <<EOF
- #line 9187 "configure"
+ #line 9368 "configure"
#include "confdefs.h"
-@@ -9212,7 +9212,7 @@
+@@ -9393,7 +9393,7 @@
fi
if eval "test \"`echo '$ac_cv_lib_'$ac_lib_var`\" = yes"; then
echo "$ac_t""yes" 1>&6
@@ -18,16 +18,16 @@
else
echo "$ac_t""no" 1>&6
echo $ac_n "checking for libiconv in -liconv""... $ac_c" 1>&6
-@@ -9222,7 +9222,7 @@
+@@ -9403,7 +9403,7 @@
echo $ac_n "(cached) $ac_c" 1>&6
else
ac_save_LIBS="$LIBS"
-LIBS="-liconv $LIBS"
+LIBS="-L$LOCALBASE/lib -liconv $LIBS"
cat > conftest.$ac_ext <<EOF
- #line 9228 "configure"
+ #line 9409 "configure"
#include "confdefs.h"
-@@ -9253,7 +9253,7 @@
+@@ -9434,7 +9434,7 @@
fi
if eval "test \"`echo '$ac_cv_lib_'$ac_lib_var`\" = yes"; then
echo "$ac_t""yes" 1>&6
@@ -36,12 +36,12 @@
else
echo "$ac_t""no" 1>&6
fi
-@@ -11969,9 +11969,9 @@
+@@ -12298,9 +12298,9 @@
--MOZ_EXTENSIONS_DEFAULT=" cookie wallet content-packs xml-rpc xmlextras help p3p pref transformiix venkman inspector irc universalchardet typeaheadfind webservices spellcheck"
-+MOZ_EXTENSIONS_DEFAULT=" cookie wallet content-packs xml-rpc xmlextras help p3p pref transformiix venkman inspector universalchardet typeaheadfind webservices spellcheck"
+-MOZ_EXTENSIONS_DEFAULT=" cookie wallet content-packs xml-rpc xmlextras help p3p pref transformiix venkman inspector irc universalchardet typeaheadfind webservices spellcheck gnomevfs negotiateauth"
++MOZ_EXTENSIONS_DEFAULT=" cookie wallet content-packs xml-rpc xmlextras help p3p pref transformiix venkman inspector universalchardet typeaheadfind webservices spellcheck gnomevfs negotiateauth"
-MOZ_EXTENSIONS_ALL="$MOZ_EXTENSIONS_DEFAULT xmlterm datetime finger cview layout-debug tasks"
+MOZ_EXTENSIONS_ALL="$MOZ_EXTENSIONS_DEFAULT irc xmlterm datetime finger cview layout-debug tasks"
diff --git a/www/mozilla/files/patch-security::coreconf::FreeBSD.mk b/www/mozilla/files/patch-security::coreconf::FreeBSD.mk
index 9c79efbaf878..caabfc098e9f 100644
--- a/www/mozilla/files/patch-security::coreconf::FreeBSD.mk
+++ b/www/mozilla/files/patch-security::coreconf::FreeBSD.mk
@@ -1,5 +1,5 @@
--- security/coreconf/FreeBSD.mk.orig Wed Mar 26 20:17:25 2003
-+++ security/coreconf/FreeBSD.mk Sun Dec 14 11:38:37 2003
++++ security/coreconf/FreeBSD.mk Fri Mar 19 15:52:59 2004
@@ -35,16 +35,18 @@
include $(CORE_DEPTH)/coreconf/UNIX.mk
@@ -27,7 +27,7 @@
endif
-MKSHLIB = $(CC) $(DSO_LDOPTS)
-+MKSHLIB = $(CC) $(DSO_LDOPTS) -o $@
++MKSHLIB = $(CC) -Wl,-Bsymbolic $(DSO_LDOPTS) -o $@
ifdef MAPFILE
# Add LD options to restrict exported symbols to those in the map file
endif
diff --git a/www/mozilla/files/patch-xpcom::reflect::xptcall::public::xptcstubsdecl.inc b/www/mozilla/files/patch-xpcom::reflect::xptcall::public::xptcstubsdecl.inc
index ed281efd9234..ebe5474ca275 100644
--- a/www/mozilla/files/patch-xpcom::reflect::xptcall::public::xptcstubsdecl.inc
+++ b/www/mozilla/files/patch-xpcom::reflect::xptcall::public::xptcstubsdecl.inc
@@ -1,11 +1,11 @@
---- xpcom/reflect/xptcall/public/xptcstubsdecl.inc.orig Sun Jul 20 11:45:41 2003
-+++ xpcom/reflect/xptcall/public/xptcstubsdecl.inc Sun Jul 20 11:49:09 2003
+--- xpcom/reflect/xptcall/public/xptcstubsdecl.inc.orig Tue Mar 16 03:07:25 2004
++++ xpcom/reflect/xptcall/public/xptcstubsdecl.inc Fri Mar 19 15:58:14 2004
@@ -8,7 +8,7 @@
* 1 is AddRef
* 2 is Release
*/
-#if !defined(__ia64) || (!defined(__hpux) && !defined(__linux__))
+#if !defined(__ia64)
- XPTC_EXPORT NS_IMETHOD Stub3();
- XPTC_EXPORT NS_IMETHOD Stub4();
- XPTC_EXPORT NS_IMETHOD Stub5();
+ NS_IMETHOD Stub3();
+ NS_IMETHOD Stub4();
+ NS_IMETHOD Stub5();
diff --git a/www/mozilla/pkg-install.in b/www/mozilla/pkg-install.in
new file mode 100644
index 000000000000..3687532f1882
--- /dev/null
+++ b/www/mozilla/pkg-install.in
@@ -0,0 +1,29 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+# Date created: Mon Nov 29, 2003
+# Whom: Thierry Thomas (<thierry@pompo.net>)
+# Fix the chrome registry.
+
+umask 022
+PATH=/bin:/usr/bin
+
+[ "x$1" = "x" ] && exit 1
+[ "x$2" != "xPOST-INSTALL" ] && exit 0
+
+MOZDIR=%%MOZDIR%%
+REGXPCOM=${MOZDIR}/regxpcom
+REGCHROME=${MOZDIR}/regchrome
+
+echo "===> Building Chrome's registry..."
+rm -rf ${MOZDIR}/chrome/overlayinfo
+rm -f ${MOZDIR}/chrome/*.rdf
+mkdir -p ${MOZDIR}/chrome/overlayinfo
+rm -f ${MOZDIR}/component.reg
+
+cd ${MOZDIR} || exit 1
+./run-mozilla.sh ${REGXPCOM} || true
+./run-mozilla.sh ${REGCHROME} || true
+
+exit 0