aboutsummaryrefslogtreecommitdiffstats
path: root/www/mozilla
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2004-12-04 17:47:27 +0800
committermarcus <marcus@FreeBSD.org>2004-12-04 17:47:27 +0800
commita433f771d4d31172183d7d4b8096454c468d8c3a (patch)
tree3eb0debfca57cdf4a2ee4b78a5efe87133e1098a /www/mozilla
parent821e2d66452a29adfce36f5a46a6e2df486aa0b9 (diff)
downloadfreebsd-ports-gnome-a433f771d4d31172183d7d4b8096454c468d8c3a.tar.gz
freebsd-ports-gnome-a433f771d4d31172183d7d4b8096454c468d8c3a.tar.zst
freebsd-ports-gnome-a433f771d4d31172183d7d4b8096454c468d8c3a.zip
Be sure to create the browser_plugins during package install as well. Some
ports (e.g. www/ump) depend on this directory being there. Reported by: pointyhat via kris
Diffstat (limited to 'www/mozilla')
-rw-r--r--www/mozilla/Makefile3
-rw-r--r--www/mozilla/pkg-install.in4
2 files changed, 6 insertions, 1 deletions
diff --git a/www/mozilla/Makefile b/www/mozilla/Makefile
index d9fe00c9191f..16c8efd009cf 100644
--- a/www/mozilla/Makefile
+++ b/www/mozilla/Makefile
@@ -267,7 +267,8 @@ post-patch:
s|mozilla-nspr|mozilla-nspr${MOZ_SUFX}${PKGNAMESUFFIX}|g' \
${WRKSRC}/build/unix/$${pcfile}.pc.in; \
done
- @${SED} -e 's|%%MOZDIR%%|${PREFIX}/lib/${MOZILLA}|g' \
+ @${SED} -e 's|%%MOZDIR%%|${PREFIX}/lib/${MOZILLA}|g ; \
+ s|%%PREFIX%%|${PREFIX}|g' \
< ${MASTERDIR}/pkg-install.in > ${PKGINSTALL}
@${SED} -e 's|%%MOZDIR%%|${PREFIX}/lib/${MOZILLA}|g' \
< ${MASTERDIR}/pkg-deinstall.in > ${PKGDEINSTALL}
diff --git a/www/mozilla/pkg-install.in b/www/mozilla/pkg-install.in
index 3687532f1882..79a65c81189a 100644
--- a/www/mozilla/pkg-install.in
+++ b/www/mozilla/pkg-install.in
@@ -26,4 +26,8 @@ cd ${MOZDIR} || exit 1
./run-mozilla.sh ${REGXPCOM} || true
./run-mozilla.sh ${REGCHROME} || true
+if [ ! -d %%PREFIX%%/lib/browser_plugins ]; then
+ mkdir -p %%PREFIX%%/lib/browser_plugins
+fi
+
exit 0