aboutsummaryrefslogtreecommitdiffstats
path: root/www/mozilla
diff options
context:
space:
mode:
authormezz <mezz@FreeBSD.org>2009-01-10 10:45:46 +0800
committermezz <mezz@FreeBSD.org>2009-01-10 10:45:46 +0800
commit867a335b88f91d457005fa0c7b3bb7c85c5fca14 (patch)
tree68af898c9a11dd756c516c49a6715cee75888e70 /www/mozilla
parent6f64cd00171c29c1c7cdfb1e40393e23fc35151d (diff)
downloadfreebsd-ports-gnome-867a335b88f91d457005fa0c7b3bb7c85c5fca14.tar.gz
freebsd-ports-gnome-867a335b88f91d457005fa0c7b3bb7c85c5fca14.tar.zst
freebsd-ports-gnome-867a335b88f91d457005fa0c7b3bb7c85c5fca14.zip
Add a new framework for browser plugins, USE_WEBPLUGINS. It is for which foo
plugins support one of web browsers and can take care of plist (depend on how you use it) at the same time. I have written a complete document and even show how it works in the www/firefox/Makefile.webplugins so be sure to read in there. If there is anything that isn't clear in the document, please feel free to ask and I will try my best to improvement it. FYI: GNOME 2.24 depends on this, so it's coming. BTW: It's based on www/linux-mplayer-plugin/Makefile.npapi with heavy modified. Approved by: portmgr
Diffstat (limited to 'www/mozilla')
-rw-r--r--www/mozilla/Makefile21
-rw-r--r--www/mozilla/files/patch-build_unix_run-mozilla.sh4
-rw-r--r--www/mozilla/pkg-deinstall.in2
-rw-r--r--www/mozilla/pkg-install.in6
4 files changed, 6 insertions, 27 deletions
diff --git a/www/mozilla/Makefile b/www/mozilla/Makefile
index 020d1c671082..21dd5873e51e 100644
--- a/www/mozilla/Makefile
+++ b/www/mozilla/Makefile
@@ -3,11 +3,11 @@
# Whom: eivind/dima/jseger
#
# $FreeBSD$
-# $MCom: ports-stable/www/mozilla/Makefile,v 1.18 2008/06/16 22:25:44 mezz Exp $
+# $MCom: ports-stable/www/mozilla/Makefile,v 1.22 2008/08/07 04:42:36 mezz Exp $
PORTNAME= mozilla
PORTVERSION= 1.7.13
-PORTREVISION?= 8
+PORTREVISION?= 10
PORTEPOCH= 2
CATEGORIES?= www
MASTER_SITES= ${MASTER_SITE_MOZILLA} \
@@ -129,14 +129,6 @@ post-patch:
${WRKDIR}/mozilla.desktop
pre-install:
- if [ ! -L ${PREFIX}/lib/browser_plugins/libjavaplugin_oji.so ]; then \
- for jpi in ${JPI_LIST}; do \
- if [ -f $${jpi} ]; then \
- ${ECHO_CMD} lib/browser_plugins/libjavaplugin_oji.so >> ${PLIST} ; \
- break; \
- fi; \
- done; \
- fi
.if !defined(WITHOUT_MAILNEWS)
@${CP} -RL ${WRKSRC}/dist/bin/defaults/isp ${FAKEDIR}/lib/${MOZILLA}/defaults
.endif
@@ -144,15 +136,6 @@ pre-install:
${ECHO_CMD} "@unexec ${RMDIR} %D/share/applications 2>/dev/null || ${TRUE}" >> ${PLIST}
do-install:
- if [ ! -L ${PREFIX}/lib/browser_plugins/libjavaplugin_oji.so ]; then \
- for jpi in ${JPI_LIST}; do \
- if [ -f $${jpi} ]; then \
- ${LN} -sf $${jpi} \
- ${PREFIX}/lib/browser_plugins/libjavaplugin_oji.so ; \
- break; \
- fi; \
- done; \
- fi
${MKDIR} ${PREFIX}/share/applications
${INSTALL_DATA} ${WRKDIR}/mozilla.desktop \
${PREFIX}/share/applications
diff --git a/www/mozilla/files/patch-build_unix_run-mozilla.sh b/www/mozilla/files/patch-build_unix_run-mozilla.sh
index 87114cc7b898..b00e0e0eefb2 100644
--- a/www/mozilla/files/patch-build_unix_run-mozilla.sh
+++ b/www/mozilla/files/patch-build_unix_run-mozilla.sh
@@ -5,7 +5,7 @@
##
## Set LD_LIBRARY_PATH
-LD_LIBRARY_PATH=${MOZ_DIST_BIN}:${MOZ_DIST_BIN}/plugins:${MRE_HOME}${LD_LIBRARY_PATH+":$LD_LIBRARY_PATH"}
-+LD_LIBRARY_PATH=${MOZ_DIST_BIN}:${MOZ_DIST_BIN}/plugins:%%PREFIX%%/lib/browser_plugins:%%PREFIX%%/lib/browser_linux_plugins:${MRE_HOME}${LD_LIBRARY_PATH+":$LD_LIBRARY_PATH"}
++LD_LIBRARY_PATH=${MOZ_DIST_BIN}:${MOZ_DIST_BIN}/plugins:%%LOCALBASE%%/lib/browser_plugins/symlinks/gecko18:%%LOCALBASE%%/lib/npapi/symlinks/mozilla:${MRE_HOME}${LD_LIBRARY_PATH+":$LD_LIBRARY_PATH"}
if [ -n "$LD_LIBRARYN32_PATH" ]
then
LD_LIBRARYN32_PATH=${MOZ_DIST_BIN}:${MOZ_DIST_BIN}/plugins:${MRE_HOME}${LD_LIBRARYN32_PATH+":$LD_LIBRARYN32_PATH"}
@@ -14,7 +14,7 @@
export MOZILLA_FIVE_HOME LD_LIBRARY_PATH
export SHLIB_PATH LIBPATH LIBRARY_PATH ADDON_PATH DYLD_LIBRARY_PATH
+
-+MOZ_PLUGIN_PATH=%%PREFIX%%/lib/browser_plugins:%%PREFIX%%/lib/browser_linux_plugins
++MOZ_PLUGIN_PATH=%%LOCALBASE%%/lib/browser_plugins/symlinks/gecko18:%%LOCALBASE%%/lib/npapi/symlinks/mozilla
+export MOZ_PLUGIN_PATH
if [ $moz_debug -eq 1 ]
diff --git a/www/mozilla/pkg-deinstall.in b/www/mozilla/pkg-deinstall.in
index a7325eabd2da..ea9cd3dcb04a 100644
--- a/www/mozilla/pkg-deinstall.in
+++ b/www/mozilla/pkg-deinstall.in
@@ -1,6 +1,6 @@
#!/bin/sh
#
-# $MCom: ports-stable/www/mozilla/pkg-deinstall.in,v 1.11 2008/06/16 21:36:02 mezz Exp $
+# $MCom: ports-stable/www/mozilla/pkg-deinstall.in,v 1.13 2008/07/30 15:56:57 mezz Exp $
#
# Date created: Mon Nov 29, 2003
# Whom: Thierry Thomas (<thierry@pompo.net>)
diff --git a/www/mozilla/pkg-install.in b/www/mozilla/pkg-install.in
index 422ce3677545..6f787fe716a1 100644
--- a/www/mozilla/pkg-install.in
+++ b/www/mozilla/pkg-install.in
@@ -1,6 +1,6 @@
#!/bin/sh
#
-# $MCom: ports-stable/www/mozilla/pkg-install.in,v 1.11 2008/06/16 21:36:02 mezz Exp $
+# $MCom: ports-stable/www/mozilla/pkg-install.in,v 1.15 2008/08/04 05:01:00 mezz Exp $
#
# Date created: Mon Nov 29, 2003
# Whom: Thierry Thomas (<thierry@pompo.net>)
@@ -33,10 +33,6 @@ fi
if [ -f ${MOZBIN} -a "${1%-*}" = "nvu" ]; then
./run-mozilla.sh ${MOZBIN} -register > /dev/null 2>&1
fi
-if [ ! -d %%PREFIX%%/lib/browser_plugins ]; then
- mkdir -p %%PREFIX%%/lib/browser_plugins
-fi
-cp -R %%LOCALBASE%%/lib/npapi/symlinks/%%MOZILLA%%/ %%MOZDIR%%/plugins/ > /dev/null 2>&1
cp -R %%LOCALBASE%%/lib/xpi/symlinks/%%MOZILLA%%/ %%MOZDIR%%/extensions/ > /dev/null 2>&1
exit 0