aboutsummaryrefslogtreecommitdiffstats
path: root/www/mplayer-plugin/Makefile
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2003-12-25 13:42:42 +0800
committermarcus <marcus@FreeBSD.org>2003-12-25 13:42:42 +0800
commit7c3bac609cd63e26b9a7e89c9ac17f495dee7731 (patch)
treea378fe6b581940183c91aea133b12ebf715463dc /www/mplayer-plugin/Makefile
parent81fca8fef66030dbb7fc2c9340cc91d8fcdf94ae (diff)
downloadfreebsd-ports-gnome-7c3bac609cd63e26b9a7e89c9ac17f495dee7731.tar.gz
freebsd-ports-gnome-7c3bac609cd63e26b9a7e89c9ac17f495dee7731.tar.zst
freebsd-ports-gnome-7c3bac609cd63e26b9a7e89c9ac17f495dee7731.zip
Update to 1.0.
Diffstat (limited to 'www/mplayer-plugin/Makefile')
-rw-r--r--www/mplayer-plugin/Makefile12
1 files changed, 7 insertions, 5 deletions
diff --git a/www/mplayer-plugin/Makefile b/www/mplayer-plugin/Makefile
index 0e45d8156298..96c1353f557e 100644
--- a/www/mplayer-plugin/Makefile
+++ b/www/mplayer-plugin/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= mplayerplug-in
-PORTVERSION= 0.95
-PORTREVISION= 1
+PORTVERSION= 1.0
CATEGORIES= www multimedia
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= mplayerplug-in
@@ -21,11 +20,14 @@ WRKSRC= ${WRKDIR}/${PORTNAME}
USE_X_PREFIX= yes
USE_REINPLACE= yes
USE_GMAKE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ENV= CPPFLAGS="-I${X11BASE}/include" \
+ LDFLAGS="-L${X11BASE}/lib"
post-patch:
- @${REINPLACE_CMD} -e 's|%%X11BASE%%|${X11BASE}|g ; \
- s|-lpthread|${PTHREAD_LIBS}|g' \
- ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g' \
+ ${WRKSRC}/Makefile.in
@${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|g' \
${WRKSRC}/Source/mplayerplug-in.c