aboutsummaryrefslogtreecommitdiffstats
path: root/www/neon
diff options
context:
space:
mode:
authorohauer <ohauer@FreeBSD.org>2014-12-24 14:03:22 +0800
committerohauer <ohauer@FreeBSD.org>2014-12-24 14:03:22 +0800
commit29825069bb30a9c0fa2e59fc6912713c7f38a097 (patch)
tree6d0a0be85421fd0336f4e6fafa7b7551fc62d88c /www/neon
parent6cd868478793f2e584b797079d9300cfa5c63050 (diff)
downloadfreebsd-ports-gnome-29825069bb30a9c0fa2e59fc6912713c7f38a097.tar.gz
freebsd-ports-gnome-29825069bb30a9c0fa2e59fc6912713c7f38a097.tar.zst
freebsd-ports-gnome-29825069bb30a9c0fa2e59fc6912713c7f38a097.zip
- rename www/neon29 to www/neon and update to neon-0.30.1
- adjust ports depending on neon, bump PORTREVISION Changelog: Fix memory leak with GnuTLS (Werner Baumann, Patrick Ohly). Fix possible crash after DNS lookup errors on Windows (Olivier Goffart). Don't fail if the SSL cert changes between connections with OpenSSL, behaviour now matches that with GnuTLS. Fix PKCS#11 support under OpenSSL with TLS 1.2. Fix static linking with pkg-config file (Alan H) PR: 195786 Differential Revision: https://reviews.freebsd.org/D1319 Submitted by: ohauer Reviewed by: portmgr (bapt, mat) Approved by: portmgr, lev (implicit)
Diffstat (limited to 'www/neon')
-rw-r--r--www/neon/Makefile62
-rw-r--r--www/neon/distinfo2
-rw-r--r--www/neon/pkg-descr19
-rw-r--r--www/neon/pkg-plist183
4 files changed, 266 insertions, 0 deletions
diff --git a/www/neon/Makefile b/www/neon/Makefile
new file mode 100644
index 000000000000..6f5f6a662748
--- /dev/null
+++ b/www/neon/Makefile
@@ -0,0 +1,62 @@
+# Created by: Mikhail Teterin <mi@aldan.algebra.com>
+# $FreeBSD$
+
+PORTNAME= neon
+PORTVERSION= 0.30.1
+CATEGORIES= www
+MASTER_SITES= http://www.webdav.org/neon/
+
+MAINTAINER= lev@FreeBSD.org
+COMMENT= HTTP and WebDAV client library for Unix systems
+
+LICENSE= GPLv2
+
+USES= pathfix libtool
+USE_LDCONFIG= yes
+GNU_CONFIGURE= yes
+
+OPTIONS_SUB= yes
+OPTIONS_DEFINE= CA_BUNDLE DOCS GSSAPI NLS OPENSSL PROXY
+OPTIONS_DEFAULT= CA_BUNDLE EXPAT GSSAPI NLS OPENSSL
+OPTIONS_SINGLE= XML
+OPTIONS_SINGLE_XML= EXPAT LIBXML
+
+CA_BUNDLE_DESC= Install CA bundle for OpenSSL
+LIBXML_DESC= libxml2 XML parser support
+PROXY_DESC= libproxy support
+XML_DESC= XML parser library
+
+CA_BUNDLE_CONFIGURE_ON= --with-ca-bundle=${LOCALBASE}/share/certs/ca-root-nss.crt
+CA_BUNDLE_RUN_DEPENDS= ${LOCALBASE}/share/certs/ca-root-nss.crt:${PORTSDIR}/security/ca_root_nss
+EXPAT_CONFIGURE_WITH= expat
+EXPAT_LIB_DEPENDS= libexpat.so:${PORTSDIR}/textproc/expat2
+GSSAPI_CONFIGURE_WITH= gssapi
+LIBXML_CONFIGURE_WITH= libxml2
+LIBXML_USE= GNOME=libxml2
+NLS_CONFIGURE_ENABLE= nls
+NLS_USES= gettext
+OPENSSL_CONFIGURE_WITH= ssl
+OPENSSL_USE= OPENSSL=yes
+PROXY_CONFIGURE_WITH= libproxy
+PROXY_LIB_DEPENDS= libproxy.so:${PORTSDIR}/net/libproxy
+
+.include <bsd.port.options.mk>
+
+CONFIGURE_ARGS+=--enable-shared \
+ --with-libs=${LOCALBASE}:${PREFIX}
+
+.if ${PORT_OPTIONS:MCA_BUNDLE} && !${PORT_OPTIONS:MOPENSSL}
+WARNING+= "OpenSSL need for CA bundle support"
+WARNING+= "Enable the OPENSSL option or disable the CA_BUNDLE option"
+.endif
+
+PLIST_SUB+= PORTVERSION=${PORTVERSION}
+DOCSDIR= ${PREFIX}/share/doc/neon
+
+post-patch:
+ ${REINPLACE_CMD} -e 's|-@NEON_VERSION@$$||' ${WRKSRC}/Makefile.in
+
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libneon.so.27.*
+
+.include <bsd.port.mk>
diff --git a/www/neon/distinfo b/www/neon/distinfo
new file mode 100644
index 000000000000..54d6b7caccd6
--- /dev/null
+++ b/www/neon/distinfo
@@ -0,0 +1,2 @@
+SHA256 (neon-0.30.1.tar.gz) = 00c626c0dc18d094ab374dbd9a354915bfe4776433289386ed489c2ec0845cdd
+SIZE (neon-0.30.1.tar.gz) = 911414
diff --git a/www/neon/pkg-descr b/www/neon/pkg-descr
new file mode 100644
index 000000000000..3f8647c6bcf3
--- /dev/null
+++ b/www/neon/pkg-descr
@@ -0,0 +1,19 @@
+Neon is an HTTP and WebDAV client library for Unix systems, with a C
+interface. Featuring:
+
+ . High-level interface to HTTP and WebDAV methods
+ (PUT, GET, HEAD etc)
+ . Low-level interface to HTTP request handling, to allow
+ implementing new methods easily.
+ . HTTP/1.1 and HTTP/1.0 persistent connections
+ . RFC2617 basic and digest authentication
+ (including auth-int, md5-sess)
+ . Proxy support (including basic/digest authentication)
+ . Generic WebDAV 207 XML response handling mechanism
+ . XML parsing using the expat or libxml parsers
+ . Easy generation of error messages from 207 error responses
+ . WebDAV resource manipulation: MOVE, COPY, DELETE, MKCOL
+ . WebDAV metadata support: set and remove properties, query
+ any set of properties (PROPPATCH/PROPFIND).
+
+WWW: http://www.webdav.org/neon/
diff --git a/www/neon/pkg-plist b/www/neon/pkg-plist
new file mode 100644
index 000000000000..3191d996c824
--- /dev/null
+++ b/www/neon/pkg-plist
@@ -0,0 +1,183 @@
+bin/neon-config
+include/neon/ne_207.h
+include/neon/ne_acl.h
+include/neon/ne_acl3744.h
+include/neon/ne_alloc.h
+include/neon/ne_auth.h
+include/neon/ne_basic.h
+include/neon/ne_compress.h
+include/neon/ne_dates.h
+include/neon/ne_defs.h
+include/neon/ne_i18n.h
+include/neon/ne_locks.h
+include/neon/ne_md5.h
+include/neon/ne_pkcs11.h
+include/neon/ne_props.h
+include/neon/ne_redirect.h
+include/neon/ne_request.h
+include/neon/ne_session.h
+include/neon/ne_socket.h
+include/neon/ne_ssl.h
+include/neon/ne_string.h
+include/neon/ne_uri.h
+include/neon/ne_utils.h
+include/neon/ne_xml.h
+include/neon/ne_xmlreq.h
+lib/libneon.a
+lib/libneon.so
+lib/libneon.so.27
+lib/libneon.so.27.3.1
+libdata/pkgconfig/neon.pc
+man/man1/neon-config.1.gz
+man/man3/ne_add_request_header.3.gz
+man/man3/ne_addr_destroy.3.gz
+man/man3/ne_addr_error.3.gz
+man/man3/ne_addr_first.3.gz
+man/man3/ne_addr_next.3.gz
+man/man3/ne_addr_resolve.3.gz
+man/man3/ne_addr_result.3.gz
+man/man3/ne_buffer.3.gz
+man/man3/ne_buffer_altered.3.gz
+man/man3/ne_buffer_append.3.gz
+man/man3/ne_buffer_clear.3.gz
+man/man3/ne_buffer_concat.3.gz
+man/man3/ne_buffer_create.3.gz
+man/man3/ne_buffer_destroy.3.gz
+man/man3/ne_buffer_finish.3.gz
+man/man3/ne_buffer_grow.3.gz
+man/man3/ne_buffer_ncreate.3.gz
+man/man3/ne_buffer_zappend.3.gz
+man/man3/ne_calloc.3.gz
+man/man3/ne_close_connection.3.gz
+man/man3/ne_forget_auth.3.gz
+man/man3/ne_get_error.3.gz
+man/man3/ne_get_request_flag.3.gz
+man/man3/ne_get_response_header.3.gz
+man/man3/ne_get_scheme.3.gz
+man/man3/ne_get_server_hostport.3.gz
+man/man3/ne_get_session_flag.3.gz
+man/man3/ne_get_status.3.gz
+man/man3/ne_has_support.3.gz
+man/man3/ne_i18n_init.3.gz
+man/man3/ne_iaddr_cmp.3.gz
+man/man3/ne_iaddr_free.3.gz
+man/man3/ne_iaddr_make.3.gz
+man/man3/ne_iaddr_parse.3.gz
+man/man3/ne_iaddr_print.3.gz
+man/man3/ne_iaddr_raw.3.gz
+man/man3/ne_iaddr_reverse.3.gz
+man/man3/ne_iaddr_typeof.3.gz
+man/man3/ne_malloc.3.gz
+man/man3/ne_oom_callback.3.gz
+man/man3/ne_print_request_header.3.gz
+man/man3/ne_qtoken.3.gz
+man/man3/ne_realloc.3.gz
+man/man3/ne_request_create.3.gz
+man/man3/ne_request_destroy.3.gz
+man/man3/ne_request_dispatch.3.gz
+man/man3/ne_response_header_iterate.3.gz
+man/man3/ne_session_create.3.gz
+man/man3/ne_session_destroy.3.gz
+man/man3/ne_session_proxy.3.gz
+man/man3/ne_session_socks_proxy.3.gz
+man/man3/ne_session_system_proxy.3.gz
+man/man3/ne_set_addrlist.3.gz
+man/man3/ne_set_connect_timeout.3.gz
+man/man3/ne_set_error.3.gz
+man/man3/ne_set_proxy_auth.3.gz
+man/man3/ne_set_read_timeout.3.gz
+man/man3/ne_set_request_body_buffer.3.gz
+man/man3/ne_set_request_body_fd.3.gz
+man/man3/ne_set_request_flag.3.gz
+man/man3/ne_set_server_auth.3.gz
+man/man3/ne_set_session_flag.3.gz
+man/man3/ne_set_useragent.3.gz
+man/man3/ne_shave.3.gz
+man/man3/ne_sock_exit.3.gz
+man/man3/ne_sock_init.3.gz
+man/man3/ne_ssl_cert_cmp.3.gz
+man/man3/ne_ssl_cert_export.3.gz
+man/man3/ne_ssl_cert_free.3.gz
+man/man3/ne_ssl_cert_identity.3.gz
+man/man3/ne_ssl_cert_import.3.gz
+man/man3/ne_ssl_cert_issuer.3.gz
+man/man3/ne_ssl_cert_read.3.gz
+man/man3/ne_ssl_cert_signedby.3.gz
+man/man3/ne_ssl_cert_subject.3.gz
+man/man3/ne_ssl_cert_write.3.gz
+man/man3/ne_ssl_clicert_decrypt.3.gz
+man/man3/ne_ssl_clicert_encrypted.3.gz
+man/man3/ne_ssl_clicert_free.3.gz
+man/man3/ne_ssl_clicert_name.3.gz
+man/man3/ne_ssl_clicert_owner.3.gz
+man/man3/ne_ssl_clicert_read.3.gz
+man/man3/ne_ssl_dname_cmp.3.gz
+man/man3/ne_ssl_readable_dname.3.gz
+man/man3/ne_ssl_set_verify.3.gz
+man/man3/ne_ssl_trust_cert.3.gz
+man/man3/ne_ssl_trust_default_ca.3.gz
+man/man3/ne_status.3.gz
+man/man3/ne_strdup.3.gz
+man/man3/ne_strndup.3.gz
+man/man3/ne_token.3.gz
+man/man3/ne_version_match.3.gz
+man/man3/ne_version_string.3.gz
+man/man3/ne_xml_create.3.gz
+man/man3/ne_xml_destroy.3.gz
+man/man3/neon.3.gz
+%%PORTDOCS%%%%DOCSDIR%%/html/api.html
+%%PORTDOCS%%%%DOCSDIR%%/html/biblio.html
+%%PORTDOCS%%%%DOCSDIR%%/html/compliance.html
+%%PORTDOCS%%%%DOCSDIR%%/html/features.html
+%%PORTDOCS%%%%DOCSDIR%%/html/index.html
+%%PORTDOCS%%%%DOCSDIR%%/html/intro.html
+%%PORTDOCS%%%%DOCSDIR%%/html/ref.html
+%%PORTDOCS%%%%DOCSDIR%%/html/refalloc.html
+%%PORTDOCS%%%%DOCSDIR%%/html/refauth.html
+%%PORTDOCS%%%%DOCSDIR%%/html/refbuf.html
+%%PORTDOCS%%%%DOCSDIR%%/html/refbufapp.html
+%%PORTDOCS%%%%DOCSDIR%%/html/refbufcr.html
+%%PORTDOCS%%%%DOCSDIR%%/html/refbufdest.html
+%%PORTDOCS%%%%DOCSDIR%%/html/refbufutil.html
+%%PORTDOCS%%%%DOCSDIR%%/html/refcert.html
+%%PORTDOCS%%%%DOCSDIR%%/html/refclicert.html
+%%PORTDOCS%%%%DOCSDIR%%/html/refconfig.html
+%%PORTDOCS%%%%DOCSDIR%%/html/referr.html
+%%PORTDOCS%%%%DOCSDIR%%/html/reffeat.html
+%%PORTDOCS%%%%DOCSDIR%%/html/refgetst.html
+%%PORTDOCS%%%%DOCSDIR%%/html/refi18n.html
+%%PORTDOCS%%%%DOCSDIR%%/html/refiaddr.html
+%%PORTDOCS%%%%DOCSDIR%%/html/refneon.html
+%%PORTDOCS%%%%DOCSDIR%%/html/refopts.html
+%%PORTDOCS%%%%DOCSDIR%%/html/refproxy.html
+%%PORTDOCS%%%%DOCSDIR%%/html/refreq.html
+%%PORTDOCS%%%%DOCSDIR%%/html/refreqbody.html
+%%PORTDOCS%%%%DOCSDIR%%/html/refreqflags.html
+%%PORTDOCS%%%%DOCSDIR%%/html/refreqhdr.html
+%%PORTDOCS%%%%DOCSDIR%%/html/refresolve.html
+%%PORTDOCS%%%%DOCSDIR%%/html/refresphdr.html
+%%PORTDOCS%%%%DOCSDIR%%/html/refsess.html
+%%PORTDOCS%%%%DOCSDIR%%/html/refsessflags.html
+%%PORTDOCS%%%%DOCSDIR%%/html/refshave.html
+%%PORTDOCS%%%%DOCSDIR%%/html/refsockinit.html
+%%PORTDOCS%%%%DOCSDIR%%/html/refsslca.html
+%%PORTDOCS%%%%DOCSDIR%%/html/refsslcert2.html
+%%PORTDOCS%%%%DOCSDIR%%/html/refsslcertio.html
+%%PORTDOCS%%%%DOCSDIR%%/html/refssldname.html
+%%PORTDOCS%%%%DOCSDIR%%/html/refsslvfy.html
+%%PORTDOCS%%%%DOCSDIR%%/html/refstatus.html
+%%PORTDOCS%%%%DOCSDIR%%/html/reftok.html
+%%PORTDOCS%%%%DOCSDIR%%/html/refvers.html
+%%PORTDOCS%%%%DOCSDIR%%/html/refxml.html
+%%PORTDOCS%%%%DOCSDIR%%/html/security.html
+%%PORTDOCS%%%%DOCSDIR%%/html/using.html
+%%PORTDOCS%%%%DOCSDIR%%/html/xml.html
+%%NLS%%share/locale/cs/LC_MESSAGES/neon.mo
+%%NLS%%share/locale/de/LC_MESSAGES/neon.mo
+%%NLS%%share/locale/fr/LC_MESSAGES/neon.mo
+%%NLS%%share/locale/ja/LC_MESSAGES/neon.mo
+%%NLS%%share/locale/nn/LC_MESSAGES/neon.mo
+%%NLS%%share/locale/pl/LC_MESSAGES/neon.mo
+%%NLS%%share/locale/ru/LC_MESSAGES/neon.mo
+%%NLS%%share/locale/tr/LC_MESSAGES/neon.mo
+%%NLS%%share/locale/zh_CN/LC_MESSAGES/neon.mo