aboutsummaryrefslogtreecommitdiffstats
path: root/www/netscape7/Makefile
diff options
context:
space:
mode:
authorsteve <steve@FreeBSD.org>1999-02-22 12:31:44 +0800
committersteve <steve@FreeBSD.org>1999-02-22 12:31:44 +0800
commitcb892396e43fda2e92c327fea079400f000413e3 (patch)
tree9088be0b92ee9cee36f304fe90d8bd82778d18af /www/netscape7/Makefile
parent04b82b228c9c91eabcecbcdb456ad47be3bdaa28 (diff)
downloadfreebsd-ports-gnome-cb892396e43fda2e92c327fea079400f000413e3.tar.gz
freebsd-ports-gnome-cb892396e43fda2e92c327fea079400f000413e3.tar.zst
freebsd-ports-gnome-cb892396e43fda2e92c327fea079400f000413e3.zip
Cleanups from maintainer.
PR: 9928 Submitted by: maintainer
Diffstat (limited to 'www/netscape7/Makefile')
-rw-r--r--www/netscape7/Makefile27
1 files changed, 14 insertions, 13 deletions
diff --git a/www/netscape7/Makefile b/www/netscape7/Makefile
index b7c31a6d6a1d..8518ff4e485b 100644
--- a/www/netscape7/Makefile
+++ b/www/netscape7/Makefile
@@ -3,38 +3,39 @@
# Date created: 24 Feb 1997
# Whom: ache
#
-# $Id: Makefile,v 1.6 1998/12/24 06:29:59 steve Exp $
+# $Id: Makefile,v 1.7 1999/01/06 04:18:06 simokawa Exp $
#
-DISTNAME= linux-netscape-4.08
+DISTNAME= communicator-v408-export.x86-unknown-linux2.0_libc5
+PKGNAME= linux-netscape-4.08
CATEGORIES= www
-MASTER_SITES= ftp://ftp.netscape.com/pub/communicator/4.08/english/unix/supported/linux12/base_install/ \
- ftp://sunsite.doc.ic.ac.uk/Mirrors/ftp.netscape.com/pub/communicator/4.08/english/unix/supported/linux12/base_install/
-DISTFILES= communicator-v408-export.x86-unknown-linux1.2.tar.gz
+MASTER_SITES= ftp://ftp.netscape.com/pub/communicator/4.08/english/unix/supported/linux20/base_install/ \
+ ftp://sunsite.doc.ic.ac.uk/Mirrors/ftp.netscape.com/pub/communicator/4.08/english/unix/supported/linux20/base_install/ \
+ ftp://ftp.funet.fi/pub/mirrors/ftp.netscape.com/pub/communicator/4.08/english/unix/supported/linux20/base_install/ \
+ ftp://ftp.sunsite.auc.dk/disk4/mirrorsite.netscape.com/pub/communicator/4.08/english/unix/supported/linux20/base_install/
-MAINTAINER= tom@eborcom.com
+MAINTAINER= tom@eborcom.com
-RUN_DEPENDS= /compat/linux/lib/ld.so:${PORTSDIR}/emulators/linux_lib
-BUILD_DEPENDS= /compat/linux/lib/ld.so:${PORTSDIR}/emulators/linux_lib
+RUN_DEPENDS= /compat/linux/lib/ld.so:${PORTSDIR}/emulators/linux_lib
ONLY_FOR_ARCHS= i386
-WRKSRC= ${WRKDIR}/communicator-v408.x86-unknown-linux1.2
-NO_BUILD= Yes
+WRKSRC= ${WRKDIR}/communicator-v408.x86-unknown-linux2.0
+NO_BUILD= Yes
-NDIR= ${PREFIX}/lib/netscape
+NDIR= ${PREFIX}/lib/netscape
BINDIR= ${PREFIX}/bin
do-install:
cd ${WRKSRC} && yes "" | \
LC_TIME=C MOZILLA_HOME="${NDIR}" ./ns-install
- ${MV} ${NDIR}/netscape ${NDIR}/netscape.bin
+ ${MV} -f ${NDIR}/netscape ${NDIR}/netscape.bin
${INSTALL_SCRIPT} ${WRKSRC}/netscape ${BINDIR}
if [ ! -f ${NDIR}/mailcap ] ; then \
${INSTALL_DATA} ${FILESDIR}/mailcap ${NDIR}; \
fi
${RM} -rf ${NDIR}/nls ${NDIR}/movemail-src ${NDIR}/XKeysymDB
- chown -R bin.bin ${NDIR}
+ chown -R ${BINOWN}.${BINGRP} ${NDIR}
post-install:
@${CAT} ${PKGDIR}/DESCR