aboutsummaryrefslogtreecommitdiffstats
path: root/www/netsurf/Makefile
diff options
context:
space:
mode:
authortijl <tijl@FreeBSD.org>2014-03-16 01:52:53 +0800
committertijl <tijl@FreeBSD.org>2014-03-16 01:52:53 +0800
commit44f306f697fa7d51c08580c33762a46e0330b551 (patch)
tree954684ab31afff8131f80528d1b044158b9ef3d7 /www/netsurf/Makefile
parentc751d003343292ce270fcdf674c76262c1cfccce (diff)
downloadfreebsd-ports-gnome-44f306f697fa7d51c08580c33762a46e0330b551.tar.gz
freebsd-ports-gnome-44f306f697fa7d51c08580c33762a46e0330b551.tar.zst
freebsd-ports-gnome-44f306f697fa7d51c08580c33762a46e0330b551.zip
- Use the more common libpng instead of libmng.
- Add an icon to the desktop entry. - Use option helpers. - Respect CFLAGS. - Remove clang support patch. No longer necessary. - Add a patch to fix rendering of SVG and BMP images on little-endian systems and all image formats on big-endian systems. [1] PR: ports/187466 [1] Tested by: Craig Butler <craig001@lerwick.hopto.org> [1]
Diffstat (limited to 'www/netsurf/Makefile')
-rw-r--r--www/netsurf/Makefile24
1 files changed, 12 insertions, 12 deletions
diff --git a/www/netsurf/Makefile b/www/netsurf/Makefile
index fc6e0ed8c5c6..50af8d119f2a 100644
--- a/www/netsurf/Makefile
+++ b/www/netsurf/Makefile
@@ -3,7 +3,7 @@
PORTNAME= netsurf
PORTVERSION= 3.0
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= www
MASTER_SITES= http://download.netsurf-browser.org/netsurf/releases/source-full/
DISTNAME= ${PORTNAME}-${PORTVERSION}-full-src
@@ -16,7 +16,8 @@ LICENSE_COMB= multi
BUILD_DEPENDS= ${LOCALBASE}/bin/flex:${PORTSDIR}/textproc/flex
LIB_DEPENDS= libcurl.so:${PORTSDIR}/ftp/curl \
- libmng.so:${PORTSDIR}/graphics/libmng
+ libjpeg.so:${PORTSDIR}/graphics/jpeg \
+ libpng15.so:${PORTSDIR}/graphics/png
ALL_TARGET= #empty
CFLAGS+= -I${LOCALBASE}/include
@@ -24,23 +25,20 @@ LDFLAGS+= -lssl -lcrypto -L${LOCALBASE}/lib ${ICONV_LIB}
MAKE_ARGS= HOST_CC="${CC}" CC="${CC}" CCOPT="" HOST="${OPSYS}" \
WARNFLAGS="" Q="" OPTCFLAGS="${CFLAGS}"
USES= bison gmake pkgconfig iconv
-USE_GNOME= librsvg2
+USE_GNOME= gtk20 librsvg2
NSFB_VERSION= 0.1.0
WRKSRC= ${WRKDIR}/${PORTNAME}-full-${PORTVERSION}
-DESKTOP_ENTRIES="NetSurf" "${COMMENT}" "" "${PORTNAME}" "" "true"
+DESKTOP_ENTRIES="NetSurf" "${COMMENT}" "${DATADIR}/${PORTNAME}.xpm" \
+ "${PORTNAME}" "" "true"
OPTIONS_DEFINE= GSTREAMER WEBP
-
+GSTREAMER_USE= GSTREAMER=yes
WEBP_LIB_DEPENDS= libwebp.so:${PORTSDIR}/graphics/webp
.include <bsd.port.options.mk>
-.if ${PORT_OPTIONS:MGSTREAMER}
-USE_GSTREAMER= yes
-.endif
-
.if ${OPSYS} == DragonFly
LIB_DEPENDS+= libssl.so:${PORTSDIR}/security/openssl
BUILD_DEPENDS+= gperf:${PORTSDIR}/devel/gperf
@@ -53,12 +51,14 @@ post-patch:
${WRKSRC}/src/libnsfb-${NSFB_VERSION}/Makefile
@${REINPLACE_CMD} 's|endian|sys/endian|' \
${WRKSRC}/src/libnsfb-${NSFB_VERSION}/src/plot/*bpp*.c
+ @${REINPLACE_CMD} '/CFLAGS/d' \
+ ${WRKSRC}/src/netsurf-${PORTVERSION}/Makefile.defaults
@${REINPLACE_CMD} 's| -O2||' \
${WRKSRC}/src/netsurf-${PORTVERSION}/gtk/Makefile.defaults
- @${REINPLACE_CMD} '/OpenSSL/d ; s| -g|| ; s|-DG_DISABLE_DEPRECATED||' \
+ @${REINPLACE_CMD} \
+ -e '/OpenSSL/d' -e '/lcms/d' -e 's| -g||' \
+ -e 's/-DG_DISABLE_DEPRECATED//' \
${WRKSRC}/src/netsurf-${PORTVERSION}/gtk/Makefile.target
- @${REINPLACE_CMD} -e '/ifeq.*clang/s/word 1/filter clang/' \
- ${WRKSRC}/src/buildsystem-1.0/makefiles/Makefile.tools
@${REINPLACE_CMD} -e 's| -g|| ; s|flex|${LOCALBASE}/bin/&|' \
${WRKSRC}/src/nsgenbind-0.0.1/src/Makefile