aboutsummaryrefslogtreecommitdiffstats
path: root/www/netsurf/Makefile
diff options
context:
space:
mode:
authorpawel <pawel@FreeBSD.org>2013-07-11 03:41:30 +0800
committerpawel <pawel@FreeBSD.org>2013-07-11 03:41:30 +0800
commit4682c2c61dcb7a63ae78f7c087ba5d0bda84f154 (patch)
treef00883f68004a81b9e525ad5cc94de309898b666 /www/netsurf/Makefile
parent31dd4fd824aafa89c7f4eb95e23f32974c053110 (diff)
downloadfreebsd-ports-gnome-4682c2c61dcb7a63ae78f7c087ba5d0bda84f154.tar.gz
freebsd-ports-gnome-4682c2c61dcb7a63ae78f7c087ba5d0bda84f154.tar.zst
freebsd-ports-gnome-4682c2c61dcb7a63ae78f7c087ba5d0bda84f154.zip
Convert my ports to current standards
- Switch USE_GMAKE to USES=gmake - Define supported options so users can see them in config dialogs - Use OPTIONS_SUB for plist alteration - Convert to options macros for better readability - Use PORTDOCS where it makes sense
Diffstat (limited to 'www/netsurf/Makefile')
-rw-r--r--www/netsurf/Makefile6
1 files changed, 2 insertions, 4 deletions
diff --git a/www/netsurf/Makefile b/www/netsurf/Makefile
index 936fda7b0469..8d1a50c980ff 100644
--- a/www/netsurf/Makefile
+++ b/www/netsurf/Makefile
@@ -32,16 +32,14 @@ DESKTOP_ENTRIES="NetSurf" "${COMMENT}" "" "${PORTNAME}" "" "true"
OPTIONS_DEFINE= GSTREAMER WEBP
+WEBP_LIB_DEPENDS= webp:${PORTSDIR}/graphics/webp
+
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MGSTREAMER}
USE_GSTREAMER= yes
.endif
-.if ${PORT_OPTIONS:MWEBP}
-LIB_DEPENDS+= webp:${PORTSDIR}/graphics/webp
-.endif
-
post-patch:
@${REINPLACE_CMD} '/^NSFB_LINUX_AVAILABLE/ s|yes|no| ; s| -g||' \
${WRKSRC}/src/libnsfb-${NSFB_VERSION}/Makefile