aboutsummaryrefslogtreecommitdiffstats
path: root/www/nginx-devel/Makefile
diff options
context:
space:
mode:
authorosa <osa@FreeBSD.org>2011-04-05 02:33:35 +0800
committerosa <osa@FreeBSD.org>2011-04-05 02:33:35 +0800
commitbfee92fa15fb36938396fd7457214ec5c95c9520 (patch)
tree393a582eb6e1d8796c317d3375e1a62c5d6f5c45 /www/nginx-devel/Makefile
parentde3992cf5fcc03417c2a45afd07fadd657b87bd1 (diff)
downloadfreebsd-ports-gnome-bfee92fa15fb36938396fd7457214ec5c95c9520.tar.gz
freebsd-ports-gnome-bfee92fa15fb36938396fd7457214ec5c95c9520.tar.zst
freebsd-ports-gnome-bfee92fa15fb36938396fd7457214ec5c95c9520.zip
Add third-party http_subs_filter module.
Do not bump PORTREVISION. PR: 156163
Diffstat (limited to 'www/nginx-devel/Makefile')
-rw-r--r--www/nginx-devel/Makefile9
1 files changed, 9 insertions, 0 deletions
diff --git a/www/nginx-devel/Makefile b/www/nginx-devel/Makefile
index 94e319bcf46f..1ff6f599c345 100644
--- a/www/nginx-devel/Makefile
+++ b/www/nginx-devel/Makefile
@@ -63,6 +63,7 @@ OPTIONS= DEBUG "Enable nginx debugging" off \
HTTP_PUSH_MODULE "3rd party push module" off \
HTTP_REDIS_MODULE "3rd party http_redis module" off \
HTTP_RESPONSE_MODULE "3rd party http_response module" off \
+ HTTP_SUBS_FILTER_MODULE "3rd party subs filter module" off \
HTTP_UPLOAD_MODULE "3rd party upload module" off \
HTTP_UPLOAD_PROGRESS "3rd party uploadprogress module" off \
HTTP_UPSTREAM_FAIR "3rd party upstream fair module" off \
@@ -310,6 +311,14 @@ DISTFILES+= ngx_http_response-${NGINX_RESPONSE_MODULE_VERSION}.tar.gz:response
CONFIGURE_ARGS+=--add-module=${WRKDIR}/ngx_http_response-${NGINX_RESPONSE_MODULE_VERSION}
.endif
+.if defined(WITH_HTTP_SUBS_FILTER_MODULE)
+NGINX_HTTP_SUBS_FILTER_MODULE_VERSION= 0.5.2.r44
+MASTER_SITES+= ${MASTER_SITE_LOCAL:S/$/:subs_filter/}
+MASTER_SITE_SUBDIR+= osa/:subs_filter
+DISTFILES+= ngx_http_subs_filter_module-${NGINX_HTTP_SUBS_FILTER_MODULE_VERSION}.tar.gz:subs_filter
+CONFIGURE_ARGS+=--add-module=${WRKDIR}/ngx_http_subs_filter_module-${NGINX_HTTP_SUBS_FILTER_MODULE_VERSION}
+.endif
+
.if defined(WITH_HTTP_SECURE_LINK_MODULE)
CONFIGURE_ARGS+=--with-http_secure_link_module
.endif