aboutsummaryrefslogtreecommitdiffstats
path: root/www/nginx-devel/Makefile
diff options
context:
space:
mode:
authorosa <osa@FreeBSD.org>2007-08-29 14:35:18 +0800
committerosa <osa@FreeBSD.org>2007-08-29 14:35:18 +0800
commita84836c33b970f0ce9ccb346e25b57dba976b701 (patch)
treecf4957c6d62f24fd904fcac29c4f8704af731866 /www/nginx-devel/Makefile
parent57f90585357181ea3524ad541928dbc6286fdd50 (diff)
downloadfreebsd-ports-gnome-a84836c33b970f0ce9ccb346e25b57dba976b701.tar.gz
freebsd-ports-gnome-a84836c33b970f0ce9ccb346e25b57dba976b701.tar.zst
freebsd-ports-gnome-a84836c33b970f0ce9ccb346e25b57dba976b701.zip
Update to 0.6.9.
Utilize ETCDIR. <ChangeLog> *) Bugfix: a worker process may got caught in an endless loop, if the HTTPS protocol was used; bug appeared in 0.6.7. *) Bugfix: if server listened on two addresses or ports and trailing wildcard was used, then nginx did not run. *) Bugfix: the "ip_hash" directive might incorrectly mark servers as down. *) Bugfix: nginx could not be built on amd64; bug appeared in 0.6.8. </ChangeLog>
Diffstat (limited to 'www/nginx-devel/Makefile')
-rw-r--r--www/nginx-devel/Makefile16
1 files changed, 8 insertions, 8 deletions
diff --git a/www/nginx-devel/Makefile b/www/nginx-devel/Makefile
index b15f921c7198..7dc839bad6b9 100644
--- a/www/nginx-devel/Makefile
+++ b/www/nginx-devel/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= nginx
-PORTVERSION= 0.6.8
+PORTVERSION= 0.6.9
CATEGORIES= www
MASTER_SITES= http://sysoev.ru/nginx/
MASTER_SITES+= ${MASTER_SITE_LOCAL}
@@ -42,10 +42,10 @@ HTTP_PORT?= 80
CONFLICTS?= nginx-0.5.*
USE_RC_SUBR= nginx.sh
HAS_CONFIGURE= yes
-CONFIGURE_ARGS+=--prefix=${PREFIX}/etc/nginx \
+CONFIGURE_ARGS+=--prefix=${ETCDIR} \
--with-cc-opt="-I ${LOCALBASE}/include" \
--with-ld-opt="-L ${LOCALBASE}/lib" \
- --conf-path=${PREFIX}/etc/nginx/nginx.conf \
+ --conf-path=${ETCDIR}/nginx.conf \
--sbin-path=${PREFIX}/sbin/nginx \
--pid-path=${NGINX_RUNDIR}/nginx.pid \
--error-log-path=${NGINX_LOGDIR}/nginx-error.log \
@@ -144,16 +144,16 @@ do-build:
@cd ${WRKSRC} && ${MAKE}
do-install:
- ${MKDIR} ${PREFIX}/etc/nginx ${NGINX_TMPDIR}
+ ${MKDIR} ${ETCDIR} ${NGINX_TMPDIR}
${CHOWN} ${WWWOWN}:${WWWGRP} ${NGINX_TMPDIR}
${INSTALL_PROGRAM} ${WRKSRC}/objs/nginx ${PREFIX}/sbin
.for i in koi-win koi-utf win-utf fastcgi_params
- ${INSTALL_DATA} ${WRKSRC}/conf/${i} ${PREFIX}/etc/nginx
+ ${INSTALL_DATA} ${WRKSRC}/conf/${i} ${ETCDIR}
.endfor
.for i in mime.types nginx.conf
- [ -f ${PREFIX}/etc/nginx/${i} ] || \
- ${INSTALL_DATA} ${WRKSRC}/conf/${i} ${PREFIX}/etc/nginx
- ${INSTALL_DATA} ${WRKSRC}/conf/${i} ${PREFIX}/etc/nginx/${i}-dist
+ [ -f ${ETCDIR}/${i} ] || \
+ ${INSTALL_DATA} ${WRKSRC}/conf/${i} ${ETCDIR}
+ ${INSTALL_DATA} ${WRKSRC}/conf/${i} ${ETCDIR}/${i}-dist
.endfor
.if defined(WITH_HTTP_MODULE) && defined(WITH_WWW)
${MKDIR} ${PREFIX}/www/nginx-dist