aboutsummaryrefslogtreecommitdiffstats
path: root/www/nginx-devel
diff options
context:
space:
mode:
authorosa <osa@FreeBSD.org>2012-06-28 22:25:06 +0800
committerosa <osa@FreeBSD.org>2012-06-28 22:25:06 +0800
commitc8bcd950ac6a0c8cdf1d98a7bc223fca4ce43725 (patch)
treead699132105027881dd9b8c11cceb65ea0227787 /www/nginx-devel
parent8094f4ed2c4540cbc058bbcdccf71f0f03f4f8bf (diff)
downloadfreebsd-ports-gnome-c8bcd950ac6a0c8cdf1d98a7bc223fca4ce43725.tar.gz
freebsd-ports-gnome-c8bcd950ac6a0c8cdf1d98a7bc223fca4ce43725.tar.zst
freebsd-ports-gnome-c8bcd950ac6a0c8cdf1d98a7bc223fca4ce43725.zip
Fix build without mail-specific modules after switch to OptionsNG.
PR: 169498
Diffstat (limited to 'www/nginx-devel')
-rw-r--r--www/nginx-devel/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/www/nginx-devel/Makefile b/www/nginx-devel/Makefile
index ccd1fd8f0874..d43a1925a3b7 100644
--- a/www/nginx-devel/Makefile
+++ b/www/nginx-devel/Makefile
@@ -782,16 +782,16 @@ PLIST_SUB+= WWWDATA="@comment "
.if ${PORT_OPTIONS:MMAIL}
CONFIGURE_ARGS+=--with-mail
-.if ${PORT_OPTIONS:NMAIL_IMAP}
+.if empty(PORT_OPTIONS:NMAIL_IMAP)
CONFIGURE_ARGS+=--without-mail_imap_module
.endif
-.if ${PORT_OPTIONS:NMAIL_POP3}
+.if empty(PORT_OPTIONS:NMAIL_POP3)
CONFIGURE_ARGS+=--without-mail_pop3_module
.endif
-.if ${PORT_OPTIONS:NMAIL_SMTP}
+.if empty(PORT_OPTIONS:NMAIL_SMTP)
CONFIGURE_ARGS+=--without-mail_smtp_module
.endif
-.if ${PORT_OPTIONS:MMAIL_SSL)
+.if ${PORT_OPTIONS:MMAIL_SSL}
NGINX_OPENSSL= yes
CONFIGURE_ARGS+=--with-mail_ssl_module
.endif