aboutsummaryrefslogtreecommitdiffstats
path: root/www/nginx/Makefile
diff options
context:
space:
mode:
authorosa <osa@FreeBSD.org>2010-12-12 20:22:47 +0800
committerosa <osa@FreeBSD.org>2010-12-12 20:22:47 +0800
commit091f84ba352001356606982bc19ec931515a7582 (patch)
tree07cf2017bf52bb80273971f7ee24e9f4190977ec /www/nginx/Makefile
parentad6bdfc59d8c0297cebafc0897e731aa78122419 (diff)
downloadfreebsd-ports-gnome-091f84ba352001356606982bc19ec931515a7582.tar.gz
freebsd-ports-gnome-091f84ba352001356606982bc19ec931515a7582.tar.zst
freebsd-ports-gnome-091f84ba352001356606982bc19ec931515a7582.zip
Update passenger as well as support for passenger-specific ports
from 3.0.0 to 3.0.1. Also: o) respect CC/CXX/CFLAGS/PTHREAD_LIBS flags; o) build depends against devel/libev instead of internal libev; o) change depends from curl binary to libcurl; o) revert back GEM_LIB_DIR for pkg-message. (!) Do not bump PORTREVISIONs for www/nginx and www/nginx-devel ports. <Note> Patch extra-patch-passenger::ext::common::Utils.cpp obtained from passenger's git: https://github.com/FooBarWidget/passenger/commit/9a811060db56cfad2e2056d90cac1a354870dbad and should be remove in next [3.0.2] port update. </Note> Approved by: maintainer [*] Pointy hat to: wen (!)
Diffstat (limited to 'www/nginx/Makefile')
-rw-r--r--www/nginx/Makefile12
1 files changed, 9 insertions, 3 deletions
diff --git a/www/nginx/Makefile b/www/nginx/Makefile
index 003f5cc5c542..cccec3228327 100644
--- a/www/nginx/Makefile
+++ b/www/nginx/Makefile
@@ -397,11 +397,13 @@ CONFIGURE_ARGS+=--with-pcre
.endif
.if defined(WITH_PASSENGER_MODULE)
-PASSENGER_VERSION= 3.0.0
+PASSENGER_VERSION= 3.0.1
MASTER_SITES+= RF/passenger/:passenger
DISTFILES+= passenger-${PASSENGER_VERSION}.tar.gz:passenger
CONFIGURE_ARGS+=--add-module=${WRKDIR}/passenger-${PASSENGER_VERSION}/ext/nginx
-EXTRA_PATCHES+= ${PATCHDIR}/extra-patch-passenger::build::nginx.rb
+EXTRA_PATCHES+= ${PATCHDIR}/extra-patch-passenger::build::nginx.rb \
+ ${PATCHDIR}/extra-patch-passenger::ext::common::Utils.cpp \
+ ${PATCHDIR}/extra-patch-passenger::ext::nginx::config
.endif
.if defined(WITH_SLOWFS_CACHE_MODULE)
@@ -487,8 +489,12 @@ post-patch:
@${REINPLACE_CMD} 's!-Wall!!g; \
s!#{PlatformInfo.debugging_cflags}!${CFLAGS}!g; \
s!-O2!!g; \
- 35s!true!false!' \
+ 42s!true!false!' \
${WRKDIR}/passenger-${PASSENGER_VERSION}/build/config.rb
+ @${REINPLACE_CMD} \
+ '258s!-I/usr/include/libev!!; \
+ 259s!-lev!!' \
+ ${WRKDIR}/passenger-${PASSENGER_VERSION}/build/common_library.rb
@${REINPLACE_CMD} 's!-lpthread!${PTHREAD_LIBS}!g' \
${WRKDIR}/passenger-${PASSENGER_VERSION}/lib/phusion_passenger/platform_info/compiler.rb
.endif