aboutsummaryrefslogtreecommitdiffstats
path: root/www/nginx/Makefile
diff options
context:
space:
mode:
authorosa <osa@FreeBSD.org>2010-01-11 15:43:39 +0800
committerosa <osa@FreeBSD.org>2010-01-11 15:43:39 +0800
commite6c928ffc8b6914148551478ef550b6e79a1e31b (patch)
tree5f41641cd524188e72d368f675032d835ae243fa /www/nginx/Makefile
parent977d594ec4dba6092cbb21ce860598279e3e56f0 (diff)
downloadfreebsd-ports-gnome-e6c928ffc8b6914148551478ef550b6e79a1e31b.tar.gz
freebsd-ports-gnome-e6c928ffc8b6914148551478ef550b6e79a1e31b.tar.zst
freebsd-ports-gnome-e6c928ffc8b6914148551478ef550b6e79a1e31b.zip
Accordingly add ngx_cache_purge-1.0, the module adding ability
to purge content from nginx's FastCGI and proxy caches. Do not bump PORTREVISIONs.
Diffstat (limited to 'www/nginx/Makefile')
-rw-r--r--www/nginx/Makefile8
1 files changed, 8 insertions, 0 deletions
diff --git a/www/nginx/Makefile b/www/nginx/Makefile
index 3fdeadeefff0..1ecfa934d73f 100644
--- a/www/nginx/Makefile
+++ b/www/nginx/Makefile
@@ -42,6 +42,7 @@ OPTIONS= DEBUG "Build with debug" off \
MAIL_SMTP_MODULE "Enable SMTP proxy module" off \
MAIL_SSL_MODULE "Enable mail_ssl module" off \
WWW "Enable html sample files" on \
+ CACHE_PURGE_MODULE "3rd party cache_purge module" off \
HTTP_ACCESSKEY_MODULE "3rd party http_accesskey module" off \
HTTP_AUTH_PAM_MODULE "3rd party http_auth_pam module" off \
HTTP_EVAL_MODULE "3rd party eval module" off \
@@ -152,6 +153,13 @@ CONFIGURE_ARGS+=--add-module=${WRKDIR}/ngx_http_auth_pam_module-${NGINX_AUTH_PAM
CONFIGURE_ARGS+=--without-http-cache
.endif
+.if defined(WITH_CACHE_PURGE_MODULE)
+NGINX_CACHE_PURGE_MODULE_VERSION= 1.0
+MASTER_SITES+= http://labs.frickle.com/files/:cache_purge
+DISTFILES+= ngx_cache_purge-${NGINX_CACHE_PURGE_MODULE_VERSION}.tar.gz:cache_purge
+CONFIGURE_ARGS+=--add-module=${WRKDIR}/ngx_cache_purge-${NGINX_CACHE_PURGE_MODULE_VERSION}
+.endif
+
.if defined(WITH_HTTP_DAV_MODULE)
CONFIGURE_ARGS+=--with-http_dav_module
.endif