aboutsummaryrefslogtreecommitdiffstats
path: root/www/nginx/Makefile
diff options
context:
space:
mode:
authorjoneum <joneum@FreeBSD.org>2018-01-20 23:22:09 +0800
committerjoneum <joneum@FreeBSD.org>2018-01-20 23:22:09 +0800
commit4ddd4223166cd76d459bf89e881266df8f613142 (patch)
tree7418f23882354226e443bebc20aeb5c10db42a8a /www/nginx/Makefile
parent2f7b967fb658db19a8760ab9f2cb4c384453ec31 (diff)
downloadfreebsd-ports-gnome-4ddd4223166cd76d459bf89e881266df8f613142.tar.gz
freebsd-ports-gnome-4ddd4223166cd76d459bf89e881266df8f613142.tar.zst
freebsd-ports-gnome-4ddd4223166cd76d459bf89e881266df8f613142.zip
Update third-party-module:
http-auth-nginx-module to 7e028a5 http_auth_ldap to 42d195d fastdfs-nginx-module to 85347be headers-more-nginx-module to 55fbdab nginx-dav-ext-module to 0.1.0 nginx-eval-module to 582bd25 nchan (aka push) to 1.1.14 nginx-push-stream-module to 0.5.4 nginx_tarantool to 9e38881 nginx-upload-progress-module to 0.9.2 nginx_upstream_check_module to 9aecf15 nginx-video-thumbextractor-module to 0.9.0 drizzle-nginx-module to 0.1.10 ngx_dynamic_upstream to 0.1.6 encrypted-session-nginx-module to 0.07 nginx-gridfs mongo-c-driver to 0.4 lua-nginx-module to 0.10.11 ModSecurity to 3.0.0 ModSecurity-nginx to c0ae166 naxsi to 0.55.3 rds-csv-nginx-module to 0.08 redis2-nginx-module to 0.14 ginx-rtmp-module to 1.2.1 set-misc-nginx-module to cda7e50 nginx-sflow-module to f15c87f nginx-http-shibboleth to f07bf3c ngx_small_light zo 0.9.2 srcache-nginx-module to 0.31 njs to 4ed8a0b ngx_brotli to 47550a2 - Bump PORTREVISION Approved by: mentors (implicit) MFH: 2018Q1
Diffstat (limited to 'www/nginx/Makefile')
-rw-r--r--www/nginx/Makefile62
1 files changed, 31 insertions, 31 deletions
diff --git a/www/nginx/Makefile b/www/nginx/Makefile
index 0d55fd3a3631..10136480a6dd 100644
--- a/www/nginx/Makefile
+++ b/www/nginx/Makefile
@@ -3,7 +3,7 @@
PORTNAME= nginx
PORTVERSION= 1.12.2
-PORTREVISION?= 4
+PORTREVISION?= 5
PORTEPOCH= 2
CATEGORIES= www
MASTER_SITES= http://nginx.org/download/
@@ -359,7 +359,7 @@ CONFIGURE_ARGS+=--add-module=${WRKSRC_auth_digest}
.endif
.if ${PORT_OPTIONS:MHTTP_AUTH_KRB5}
-GIT_HTTP_AUTH_KRB5_VERSION= 0c6ff3f
+GIT_HTTP_AUTH_KRB5_VERSION= 7e028a5
GH_ACCOUNT+= stnoonan:auth_krb5
GH_PROJECT+= spnego-http-auth-nginx-module:auth_krb5
GH_TAGNAME+= ${GIT_HTTP_AUTH_KRB5_VERSION}:auth_krb5
@@ -373,7 +373,7 @@ CONFIGURE_ARGS+=--add-module=${WRKSRC_auth_krb5}
.if ${PORT_OPTIONS:MHTTP_AUTH_LDAP}
# WWW: https://github.com/kvspb/nginx-auth-ldap
-GIT_HTTP_AUTH_LDAP_VERSION= dbcef31
+GIT_HTTP_AUTH_LDAP_VERSION= 42d195d
GH_ACCOUNT+= kvspb:http_auth_ldap
GH_PROJECT+= nginx-auth-ldap:http_auth_ldap
GH_TAGNAME+= ${GIT_HTTP_AUTH_LDAP_VERSION}:http_auth_ldap
@@ -475,7 +475,7 @@ EXTRA_PATCHES+= ${PATCHDIR}/extra-patch-ngx_http_echo_request_info.c
.endif
.if ${PORT_OPTIONS:MFASTDFS}
-NGINX_FASTDFS_VERSION= 5a8110f
+NGINX_FASTDFS_VERSION= 85347be
GH_ACCOUNT+= happyfish100:fastdfs
GH_PROJECT+= fastdfs-nginx-module:fastdfs
GH_TAGNAME+= ${NGINX_FASTDFS_VERSION}:fastdfs
@@ -491,7 +491,7 @@ CONFIGURE_ARGS+=--add-module=${WRKSRC_fastdfs}/src \
.endif
.if ${PORT_OPTIONS:MHEADERS_MORE}
-NGINX_HEADERS_MORE_VERSION= 84241e4
+NGINX_HEADERS_MORE_VERSION= 55fbdab
GH_ACCOUNT+= openresty:headers_more
GH_PROJECT+= headers-more-nginx-module:headers_more
GH_TAGNAME+= ${NGINX_HEADERS_MORE_VERSION}:headers_more
@@ -509,7 +509,7 @@ CONFIGURE_ARGS+=--with-http_dav_module
.if ${PORT_OPTIONS:MHTTP_DAV_EXT}
USE_HTTP_DAV= yes
LIB_DEPENDS+= libexpat.so:textproc/expat2
-NGINX_DAV_EXT_VERSION= 0.0.3
+NGINX_DAV_EXT_VERSION= 0.1.0
GH_ACCOUNT+= arut:dav_ext
GH_PROJECT+= nginx-dav-ext-module:dav_ext
GH_TAGNAME+= v${NGINX_DAV_EXT_VERSION}:dav_ext
@@ -517,7 +517,7 @@ CONFIGURE_ARGS+=--add-module=${WRKSRC_dav_ext}
.endif
.if ${PORT_OPTIONS:MHTTP_EVAL}
-NGINX_EVAL_VERSION= 342c812
+NGINX_EVAL_VERSION= 582bd25
GH_ACCOUNT+= openresty:eval
GH_PROJECT+= nginx-eval-module:eval
GH_TAGNAME+= ${NGINX_EVAL_VERSION}:eval
@@ -641,7 +641,7 @@ USES+= perl5
.endif
.if ${PORT_OPTIONS:MHTTP_PUSH}
-GIT_PUSH_VERSION= 0.99.16
+GIT_PUSH_VERSION= 1.1.14
GH_ACCOUNT+= slact:push
GH_PROJECT+= nchan:push
GH_TAGNAME+= v${GIT_PUSH_VERSION}:push
@@ -649,7 +649,7 @@ CONFIGURE_ARGS+=--add-module=${WRKSRC_push}
.endif
.if ${PORT_OPTIONS:MHTTP_PUSH_STREAM}
-NGINX_PUSH_STREAM_VERSION= 0.5.1
+NGINX_PUSH_STREAM_VERSION= 0.5.4
GH_ACCOUNT+= wandenberg:pushstream
GH_PROJECT+= nginx-push-stream-module:pushstream
GH_TAGNAME+= ${NGINX_PUSH_STREAM_VERSION}:pushstream
@@ -695,7 +695,7 @@ LIB_DEPENDS+= libmsgpuck.so:devel/msgpuck \
libyajl.so:devel/yajl
GH_ACCOUNT+= tarantool:nginx_tarantool
GH_PROJECT+= nginx_upstream_module:nginx_tarantool
-GH_TAGNAME+= 1278ee5:nginx_tarantool
+GH_TAGNAME+= 9e38881:nginx_tarantool
.if ${PORT_OPTIONS:MDSO}
CONFIGURE_ARGS+=--add-dynamic-module=${WRKSRC_nginx_tarantool}
.else
@@ -729,7 +729,7 @@ CONFIGURE_ARGS+=--add-module=${WRKSRC_upload}
.endif
.if ${PORT_OPTIONS:MHTTP_UPLOAD_PROGRESS}
-NGINX_UPLOADPROGRESS_VERSION= 0.9.0
+NGINX_UPLOADPROGRESS_VERSION= 0.9.2
GH_ACCOUNT+= masterzen:uploadprogress
GH_PROJECT+= nginx-upload-progress-module:uploadprogress
GH_TAGNAME+= v${NGINX_UPLOADPROGRESS_VERSION}:uploadprogress
@@ -738,7 +738,7 @@ CONFIGURE_ARGS+=--add-module=${WRKSRC_uploadprogress}
.if ${PORT_OPTIONS:MHTTP_UPSTREAM_CHECK}
# WWW: https://github.com/yaoweibin/nginx_upstream_check_module
-NGINX_UPSTREAM_CHECK_VERSION= 10782ea
+NGINX_UPSTREAM_CHECK_VERSION= 9aecf15
GH_ACCOUNT+= yaoweibin:upstreamcheck
GH_PROJECT+= nginx_upstream_check_module:upstreamcheck
GH_TAGNAME+= ${NGINX_UPSTREAM_CHECK_VERSION}:upstreamcheck
@@ -771,7 +771,7 @@ EXTRA_PATCHES+= ${PATCHDIR}/extra-patch-ngx_http_sticky_misc.c
.endif
.if ${PORT_OPTIONS:MHTTP_VIDEO_THUMBEXTRACTOR}
-NGINX_VIDEO_THUMBEXTRACTOR_VERSION= 0.7.0
+NGINX_VIDEO_THUMBEXTRACTOR_VERSION= 0.9.0
LIB_DEPENDS+= libavformat.so:multimedia/ffmpeg \
libavcodec.so:multimedia/ffmpeg \
libavutil.so:multimedia/ffmpeg \
@@ -804,7 +804,7 @@ CONFIGURE_ARGS+=--add-module=${WRKDIR}/mod_zip-${NGINX_ZIP_VERSION}
LIB_DEPENDS+= libdrizzle.so:databases/libdrizzle
CONFIGURE_ENV+= "LIBDRIZZLE_INC=${LOCALBASE}/include"
CONFIGURE_ENV+= "LIBDRIZZLE_LIB=${LOCALBASE}/lib"
-NGINX_DRIZZLE_VERSION= 0.1.9
+NGINX_DRIZZLE_VERSION= 0.1.10
GH_ACCOUNT+= openresty:drizzle
GH_PROJECT+= drizzle-nginx-module:drizzle
GH_TAGNAME+= v${NGINX_DRIZZLE_VERSION}:drizzle
@@ -814,7 +814,7 @@ EXTRA_PATCHES+= ${PATCHDIR}/extra-patch-openresty-drizzle-nginx-module-config \
.endif
.if ${PORT_OPTIONS:MDYNAMIC_UPSTREAM}
-NGINX_DYNAMIC_UPSTREAM_VERSION= 0.1.3
+NGINX_DYNAMIC_UPSTREAM_VERSION= 0.1.6
GH_ACCOUNT+= cubicdaiya:dyn_upstream
GH_PROJECT+= ngx_dynamic_upstream:dyn_upstream
GH_TAGNAME+= v${NGINX_DYNAMIC_UPSTREAM_VERSION}:dyn_upstream
@@ -835,7 +835,7 @@ CONFIGURE_ARGS+=--add-module=${WRKSRC_devel_kit}
.endif
.if ${PORT_OPTIONS:MENCRYPTSESSION}
-NGINX_ENCRYPTSESSION_VERSION= 0.06
+NGINX_ENCRYPTSESSION_VERSION= 0.07
GH_ACCOUNT+= openresty:encryptsession
GH_PROJECT+= encrypted-session-nginx-module:encryptsession
GH_TAGNAME+= v${NGINX_ENCRYPTSESSION_VERSION}:encryptsession
@@ -844,7 +844,7 @@ CONFIGURE_ARGS+=--add-module=${WRKSRC_encryptsession}
.if ${PORT_OPTIONS:MGRIDFS}
NGINX_GRIDFS_VERSION= 0.8
-MONGO_C_DRIVER_VERSION= 0.3.1
+MONGO_C_DRIVER_VERSION= 0.4
GH_ACCOUNT+= mdirolf:gridfs mongodb:mongo_c
GH_PROJECT+= nginx-gridfs:gridfs mongo-c-driver:mongo_c
GH_TAGNAME+= v${NGINX_GRIDFS_VERSION}:gridfs v${MONGO_C_DRIVER_VERSION}:mongo_c
@@ -863,7 +863,7 @@ CONFIGURE_ARGS+=--add-module=${WRKSRC_let}
LIB_DEPENDS+= libluajit-5.1.so:lang/luajit
CONFIGURE_ENV+= "LUAJIT_INC=${LOCALBASE}/include/luajit-2.0"
CONFIGURE_ENV+= "LUAJIT_LIB=${LOCALBASE}/lib"
-NGINX_LUA_VERSION= 0.10.8
+NGINX_LUA_VERSION= 0.10.11
GH_ACCOUNT+= openresty:lua
GH_PROJECT+= lua-nginx-module:lua
GH_TAGNAME+= v${NGINX_LUA_VERSION}:lua
@@ -892,7 +892,7 @@ CONFIGURE_ARGS+=--add-module=${WRKSRC_memc}
.endif
.if ${PORT_OPTIONS:MMODSECURITY}
-NGINX_MODSECURITY_VERSION= 2.9.1
+NGINX_MODSECURITY_VERSION= 3.0.0
LIB_DEPENDS+= libapr-1.so:devel/apr1 \
libcurl.so:ftp/curl \
libluajit-5.1.so:lang/luajit \
@@ -910,12 +910,12 @@ EXTRA_PATCHES+= ${PATCHDIR}/extra-patch-nginx-modsecurity-configure \
.if ${PORT_OPTIONS:MMODSECURITY_DEVEL}
LIB_DEPENDS+= libmodsecurity.so.3:www/mod_security-devel
-GH_TUPLE+= SpiderLabs:ModSecurity-nginx:abbf2c4:modsec
+GH_TUPLE+= SpiderLabs:ModSecurity-nginx:c0ae166:modsec
CONFIGURE_ARGS+=--add-module=${WRKSRC_modsec}
.endif
.if ${PORT_OPTIONS:MNAXSI}
-NGINX_NAXSI_VERSION= 0.54
+NGINX_NAXSI_VERSION= 0.55.3
GH_ACCOUNT+= nbs-system:naxsi
GH_PROJECT+= naxsi:naxsi
GH_TAGNAME+= ${NGINX_NAXSI_VERSION}:naxsi
@@ -959,7 +959,7 @@ EXTRA_PATCHES+= ${PATCHDIR}/extra-patch-ngx_postgres-config \
.endif
.if ${PORT_OPTIONS:MRDS_CSV}
-NGINX_RDS_CSV_VERSION= 0.07
+NGINX_RDS_CSV_VERSION= 0.08
GH_ACCOUNT+= openresty:rdscsv
GH_PROJECT+= rds-csv-nginx-module:rdscsv
GH_TAGNAME+= v${NGINX_RDS_CSV_VERSION}:rdscsv
@@ -975,7 +975,7 @@ CONFIGURE_ARGS+=--add-module=${WRKSRC_rdsjson}
.endif
.if ${PORT_OPTIONS:MREDIS2}
-NGINX_REDIS2_VERSION= 0.12
+NGINX_REDIS2_VERSION= 0.14
GH_ACCOUNT+= openresty:redis2
GH_PROJECT+= redis2-nginx-module:redis2
GH_TAGNAME+= v${NGINX_REDIS2_VERSION}:redis2
@@ -984,7 +984,7 @@ EXTRA_PATCHES+= ${PATCHDIR}/extra-patch-ngx_http_redis2_util.c
.endif
.if ${PORT_OPTIONS:MRTMP}
-NGINX_RTMP_VERSION= 1.1.8
+NGINX_RTMP_VERSION= 1.2.1
GH_ACCOUNT+= arut:rtmp
GH_PROJECT+= nginx-rtmp-module:rtmp
GH_TAGNAME+= v${NGINX_RTMP_VERSION}:rtmp
@@ -992,7 +992,7 @@ CONFIGURE_ARGS+=--add-module=${WRKSRC_rtmp}
.endif
.if ${PORT_OPTIONS:MSET_MISC}
-NGINX_SET_MISC_VERSION= f808ef4
+NGINX_SET_MISC_VERSION= cda7e50
GH_ACCOUNT+= openresty:setmisc
GH_PROJECT+= set-misc-nginx-module:setmisc
GH_TAGNAME+= ${NGINX_SET_MISC_VERSION}:setmisc
@@ -1004,7 +1004,7 @@ CONFIGURE_ARGS+=--add-module=${WRKSRC_setmisc}
.endif
.if ${PORT_OPTIONS:MSFLOW}
-NGINX_SFLOW_VERSION= 543c72a
+NGINX_SFLOW_VERSION= f15c87f
GH_ACCOUNT+= sflow:sflow
GH_PROJECT+= nginx-sflow-module:sflow
GH_TAGNAME+= ${NGINX_SFLOW_VERSION}:sflow
@@ -1014,7 +1014,7 @@ EXTRA_PATCHES+= ${PATCHDIR}/extra-patch-ngx_http_sflow_config.c \
.endif
.if ${PORT_OPTIONS:MSHIBBOLETH}
-GIT_SHIBBOLETH_VERSION= 4f1119b
+GIT_SHIBBOLETH_VERSION= f07bf3c
GH_ACCOUNT+= nginx-shib:shib
GH_PROJECT+= nginx-http-shibboleth:shib
GH_TAGNAME+= ${GIT_SHIBBOLETH_VERSION}:shib
@@ -1029,7 +1029,7 @@ CONFIGURE_ARGS+=--add-module=${WRKDIR}/ngx_slowfs_cache-${NGINX_SLOWFS_CACHE_VER
.endif
.if ${PORT_OPTIONS:MSMALL_LIGHT}
-NGINX_SMALL_LIGHT_VERSION= 0.8.0
+NGINX_SMALL_LIGHT_VERSION= 0.9.2
LIB_DEPENDS+= ${IMAGEMAGICK_LIB_DEPENDS} \
libpcre.so:devel/pcre
GH_ACCOUNT+= cubicdaiya:small_light
@@ -1043,7 +1043,7 @@ CONFIGURE_ARGS+=--add-module=${WRKSRC_small_light}
.endif
.if ${PORT_OPTIONS:MSRCACHE}
-NGINX_SRCACHE_VERSION= 0.30
+NGINX_SRCACHE_VERSION= 0.31
GH_ACCOUNT+= openresty:srcache
GH_PROJECT+= srcache-nginx-module:srcache
GH_TAGNAME+= v${NGINX_SRCACHE_VERSION}:srcache
@@ -1067,7 +1067,7 @@ CONFIGURE_ARGS+=--with-http_v2_module
.if ${PORT_OPTIONS:MNJS}
GH_ACCOUNT+= nginx:njs
GH_PROJECT+= njs:njs
-GH_TAGNAME+= 753ebe6:njs
+GH_TAGNAME+= 4ed8a0b:njs
.if ${PORT_OPTIONS:MDSO}
CONFIGURE_ARGS+=--add-dynamic-module=${WRKSRC_njs}/nginx
.else
@@ -1141,7 +1141,7 @@ CONFIGURE_ARGS+=--add-module=${WRKSRC_arrayvar}
.endif
.if ${PORT_OPTIONS:MBROTLI}
-NGINX_BROTLI_VERSION= 990d925
+NGINX_BROTLI_VERSION= 47550a2
LIB_DEPENDS+= libbrotlicommon.so:archivers/brotli
GH_ACCOUNT+= eustas:brotli
GH_PROJECT+= ngx_brotli:brotli