aboutsummaryrefslogtreecommitdiffstats
path: root/www/nginx/Makefile
diff options
context:
space:
mode:
authorjoneum <joneum@FreeBSD.org>2017-12-02 06:52:27 +0800
committerjoneum <joneum@FreeBSD.org>2017-12-02 06:52:27 +0800
commitb72e2113549eed2d9c2857339bee05b9467732b5 (patch)
tree0a2abd27c3f3cabcd59fbec296f9eae8d48892d6 /www/nginx/Makefile
parent61bf553d148ea420b1b4ecaeeaff97720728ddff (diff)
downloadfreebsd-ports-gnome-b72e2113549eed2d9c2857339bee05b9467732b5.tar.gz
freebsd-ports-gnome-b72e2113549eed2d9c2857339bee05b9467732b5.tar.zst
freebsd-ports-gnome-b72e2113549eed2d9c2857339bee05b9467732b5.zip
www/nginx: Update brotli module
- Switch to fork that uses new brotli ABI The upstream brotli module hasn't been updated for over a year even though it's been broken for over a year with later brotli releases. There's a fork that does update which uses the new brotli abi. This patch is based on the fork. Requires some patching to the config file as it depends on an old upstream brotli snapshot to be in the src dir. PR: 224000 Reported by: brnrd Approved by: tcberner (mentor) Differential Revision: https://reviews.freebsd.org/D13319
Diffstat (limited to 'www/nginx/Makefile')
-rw-r--r--www/nginx/Makefile12
1 files changed, 9 insertions, 3 deletions
diff --git a/www/nginx/Makefile b/www/nginx/Makefile
index 8d6555e88a92..d0298fddd436 100644
--- a/www/nginx/Makefile
+++ b/www/nginx/Makefile
@@ -3,7 +3,7 @@
PORTNAME= nginx
PORTVERSION= 1.12.2
-PORTREVISION?= 1
+PORTREVISION?= 2
PORTEPOCH= 2
CATEGORIES= www
MASTER_SITES= http://nginx.org/download/
@@ -1141,11 +1141,12 @@ CONFIGURE_ARGS+=--add-module=${WRKSRC_arrayvar}
.endif
.if ${PORT_OPTIONS:MBROTLI}
-NGINX_BROTLI_VERSION= 12529813
+NGINX_BROTLI_VERSION= 990d925
LIB_DEPENDS+= libbrotlicommon.so:archivers/brotli
-GH_ACCOUNT+= google:brotli
+GH_ACCOUNT+= eustas:brotli
GH_PROJECT+= ngx_brotli:brotli
GH_TAGNAME+= ${NGINX_BROTLI_VERSION}:brotli
+EXTRA_PATCHES+= ${PATCHDIR}/extra-patch-brotli_config
.if ${PORT_OPTIONS:MDSO}
CONFIGURE_ARGS+=--add-dynamic-module=${WRKSRC_brotli}
.else
@@ -1269,6 +1270,11 @@ post-patch:
's!%%PREFIX%%!${LOCALBASE}!g' \
${WRKSRC_nginx_tarantool}/config
.endif
+.if ${PORT_OPTIONS:MBROTLI}
+ @${REINPLACE_CMD} -E \
+ 's!^brotli=.*!brotli="${LOCALBASE}"!' \
+ ${WRKSRC_brotli}/config
+.endif
pre-configure:
.if ${PORT_OPTIONS:MMODSECURITY}