aboutsummaryrefslogtreecommitdiffstats
path: root/www/nginx/Makefile
diff options
context:
space:
mode:
authorjoneum <joneum@FreeBSD.org>2017-08-04 19:04:18 +0800
committerjoneum <joneum@FreeBSD.org>2017-08-04 19:04:18 +0800
commitf385b6ffe419234c37ff21d88d8fd0b122595cb9 (patch)
tree0bf5201c616d5e4737998f84d0afb5ca7b3769df /www/nginx/Makefile
parent9a52961379ceec0cc612f3dfe185723b0cd4e94f (diff)
downloadfreebsd-ports-gnome-f385b6ffe419234c37ff21d88d8fd0b122595cb9.tar.gz
freebsd-ports-gnome-f385b6ffe419234c37ff21d88d8fd0b122595cb9.tar.zst
freebsd-ports-gnome-f385b6ffe419234c37ff21d88d8fd0b122595cb9.zip
- Add mod_security v3 support
This update adds support for mod_security version 3 to nginx. ModSecurity v3 is the next version of ModSecurity currently under development. It is developed as a library independent of webservers and can be used from different connectors such as the ModSecurity-nginx module used by this port PR: 220353 Reported by: Marius Halden <marius.h@lden.org> Approved by: miwi (mentor) Differential Revision: https://reviews.freebsd.org/D11778
Diffstat (limited to 'www/nginx/Makefile')
-rw-r--r--www/nginx/Makefile11
1 files changed, 10 insertions, 1 deletions
diff --git a/www/nginx/Makefile b/www/nginx/Makefile
index b48dbab8eb0e..bf4dcdd67037 100644
--- a/www/nginx/Makefile
+++ b/www/nginx/Makefile
@@ -3,6 +3,7 @@
PORTNAME= nginx
PORTVERSION= 1.12.1
+PORTREVISION?= 1
PORTEPOCH= 2
CATEGORIES= www
MASTER_SITES= http://nginx.org/download/
@@ -112,6 +113,7 @@ OPTIONS_DEFINE= \
LUA \
MEMC \
MODSECURITY \
+ MODSECURITY_DEVEL \
NAXSI \
PASSENGER \
POSTGRES \
@@ -226,6 +228,7 @@ LET_DESC= 3rd party let module
LUA_DESC= 3rd party lua module
MEMC_DESC= 3rd party memc (memcached) module
MODSECURITY_DESC= 3rd party mod_security module
+MODSECURITY_DEVEL_DESC= 3rd party mod_security v3 module
NAXSI_DESC= 3rd party naxsi module
PASSENGER_DESC= 3rd party passenger module
POSTGRES_DESC= 3rd party postgres module
@@ -770,7 +773,7 @@ EXTRA_PATCHES+= ${PATCHDIR}/extra-patch-ngx_http_sticky_misc.c
.if ${PORT_OPTIONS:MHTTP_VIDEO_THUMBEXTRACTOR}
NGINX_VIDEO_THUMBEXTRACTOR_VERSION= 0.7.0
-LIB_DEPENDS+= libavformat.so:multimedia/ffmpeg \
+LIB_DEPENDS+= libavformat.so:multimedia/ffmpeg \
libavcodec.so:multimedia/ffmpeg \
libavutil.so:multimedia/ffmpeg \
libswscale.so:multimedia/ffmpeg
@@ -906,6 +909,12 @@ EXTRA_PATCHES+= ${PATCHDIR}/extra-patch-nginx-modsecurity-configure \
${PATCHDIR}/extra-patch-ngx_http_modsecurity.c
.endif
+.if ${PORT_OPTIONS:MMODSECURITY_DEVEL}
+LIB_DEPENDS+= libmodsecurity.so.3:www/mod_security-devel
+GH_TUPLE+= SiderLaps:ModSecurity-nginx:abbf2c4:modsec
+CONFIGURE_ARGS+=--add-dynamic-module=${WRKSRC_modsec}
+.endif
+
.if ${PORT_OPTIONS:MNAXSI}
NGINX_NAXSI_VERSION= 0.54
GH_ACCOUNT+= nbs-system:naxsi