aboutsummaryrefslogtreecommitdiffstats
path: root/www/nginx
diff options
context:
space:
mode:
authorosa <osa@FreeBSD.org>2010-02-28 03:56:07 +0800
committerosa <osa@FreeBSD.org>2010-02-28 03:56:07 +0800
commit3801102831e38df901f5177b7a5796180e517454 (patch)
tree8540bab4e4c85938b73907ae9555a15dd2358163 /www/nginx
parenta1a19e395d85c9ef0d8ad02052f1db4af31035f0 (diff)
downloadfreebsd-ports-gnome-3801102831e38df901f5177b7a5796180e517454.tar.gz
freebsd-ports-gnome-3801102831e38df901f5177b7a5796180e517454.tar.zst
freebsd-ports-gnome-3801102831e38df901f5177b7a5796180e517454.zip
Accordingly add third party auth_request module, version 0.1.
Do not bump PORTREVISIONs. Feature safe: yes
Diffstat (limited to 'www/nginx')
-rw-r--r--www/nginx/Makefile8
-rw-r--r--www/nginx/distinfo3
2 files changed, 11 insertions, 0 deletions
diff --git a/www/nginx/Makefile b/www/nginx/Makefile
index 094484da7ffd..91df39d7ad57 100644
--- a/www/nginx/Makefile
+++ b/www/nginx/Makefile
@@ -47,6 +47,7 @@ OPTIONS= DEBUG "Build with debug" off \
HTTP_ACCEPT_LANGUAGE "3rd party accept_language module" off \
HTTP_ACCESSKEY_MODULE "3rd party http_accesskey module" off \
HTTP_AUTH_PAM_MODULE "3rd party http_auth_pam module" off \
+ HTTP_AUTH_REQ_MODULE "3rd party http_auth_request module" off \
HTTP_EVAL_MODULE "3rd party eval module" off \
HTTP_FANCYINDEX_MODULE "3rd party http_fancyindex module" off \
HTTP_GUNZIP_FILTER "3rd party http_gunzip_filter module" off \
@@ -156,6 +157,13 @@ DISTFILES+= ngx_http_auth_pam_module-${NGINX_AUTH_PAM_MODULE_VERSION}.tar.gz:aut
CONFIGURE_ARGS+=--add-module=${WRKDIR}/ngx_http_auth_pam_module-${NGINX_AUTH_PAM_MODULE_VERSION}
.endif
+.if defined(WITH_HTTP_AUTH_REQ_MODULE)
+NGINX_AUTH_REQ_MODULE_VERSION= 0.1
+MASTER_SITES+= http://mdounin.ru/files/:auth_request
+DISTFILES+= ngx_http_auth_request-${NGINX_AUTH_REQ_MODULE_VERSION}.tar.gz:auth_request
+CONFIGURE_ARGS+=--add-module=${WRKDIR}/ngx_http_auth_request-${NGINX_AUTH_REQ_MODULE_VERSION}
+.endif
+
.if defined(WITHOUT_HTTP_CACHE_MODULE)
CONFIGURE_ARGS+=--without-http-cache
.endif
diff --git a/www/nginx/distinfo b/www/nginx/distinfo
index bd0b920348dd..ddda22f7e271 100644
--- a/www/nginx/distinfo
+++ b/www/nginx/distinfo
@@ -10,6 +10,9 @@ SIZE (nginx-accesskey-2.0.3.tar.gz) = 2632
MD5 (ngx_http_auth_pam_module-1.1.tar.gz) = 4e30d7481f6cb90bbf6c43c50b5c8502
SHA256 (ngx_http_auth_pam_module-1.1.tar.gz) = ea9da5f106b952729398248cddabbe25f7a5752993e91c9b8252dbc2b03b8ecd
SIZE (ngx_http_auth_pam_module-1.1.tar.gz) = 5193
+MD5 (ngx_http_auth_request-0.1.tar.gz) = c0ed1610097017813e6468e7cca28af7
+SHA256 (ngx_http_auth_request-0.1.tar.gz) = ccaafc2afa4b4c98dc2b7555fc61774cfbd4f98edca87eb172ae3ec36a49f263
+SIZE (ngx_http_auth_request-0.1.tar.gz) = 4291
MD5 (ngx_cache_purge-1.0.tar.gz) = ec1dabaa8321530c100f9baf65370294
SHA256 (ngx_cache_purge-1.0.tar.gz) = 6f4229a4edc0e8b914dc89c0a3c5b6a746469a3f9e5942b3d025dbe6a5ab2d13
SIZE (ngx_cache_purge-1.0.tar.gz) = 4569